summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/zchunk/files/clang.patch35
-rw-r--r--meta-oe/recipes-support/zchunk/zchunk_1.2.0.bb22
-rw-r--r--meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb25
3 files changed, 60 insertions, 22 deletions
diff --git a/meta-oe/recipes-support/zchunk/files/clang.patch b/meta-oe/recipes-support/zchunk/files/clang.patch
new file mode 100644
index 0000000000..86faf4aac7
--- /dev/null
+++ b/meta-oe/recipes-support/zchunk/files/clang.patch
@@ -0,0 +1,35 @@
1From e69d907c3fe8765ce50ce1258648ebc8283ef8a7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 22 Feb 2023 14:55:07 -0800
4Subject: [PATCH] meson: Use global function in argp check
5
6clang is optimizing away parse_opt() since its marked static and not
7used in main(), make life a bit harder for clang :)
8removing static now emits the global symbols to be resolved during link
9and when libargp is missing the error is thrown rightly
10
11riscv64-yoe-linux-musl-ld: /tmp/a-5ba039.o: in function `.Lpcrel_hi0':
12a.c:(.text+0x44): undefined reference to `argp_state_help'
13clang-16: error: linker command failed with exit code 1 (use -v to see invocation)
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16
17Upstream-Status: Submitted [https://github.com/zchunk/zchunk/pull/92/]
18Signed-off-by: Ross Burton <ross.burton@arm.com>
19---
20 meson.build | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-)
22
23diff --git a/meson.build b/meson.build
24index 3b92d58..ab54abd 100644
25--- a/meson.build
26+++ b/meson.build
27@@ -57,7 +57,7 @@ if host_machine.system() == 'windows'
28 endif
29
30 # argp-standalone dependency (if required)
31-if build_machine.system() == 'windows' or build_machine.system() == 'darwin' or build_machine.system() == 'freebsd' or not cc.links('#include <argp.h>\nstatic error_t parse_opt (int key, char *arg, struct argp_state *state) { argp_usage(state); return 0; }; void main() {}')
32+if build_machine.system() == 'windows' or build_machine.system() == 'darwin' or build_machine.system() == 'freebsd' or not cc.links('#include <argp.h>\nerror_t parse_opt (int key, char *arg, struct argp_state *state) { argp_usage(state); return 0; }; void main() {}')
33 argplib = cc.find_library('argp', has_headers : ['argp.h'], required: false)
34 if not argplib.found()
35 argplib = dependency('argp-standalone')
diff --git a/meta-oe/recipes-support/zchunk/zchunk_1.2.0.bb b/meta-oe/recipes-support/zchunk/zchunk_1.2.0.bb
deleted file mode 100644
index 0baea5032a..0000000000
--- a/meta-oe/recipes-support/zchunk/zchunk_1.2.0.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression"
2AUTHOR = "Jonathan Dieter"
3
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242"
6
7SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main"
8
9SRCREV = "dd6a30a1e4e8b738b0cafc682f3c00e7706134e5"
10S = "${WORKDIR}/git"
11
12DEPENDS = "\
13 curl \
14 zstd \
15 "
16
17DEPENDS:append:libc-musl = " argp-standalone"
18LDFLAGS:append:libc-musl = " -largp"
19
20inherit meson pkgconfig
21
22BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb b/meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb
new file mode 100644
index 0000000000..b4fd027603
--- /dev/null
+++ b/meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression"
2AUTHOR = "Jonathan Dieter"
3
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242"
6
7SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main \
8 file://clang.patch"
9
10SRCREV = "0bed8496262a71beadccd4e562bdac093ef6e06f"
11S = "${WORKDIR}/git"
12
13DEPENDS = "zstd"
14DEPENDS:append:libc-musl = " argp-standalone"
15
16inherit meson pkgconfig lib_package
17
18PACKAGECONFIG ??= "openssl zckdl"
19
20# zckdl gets packaged into zchunk-bin
21PACKAGECONFIG[zckdl] = "-Dwith-curl=enabled,-Dwith-curl=disabled,curl"
22# Use OpenSSL primitives for SHA
23PACKAGECONFIG[openssl] = "-Dwith-openssl=enabled,-Dwith-openssl=disabled,openssl"
24
25BBCLASSEXTEND = "native nativesdk"