summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.26.0.bb14
2 files changed, 3 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow/run-ptest b/meta-python/recipes-devtools/python/python3-marshmallow/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-marshmallow/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.26.0.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.26.0.bb
index a421a93e4c..bde3819379 100644
--- a/meta-python/recipes-devtools/python/python3-marshmallow_3.26.0.bb
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.26.0.bb
@@ -8,25 +8,17 @@ LIC_FILES_CHKSUM = "\
8 8
9SRC_URI[sha256sum] = "eb36762a1cc76d7abf831e18a3a1b26d3d481bbc74581b8e532a3d3a8115e1cb" 9SRC_URI[sha256sum] = "eb36762a1cc76d7abf831e18a3a1b26d3d481bbc74581b8e532a3d3a8115e1cb"
10 10
11inherit python_flit_core pypi ptest 11inherit python_flit_core pypi ptest-python-pytest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16 12
17RDEPENDS:${PN}-ptest += " \ 13RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-pytz \ 14 python3-pytz \
20 python3-simplejson \ 15 python3-simplejson \
21 python3-unittest-automake-output \
22 python3-zoneinfo \ 16 python3-zoneinfo \
23 python3-tzdata \ 17 python3-tzdata \
24" 18"
25 19
26do_install_ptest() { 20do_install_ptest:append () {
27 install -d ${D}${PTEST_PATH}/tests 21 rm -rf ${D}${PTEST_PATH}/tests/mypy_test_cases
28 rm -rf ${S}/tests/mypy_test_cases
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30} 22}
31 23
32RDEPENDS:${PN} += " \ 24RDEPENDS:${PN} += " \