diff options
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod.inc | 21 | ||||
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb | 22 |
2 files changed, 22 insertions, 21 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc new file mode 100644 index 0000000000..cd77506235 --- /dev/null +++ b/meta-oe/recipes-support/libgpiod/libgpiod.inc | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "C library and tools for interacting with the linux GPIO character device" | ||
2 | |||
3 | LICENSE = "LGPLv2.1+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de" | ||
5 | |||
6 | SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | # enable tools | ||
11 | PACKAGECONFIG ?= "tools" | ||
12 | |||
13 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | ||
14 | PACKAGECONFIG[tools] = "--enable-tools,--disable-tools," | ||
15 | |||
16 | PACKAGES =+ " ${PN}-tools" | ||
17 | |||
18 | FILES_${PN}-tools = "${bindir}/*" | ||
19 | |||
20 | RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}" | ||
21 | RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}" | ||
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb index 20068894eb..ea785ad0ca 100644 --- a/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb +++ b/meta-oe/recipes-support/libgpiod/libgpiod_0.3.2.bb | |||
@@ -1,24 +1,4 @@ | |||
1 | SUMMARY = "C library and tools for interacting with the linux GPIO character device" | 1 | require libgpiod.inc |
2 | |||
3 | LICENSE = "LGPLv2.1+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de" | ||
5 | |||
6 | SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz" | ||
7 | 2 | ||
8 | SRC_URI[md5sum] = "9c1966bea7dffd59bd099a8b2930e2ea" | 3 | SRC_URI[md5sum] = "9c1966bea7dffd59bd099a8b2930e2ea" |
9 | SRC_URI[sha256sum] = "50c7862428ca90b58672e2475aea66d33a6fc86c6bab1928c0660f3aedf44a37" | 4 | SRC_URI[sha256sum] = "50c7862428ca90b58672e2475aea66d33a6fc86c6bab1928c0660f3aedf44a37" |
10 | |||
11 | inherit autotools pkgconfig | ||
12 | |||
13 | # enable tools | ||
14 | PACKAGECONFIG ?= "tools" | ||
15 | |||
16 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" | ||
17 | PACKAGECONFIG[tools] = "--enable-tools,--disable-tools," | ||
18 | |||
19 | PACKAGES =+ " ${PN}-tools" | ||
20 | |||
21 | FILES_${PN}-tools = "${bindir}/*" | ||
22 | |||
23 | RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}" | ||
24 | RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}" | ||