summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch30
-rw-r--r--meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb34
2 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch b/meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch
new file mode 100644
index 0000000000..b57e39fbcc
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch
@@ -0,0 +1,30 @@
1From 2ddc97b30792817d162f51ec3818376aefbf184e Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 3 May 2017 02:05:33 -0400
4Subject: [PATCH] remove python2 support
5
6We use python3 rather than python2 support
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11---
12 src/python/Makefile.am | 5 -----
13 1 file changed, 5 deletions(-)
14
15diff --git a/src/python/Makefile.am b/src/python/Makefile.am
16index 567d0d7..8d9f446 100644
17--- a/src/python/Makefile.am
18+++ b/src/python/Makefile.am
19@@ -1,8 +1,3 @@
20-pylibdir = $(shell python -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(1,0,prefix='${exec_prefix}'))")
21-
22-pybytesizedir = $(pylibdir)/bytesize
23-dist_pybytesize_DATA = bytesize.py __init__.py
24-
25 if WITH_PYTHON3
26 py3libdir = $(shell python3 -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(1,0,prefix='${exec_prefix}'))")
27 py3bytesizedir = $(py3libdir)/bytesize
28--
292.8.1
30
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb b/meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb
new file mode 100644
index 0000000000..6903021490
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "The goal of this project is to provide a tiny library that would \
2facilitate the common operations with sizes in bytes."
3HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
4LICENSE = "LGPLv2+"
5SECTION = "devel/lib"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
12SRCREV = "369127c0edbba7d1a4e2e02486375dd9d379524f"
13PV = "0.10+git${SRCPV}"
14SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
15 file://0001-remove-python2-support.patch \
16"
17
18inherit gettext autotools python3native
19
20DEPENDS += " \
21 libpcre \
22 gmp \
23 mpfr \
24"
25
26FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
27
28PACKAGECONFIG ??= "python3"
29PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
30PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
31
32EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
33
34