diff options
-rw-r--r-- | meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb | 34 |
2 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch b/meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch new file mode 100644 index 0000000000..b57e39fbcc --- /dev/null +++ b/meta-oe/recipes-support/libbytesize/files/0001-remove-python2-support.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 2ddc97b30792817d162f51ec3818376aefbf184e Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Wed, 3 May 2017 02:05:33 -0400 | ||
4 | Subject: [PATCH] remove python2 support | ||
5 | |||
6 | We use python3 rather than python2 support | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
11 | --- | ||
12 | src/python/Makefile.am | 5 ----- | ||
13 | 1 file changed, 5 deletions(-) | ||
14 | |||
15 | diff --git a/src/python/Makefile.am b/src/python/Makefile.am | ||
16 | index 567d0d7..8d9f446 100644 | ||
17 | --- a/src/python/Makefile.am | ||
18 | +++ b/src/python/Makefile.am | ||
19 | @@ -1,8 +1,3 @@ | ||
20 | -pylibdir = $(shell python -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(1,0,prefix='${exec_prefix}'))") | ||
21 | - | ||
22 | -pybytesizedir = $(pylibdir)/bytesize | ||
23 | -dist_pybytesize_DATA = bytesize.py __init__.py | ||
24 | - | ||
25 | if WITH_PYTHON3 | ||
26 | py3libdir = $(shell python3 -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_lib(1,0,prefix='${exec_prefix}'))") | ||
27 | py3bytesizedir = $(py3libdir)/bytesize | ||
28 | -- | ||
29 | 2.8.1 | ||
30 | |||
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb b/meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb new file mode 100644 index 0000000000..6903021490 --- /dev/null +++ b/meta-oe/recipes-support/libbytesize/libbytesize_0.10.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | DESCRIPTION = "The goal of this project is to provide a tiny library that would \ | ||
2 | facilitate the common operations with sizes in bytes." | ||
3 | HOMEPAGE = "https://github.com/rhinstaller/libbytesize" | ||
4 | LICENSE = "LGPLv2+" | ||
5 | SECTION = "devel/lib" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | B = "${S}" | ||
11 | |||
12 | SRCREV = "369127c0edbba7d1a4e2e02486375dd9d379524f" | ||
13 | PV = "0.10+git${SRCPV}" | ||
14 | SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \ | ||
15 | file://0001-remove-python2-support.patch \ | ||
16 | " | ||
17 | |||
18 | inherit gettext autotools python3native | ||
19 | |||
20 | DEPENDS += " \ | ||
21 | libpcre \ | ||
22 | gmp \ | ||
23 | mpfr \ | ||
24 | " | ||
25 | |||
26 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize" | ||
27 | |||
28 | PACKAGECONFIG ??= "python3" | ||
29 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" | ||
30 | PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" | ||
31 | |||
32 | EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}" | ||
33 | |||
34 | |||