diff options
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-extended/ostree/ostree_2022.5.bb | 1 |
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch b/meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch new file mode 100644 index 0000000000..248dcf49b8 --- /dev/null +++ b/meta-oe/recipes-extended/ostree/ostree/0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From bd325061dc9585886f7e60e58d9fc0c8b37e71db Mon Sep 17 00:00:00 2001 | ||
2 | From: Colin Walters <walters@verbum.org> | ||
3 | Date: Wed, 9 Nov 2022 11:18:36 -0500 | ||
4 | Subject: [PATCH] deploy: Don't rebuild selinux policy on first deployment | ||
5 | |||
6 | Basically, it should not be necessary - the policy should be | ||
7 | up-to-date. We don't want to force on continual policy rebuilds. | ||
8 | |||
9 | Even trying to run bwrap when we're *not* in a booted | ||
10 | root can cause failures in nested containerization scenarios. | ||
11 | |||
12 | Closes: https://github.com/ostreedev/ostree/issues/2758 | ||
13 | |||
14 | Upstream-Status: Backport | ||
15 | [https://github.com/ostreedev/ostree/commit/bd325061dc9585886f7e60e58d9fc0c8b37e71db] | ||
16 | |||
17 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
18 | --- | ||
19 | src/libostree/ostree-sysroot-deploy.c | 6 +++--- | ||
20 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/src/libostree/ostree-sysroot-deploy.c b/src/libostree/ostree-sysroot-deploy.c | ||
23 | index f27ae0e1..26b07080 100644 | ||
24 | --- a/src/libostree/ostree-sysroot-deploy.c | ||
25 | +++ b/src/libostree/ostree-sysroot-deploy.c | ||
26 | @@ -2987,12 +2987,12 @@ sysroot_finalize_deployment (OstreeSysroot *self, | ||
27 | if (!merge_configuration_from (self, merge_deployment, deployment, deployment_dfd, | ||
28 | cancellable, error)) | ||
29 | return FALSE; | ||
30 | - } | ||
31 | |||
32 | #ifdef HAVE_SELINUX | ||
33 | - if (!sysroot_finalize_selinux_policy(deployment_dfd, error)) | ||
34 | - return FALSE; | ||
35 | + if (!sysroot_finalize_selinux_policy (deployment_dfd, error)) | ||
36 | + return FALSE; | ||
37 | #endif /* HAVE_SELINUX */ | ||
38 | + } | ||
39 | |||
40 | const char *osdeploypath = glnx_strjoina ("ostree/deploy/", ostree_deployment_get_osname (deployment)); | ||
41 | glnx_autofd int os_deploy_dfd = -1; | ||
42 | -- | ||
43 | 2.25.1 | ||
44 | |||
diff --git a/meta-oe/recipes-extended/ostree/ostree_2022.5.bb b/meta-oe/recipes-extended/ostree/ostree_2022.5.bb index 699b693d20..1a0987361e 100644 --- a/meta-oe/recipes-extended/ostree/ostree_2022.5.bb +++ b/meta-oe/recipes-extended/ostree/ostree_2022.5.bb | |||
@@ -22,6 +22,7 @@ SRC_URI = " \ | |||
22 | file://0001-Remove-unused-linux-fs.h-includes.patch \ | 22 | file://0001-Remove-unused-linux-fs.h-includes.patch \ |
23 | file://0001-libostree-Remove-including-sys-mount.h.patch \ | 23 | file://0001-libostree-Remove-including-sys-mount.h.patch \ |
24 | file://0001-s390x-se-luks-gencpio-There-is-no-bashism.patch \ | 24 | file://0001-s390x-se-luks-gencpio-There-is-no-bashism.patch \ |
25 | file://0001-deploy-Don-t-rebuild-selinux-policy-on-first-deploym.patch \ | ||
25 | file://run-ptest \ | 26 | file://run-ptest \ |
26 | " | 27 | " |
27 | SRCREV = "15740d042c9c5258a1c082b5e228cf6f115edbb0" | 28 | SRCREV = "15740d042c9c5258a1c082b5e228cf6f115edbb0" |