diff options
3 files changed, 12 insertions, 63 deletions
diff --git a/meta-oe/recipes-crypto/libsodium/libsodium/0001-fix-aarch64-Move-target-pragma-after-arm_neon.h-incl.patch b/meta-oe/recipes-crypto/libsodium/libsodium/0001-fix-aarch64-Move-target-pragma-after-arm_neon.h-incl.patch deleted file mode 100644 index 7a6fae7997..0000000000 --- a/meta-oe/recipes-crypto/libsodium/libsodium/0001-fix-aarch64-Move-target-pragma-after-arm_neon.h-incl.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From d3253310f7c0fc0f1aad6864e3b57958ea1bb9c5 Mon Sep 17 00:00:00 2001 | ||
2 | From: tux3 <barrdetwix@gmail.com> | ||
3 | Date: Mon, 16 Oct 2023 16:42:04 +0200 | ||
4 | Subject: [PATCH] fix(aarch64): Move target #pragma after arm_neon.h include | ||
5 | |||
6 | Fix per https://github.com/android/ndk/issues/1945 | ||
7 | |||
8 | If the pragma is done before the header include, | ||
9 | in NDK 26 the attribute may apply to the functions in arm_neon.h | ||
10 | |||
11 | Upstream-Status: Backport [https://github.com/jedisct1/libsodium/pull/1321] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | .../aes256gcm/armcrypto/aead_aes256gcm_armcrypto.c | 12 ++++++------ | ||
15 | 1 file changed, 6 insertions(+), 6 deletions(-) | ||
16 | |||
17 | diff --git a/src/libsodium/crypto_aead/aes256gcm/armcrypto/aead_aes256gcm_armcrypto.c b/src/libsodium/crypto_aead/aes256gcm/armcrypto/aead_aes256gcm_armcrypto.c | ||
18 | index 0a5a128..aa76f5c 100644 | ||
19 | --- a/src/libsodium/crypto_aead/aes256gcm/armcrypto/aead_aes256gcm_armcrypto.c | ||
20 | +++ b/src/libsodium/crypto_aead/aes256gcm/armcrypto/aead_aes256gcm_armcrypto.c | ||
21 | @@ -19,12 +19,6 @@ | ||
22 | #define __vectorcall | ||
23 | #endif | ||
24 | |||
25 | -#ifdef __clang__ | ||
26 | -#pragma clang attribute push(__attribute__((target("neon,crypto,aes"))), apply_to = function) | ||
27 | -#elif defined(__GNUC__) | ||
28 | -#pragma GCC target("+simd+crypto") | ||
29 | -#endif | ||
30 | - | ||
31 | #ifndef __ARM_FEATURE_CRYPTO | ||
32 | #define __ARM_FEATURE_CRYPTO 1 | ||
33 | #endif | ||
34 | @@ -34,6 +28,12 @@ | ||
35 | |||
36 | #include <arm_neon.h> | ||
37 | |||
38 | +#ifdef __clang__ | ||
39 | +#pragma clang attribute push(__attribute__((target("neon,crypto,aes"))), apply_to = function) | ||
40 | +#elif defined(__GNUC__) | ||
41 | +#pragma GCC target("+simd+crypto") | ||
42 | +#endif | ||
43 | + | ||
44 | #define ABYTES crypto_aead_aes256gcm_ABYTES | ||
45 | #define NPUBBYTES crypto_aead_aes256gcm_NPUBBYTES | ||
46 | #define KEYBYTES crypto_aead_aes256gcm_KEYBYTES | ||
47 | -- | ||
48 | 2.42.1 | ||
49 | |||
diff --git a/meta-oe/recipes-crypto/libsodium/libsodium_1.0.19.bb b/meta-oe/recipes-crypto/libsodium/libsodium_1.0.19.bb deleted file mode 100644 index 2e678f3f0f..0000000000 --- a/meta-oe/recipes-crypto/libsodium/libsodium_1.0.19.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | SUMMARY = "The Sodium crypto library" | ||
2 | HOMEPAGE = "http://libsodium.org/" | ||
3 | BUGTRACKER = "https://github.com/jedisct1/libsodium/issues" | ||
4 | LICENSE = "ISC" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=49ce3b426e6a002e23a1387248e6dbe9" | ||
6 | |||
7 | SRC_URI = "https://download.libsodium.org/libsodium/releases/${BPN}-${PV}.tar.gz \ | ||
8 | file://0001-fix-aarch64-Move-target-pragma-after-arm_neon.h-incl.patch" | ||
9 | SRC_URI[sha256sum] = "018d79fe0a045cca07331d37bd0cb57b2e838c51bc48fd837a1472e50068bbea" | ||
10 | |||
11 | inherit autotools | ||
12 | |||
13 | S = "${WORKDIR}/libsodium-stable" | ||
14 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-oe/recipes-crypto/libsodium/libsodium_1.0.20.bb b/meta-oe/recipes-crypto/libsodium/libsodium_1.0.20.bb new file mode 100644 index 0000000000..63d21576b4 --- /dev/null +++ b/meta-oe/recipes-crypto/libsodium/libsodium_1.0.20.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | SUMMARY = "The Sodium crypto library" | ||
2 | HOMEPAGE = "http://libsodium.org/" | ||
3 | BUGTRACKER = "https://github.com/jedisct1/libsodium/issues" | ||
4 | LICENSE = "ISC" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c59be7bb29f8e431b5f2d690b6734185" | ||
6 | |||
7 | SRC_URI = "https://download.libsodium.org/libsodium/releases/${BPN}-${PV}.tar.gz" | ||
8 | SRC_URI[sha256sum] = "ebb65ef6ca439333c2bb41a0c1990587288da07f6c7fd07cb3a18cc18d30ce19" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||