summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/mraa/mraa/0001-include-Declare-gVERSION-global-as-extern.patch31
-rw-r--r--meta-oe/recipes-extended/mraa/mraa_git.bb3
2 files changed, 32 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/mraa/mraa/0001-include-Declare-gVERSION-global-as-extern.patch b/meta-oe/recipes-extended/mraa/mraa/0001-include-Declare-gVERSION-global-as-extern.patch
new file mode 100644
index 0000000000..d1152ed641
--- /dev/null
+++ b/meta-oe/recipes-extended/mraa/mraa/0001-include-Declare-gVERSION-global-as-extern.patch
@@ -0,0 +1,31 @@
1From dbb5961f106ec42cd70689d933674c9c37aedfe1 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
3Date: Mon, 13 Apr 2020 20:12:11 +0200
4Subject: include: Declare gVERSION global as 'extern'.
5
6Fixes build with '-fno-common'.
7
8Upstream-Status: Submitted [https://github.com/eclipse/mraa/pull/1012]
9Signed-off-by: Adrian Bunk <bunk@stusta.de>
10---
11 include/version.h | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/include/version.h b/include/version.h
15index 47366ef..3a567a1 100644
16--- a/include/version.h
17+++ b/include/version.h
18@@ -11,8 +11,8 @@
19 extern "C" {
20 #endif
21
22-const char* gVERSION;
23-const char* gVERSION_SHORT;
24+extern const char* gVERSION;
25+extern const char* gVERSION_SHORT;
26
27 #ifdef __cplusplus
28 }
29--
302.17.1
31
diff --git a/meta-oe/recipes-extended/mraa/mraa_git.bb b/meta-oe/recipes-extended/mraa/mraa_git.bb
index 403d641ee9..7c2441632e 100644
--- a/meta-oe/recipes-extended/mraa/mraa_git.bb
+++ b/meta-oe/recipes-extended/mraa/mraa_git.bb
@@ -10,6 +10,7 @@ PV = "2.1.0+git${SRCPV}"
10 10
11SRC_URI = "git://github.com/eclipse/${BPN}.git;protocol=http \ 11SRC_URI = "git://github.com/eclipse/${BPN}.git;protocol=http \
12 file://0001-cmake-Use-a-regular-expression-to-match-x86-architec.patch \ 12 file://0001-cmake-Use-a-regular-expression-to-match-x86-architec.patch \
13 file://0001-include-Declare-gVERSION-global-as-extern.patch \
13 " 14 "
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
@@ -27,8 +28,6 @@ EXTRA_OECMAKE_append = " -DINSTALLTOOLS:BOOL=ON -DFIRMATA=ON -DCMAKE_SKIP_RPATH=
27 -DPYTHON_INCLUDE_DIR=${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI} \ 28 -DPYTHON_INCLUDE_DIR=${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI} \
28 " 29 "
29 30
30CFLAGS += "-fcommon"
31
32# Prepend mraa-utils to make sure bindir ends up in there 31# Prepend mraa-utils to make sure bindir ends up in there
33PACKAGES =+ "${PN}-utils" 32PACKAGES =+ "${PN}-utils"
34 33