summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_16.02.bb23
1 files changed, 3 insertions, 20 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
index d986da9043..13479a90fe 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
@@ -17,26 +17,9 @@ SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6
17S = "${WORKDIR}/${BPN}_${PV}" 17S = "${WORKDIR}/${BPN}_${PV}"
18 18
19do_install() { 19do_install() {
20 install -d ${D}${bindir} 20 install -d ${D}${bindir}
21 install -m 0755 ${S}/bin/* ${D}${bindir} 21 install -m 0755 ${S}/bin/* ${D}${bindir}
22} 22 ln -s 7za ${D}${bindir}/7z
23
24# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
25EXTRA_OEMAKE_class-native = "all3"
26
27do_install_class-native() {
28 install -d ${D}${bindir}
29 install -d ${D}${bindir}/Codecs
30 install -m 0755 ${S}/bin/7* ${D}${bindir}
31 install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
32
33 # Create a shell script wrapper to execute next to 7z.so
34 mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
35 cat > ${D}${bindir}/7z << 'EOF'
36#!/bin/sh
37exec "$(dirname "$0")"/7z.bin "$@"
38EOF
39 chmod 0755 ${D}${bindir}/7z
40} 23}
41 24
42BBCLASSEXTEND = "native" 25BBCLASSEXTEND = "native"