summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson.inc (renamed from meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb)21
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb7
3 files changed, 15 insertions, 15 deletions
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson.inc
index 75ec2dc2d3..2eed199655 100644
--- a/meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb
+++ b/meta-python/recipes-devtools/python/python-simplejson.inc
@@ -1,26 +1,17 @@
1SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python" 1SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson" 2HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
3SECTION = "devel/python"
4 3
5LICENSE = "MIT" 4LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
7 6
8SRCNAME = "simplejson"
9
10SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15" 7SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15"
12SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2" 8SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2"
13 9
14S = "${WORKDIR}/${SRCNAME}-${PV}" 10inherit pypi
15
16inherit setuptools
17 11
18RDEPENDS_${PN} = "\ 12RDEPENDS_${PN} += "\
19 python-core \ 13 ${PYTHON_PN}-re \
20 python-re \ 14 ${PYTHON_PN}-io \
21 python-io \ 15 ${PYTHON_PN}-netserver \
22 python-netserver \ 16 ${PYTHON_PN}-numbers \
23 python-numbers \
24" 17"
25
26
diff --git a/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb
new file mode 100644
index 0000000000..e33edfebaa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-simplejson.inc
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb
new file mode 100644
index 0000000000..d44bc1526d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb
@@ -0,0 +1,7 @@
1inherit setuptools3
2require python-simplejson.inc
3
4# Requires _pydecimal which is in misc
5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-misc \
7"