diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-simplejson.inc (renamed from meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb) | 21 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb | 7 |
3 files changed, 15 insertions, 15 deletions
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson.inc index 75ec2dc2d3..2eed199655 100644 --- a/meta-oe/recipes-devtools/python/python-simplejson_3.10.0.bb +++ b/meta-python/recipes-devtools/python/python-simplejson.inc | |||
@@ -1,26 +1,17 @@ | |||
1 | SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python" | 1 | SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python" |
2 | HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson" | 2 | HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson" |
3 | SECTION = "devel/python" | ||
4 | 3 | ||
5 | LICENSE = "MIT" | 4 | LICENSE = "MIT" |
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" | 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" |
7 | 6 | ||
8 | SRCNAME = "simplejson" | ||
9 | |||
10 | SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
11 | SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15" | 7 | SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15" |
12 | SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2" | 8 | SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2" |
13 | 9 | ||
14 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 10 | inherit pypi |
15 | |||
16 | inherit setuptools | ||
17 | 11 | ||
18 | RDEPENDS_${PN} = "\ | 12 | RDEPENDS_${PN} += "\ |
19 | python-core \ | 13 | ${PYTHON_PN}-re \ |
20 | python-re \ | 14 | ${PYTHON_PN}-io \ |
21 | python-io \ | 15 | ${PYTHON_PN}-netserver \ |
22 | python-netserver \ | 16 | ${PYTHON_PN}-numbers \ |
23 | python-numbers \ | ||
24 | " | 17 | " |
25 | |||
26 | |||
diff --git a/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb new file mode 100644 index 0000000000..e33edfebaa --- /dev/null +++ b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-simplejson.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb new file mode 100644 index 0000000000..d44bc1526d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-simplejson.inc | ||
3 | |||
4 | # Requires _pydecimal which is in misc | ||
5 | RDEPENDS_${PN} += " \ | ||
6 | ${PYTHON_PN}-misc \ | ||
7 | " | ||