diff options
-rw-r--r-- | meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-eh-no-give-up-share-detection.patch | 68 | ||||
-rw-r--r-- | meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-gcc-only-GNU-specifics-after-Og.patch | 45 | ||||
-rw-r--r-- | meta-oe/recipes-extended/s-nail/s-nail_14.9.25.bb (renamed from meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb) | 4 |
3 files changed, 1 insertions, 116 deletions
diff --git a/meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-eh-no-give-up-share-detection.patch b/meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-eh-no-give-up-share-detection.patch deleted file mode 100644 index 41f98281f8..0000000000 --- a/meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-eh-no-give-up-share-detection.patch +++ /dev/null | |||
@@ -1,68 +0,0 @@ | |||
1 | From 9db4c0f6bc0dd11c77b54296fce6b8afe18f4325 Mon Sep 17 00:00:00 2001 | ||
2 | From: Steffen Nurpmeso <steffen@sdaoden.eu> | ||
3 | Date: Thu, 9 Jun 2022 18:26:38 +0800 | ||
4 | Subject: [PATCH] su_INLINE: eh no; give up, share detection with clang but for | ||
5 | a thing | ||
6 | |||
7 | Upstream-Status: Backport [https://git.sdaoden.eu/browse/s-nail.git/commit/?id=de2a44c393a39d80ddf12154aec94cace84b19c1] | ||
8 | |||
9 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
10 | --- | ||
11 | include/su/code.h | 34 +++++++++------------------------- | ||
12 | 1 file changed, 9 insertions(+), 25 deletions(-) | ||
13 | |||
14 | diff --git a/include/su/code.h b/include/su/code.h | ||
15 | index 9683f4a..c7a2af3 100644 | ||
16 | --- a/include/su/code.h | ||
17 | +++ b/include/su/code.h | ||
18 | @@ -308,29 +308,8 @@ do{\ | ||
19 | # ifdef DOXYGEN | ||
20 | # define su_INLINE inline | ||
21 | # define su_SINLINE inline | ||
22 | -# elif su_CC_GCC | ||
23 | -# if !su_CC_VCHECK_GCC(3, 1) | ||
24 | -# define su_INLINE extern __inline__ | ||
25 | -# define su_SINLINE static __inline__ | ||
26 | -# elif !defined __GNUC_GNU_INLINE__ /*4.1.3; !su_CC_VCHECK_GCC(4, 2)*/ | ||
27 | -# define su_INLINE extern __inline __attribute__((always_inline)) | ||
28 | -# define su_SINLINE static __inline __attribute__((always_inline)) | ||
29 | - /* gcc 8.3.0 bug: does not gracefully inline with -Os | ||
30 | - * gcc 12.1.0 bug: ditto, -Og | ||
31 | - * Thus: always gcc-specific! */ | ||
32 | -# elif 1 /*!defined __OPTIMIZE__ || \ | ||
33 | - !defined __STDC_VERSION__ || __STDC_VERSION__ +0 < 199901L*/ | ||
34 | -# define su_INLINE extern __inline __attribute__((gnu_inline)) | ||
35 | -# define su_SINLINE static __inline __attribute__((gnu_inline)) | ||
36 | -# elif !defined NDEBUG || !defined __OPTIMIZE__ | ||
37 | -# define su_INLINE static inline | ||
38 | -# define su_SINLINE static inline | ||
39 | -# else | ||
40 | -# define su_INLINE inline | ||
41 | -# define su_SINLINE static inline | ||
42 | -# endif | ||
43 | -# elif su_CC_CLANG || su_CC_PCC | ||
44 | -# if defined __STDC_VERSION__ && __STDC_VERSION__ +0 >= 199901L | ||
45 | +# elif su_CC_CLANG || su_CC_GCC || su_CC_PCC | ||
46 | +# if defined __STDC_VERSION__ && __STDC_VERSION__ +0 >= 199901l | ||
47 | # if !defined NDEBUG || !defined __OPTIMIZE__ | ||
48 | # define su_INLINE static inline | ||
49 | # define su_SINLINE static inline | ||
50 | @@ -340,8 +319,13 @@ do{\ | ||
51 | # define su_SINLINE static inline __attribute__((always_inline)) | ||
52 | # endif | ||
53 | # else | ||
54 | -# define su_INLINE static __inline | ||
55 | -# define su_SINLINE static __inline | ||
56 | +# if su_CC_VCHECK_GCC(3, 1) | ||
57 | +# define su_INLINE static __inline __attribute__((always_inline)) | ||
58 | +# define su_SINLINE static __inline __attribute__((always_inline)) | ||
59 | +# else | ||
60 | +# define su_INLINE static __inline | ||
61 | +# define su_SINLINE static __inline | ||
62 | +# endif | ||
63 | # endif | ||
64 | # else | ||
65 | # define su_INLINE static /* TODO __attribute__((unused)) alike? */ | ||
66 | -- | ||
67 | 2.25.1 | ||
68 | |||
diff --git a/meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-gcc-only-GNU-specifics-after-Og.patch b/meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-gcc-only-GNU-specifics-after-Og.patch deleted file mode 100644 index 37ecb0c1ff..0000000000 --- a/meta-oe/recipes-extended/s-nail/files/0001-su_INLINE-gcc-only-GNU-specifics-after-Og.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From 5429b9e343c808951b1418d8626e544c9dcb28de Mon Sep 17 00:00:00 2001 | ||
2 | From: Steffen Nurpmeso <steffen@sdaoden.eu> | ||
3 | Date: Thu, 9 Jun 2022 18:06:04 +0800 | ||
4 | Subject: [PATCH] su_INLINE: gcc: only GNU specifics after -Og | ||
5 | |||
6 | Upstream-Status: Backport [https://git.sdaoden.eu/browse/s-nail.git/commit/?id=c5544b66c3b4b2e161166562349908a07e324b38] | ||
7 | |||
8 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
9 | --- | ||
10 | include/su/code.h | 17 +++++++++-------- | ||
11 | 1 file changed, 9 insertions(+), 8 deletions(-) | ||
12 | |||
13 | diff --git a/include/su/code.h b/include/su/code.h | ||
14 | index 4d552c1..9683f4a 100644 | ||
15 | --- a/include/su/code.h | ||
16 | +++ b/include/su/code.h | ||
17 | @@ -309,16 +309,17 @@ do{\ | ||
18 | # define su_INLINE inline | ||
19 | # define su_SINLINE inline | ||
20 | # elif su_CC_GCC | ||
21 | - /* After lots of trouble with OpenBSD/gcc 4.2.1 and SunOS/gcc 3.4.3 */ | ||
22 | -# if !su_CC_VCHECK_GCC(3, 2) /* Unsure: only used C++ at that time */ | ||
23 | -# define su_INLINE extern __inline | ||
24 | -# define su_SINLINE static __inline | ||
25 | -# elif !su_CC_VCHECK_GCC(4, 3) | ||
26 | +# if !su_CC_VCHECK_GCC(3, 1) | ||
27 | +# define su_INLINE extern __inline__ | ||
28 | +# define su_SINLINE static __inline__ | ||
29 | +# elif !defined __GNUC_GNU_INLINE__ /*4.1.3; !su_CC_VCHECK_GCC(4, 2)*/ | ||
30 | # define su_INLINE extern __inline __attribute__((always_inline)) | ||
31 | # define su_SINLINE static __inline __attribute__((always_inline)) | ||
32 | - /* xxx gcc 8.3.0 bug: does not truly inline with -Os */ | ||
33 | -# elif !su_CC_VCHECK_GCC(8, 3) || !defined __OPTIMIZE__ ||\ | ||
34 | - !defined __STDC_VERSION__ || __STDC_VERSION__ +0 < 199901L | ||
35 | + /* gcc 8.3.0 bug: does not gracefully inline with -Os | ||
36 | + * gcc 12.1.0 bug: ditto, -Og | ||
37 | + * Thus: always gcc-specific! */ | ||
38 | +# elif 1 /*!defined __OPTIMIZE__ || \ | ||
39 | + !defined __STDC_VERSION__ || __STDC_VERSION__ +0 < 199901L*/ | ||
40 | # define su_INLINE extern __inline __attribute__((gnu_inline)) | ||
41 | # define su_SINLINE static __inline __attribute__((gnu_inline)) | ||
42 | # elif !defined NDEBUG || !defined __OPTIMIZE__ | ||
43 | -- | ||
44 | 2.25.1 | ||
45 | |||
diff --git a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb b/meta-oe/recipes-extended/s-nail/s-nail_14.9.25.bb index bcdb1e4788..93a852a6df 100644 --- a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb +++ b/meta-oe/recipes-extended/s-nail/s-nail_14.9.25.bb | |||
@@ -8,11 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=87266591c81260f10221f1f38872d023" | |||
8 | SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \ | 8 | SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \ |
9 | file://make-errors.patch \ | 9 | file://make-errors.patch \ |
10 | file://0001-make.rc-set-VAL_MTA.patch \ | 10 | file://0001-make.rc-set-VAL_MTA.patch \ |
11 | file://0001-su_INLINE-gcc-only-GNU-specifics-after-Og.patch \ | ||
12 | file://0001-su_INLINE-eh-no-give-up-share-detection.patch \ | ||
13 | file://0001-mk-make-config.sh-not-reveal-the-build-env.patch \ | 11 | file://0001-mk-make-config.sh-not-reveal-the-build-env.patch \ |
14 | " | 12 | " |
15 | SRC_URI[sha256sum] = "2714d6b8fb2af3b363fc7c79b76d058753716345d1b6ebcd8870ecd0e4f7ef8c" | 13 | SRC_URI[sha256sum] = "20ff055be9829b69d46ebc400dfe516a40d287d7ce810c74355d6bdc1a28d8a9" |
16 | 14 | ||
17 | DEPENDS = "coreutils-native" | 15 | DEPENDS = "coreutils-native" |
18 | 16 | ||