diff options
5 files changed, 13 insertions, 134 deletions
diff --git a/meta-oe/recipes-support/rdfind/rdfind/0001-configure-Fix-check-for-AC_CHECK_LIB.patch b/meta-oe/recipes-support/rdfind/rdfind/0001-configure-Fix-check-for-AC_CHECK_LIB.patch deleted file mode 100644 index a65d8cb77b..0000000000 --- a/meta-oe/recipes-support/rdfind/rdfind/0001-configure-Fix-check-for-AC_CHECK_LIB.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From 823a4deb61f6f9b91b0cfc4a7e7b20922c635777 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 1 Sep 2022 13:13:50 -0700 | ||
4 | Subject: [PATCH] configure: Fix check for AC_CHECK_LIB | ||
5 | |||
6 | Check for nettle_pbkdf2_hmac_sha256 from libnettle instead of main() | ||
7 | which is not in nettle library | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/pauldreik/rdfind/pull/115] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | configure.ac | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | --- a/configure.ac | ||
16 | +++ b/configure.ac | ||
17 | @@ -46,7 +46,7 @@ AC_CHECK_HEADER(nettle/sha.h,,[AC_MSG_ER | ||
18 | On Debian-ish systems, use "apt-get install nettle-dev" to get a system | ||
19 | wide nettle install. | ||
20 | ])]) | ||
21 | -AC_CHECK_LIB(nettle,main,,[AC_MSG_ERROR([ | ||
22 | +AC_CHECK_LIB(nettle,nettle_pbkdf2_hmac_sha256,,[AC_MSG_ERROR([ | ||
23 | Could not link to libnettle. Please install nettle | ||
24 | first. If you have already done so; please run ldconfig | ||
25 | as root or check whether the path libnettle was installed | ||
diff --git a/meta-oe/recipes-support/rdfind/rdfind/0001-configure.ac-fix-C-11-support-check.patch b/meta-oe/recipes-support/rdfind/rdfind/0001-configure.ac-fix-C-11-support-check.patch deleted file mode 100644 index 815939b82d..0000000000 --- a/meta-oe/recipes-support/rdfind/rdfind/0001-configure.ac-fix-C-11-support-check.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 9070bc210b2ecff641b73e4ade30040c1461969c Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Wed, 3 May 2023 18:31:57 +0200 | ||
4 | Subject: [PATCH] configure.ac: fix C++11 support check | ||
5 | |||
6 | * with -Werror=return-type in CFLAGS this test fails with: | ||
7 | |||
8 | configure:4290: checking for C++11 support or better | ||
9 | configure:4303: x86_64-webos-linux-g++ -m64 -march=core2 -mtune=core2 -msse3 -mfpmath=sse -fstack-protector-strong -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -Werror=format-security -Werror=return-type --sysroot=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/recipe-sysroot -c -O2 -pipe -g -feliminate-unused-debug-types -fmacro-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/rdfind-1.5.0=/usr/src/debug/rdfind/1.5.0-r0 -fdebug-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/rdfind-1.5.0=/usr/src/debug/rdfind/1.5.0-r0 -fmacro-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/build=/usr/src/debug/rdfind/1.5.0-r0 -fdebug-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/build=/usr/src/debug/rdfind/1.5.0-r0 -fdebug-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/recipe-sysroot= -fmacro-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/recipe-sysroot= -fdebug-prefix-map=/OE/lge/build/webos/mickledore/BUILD/work/qemux86_64-webos-linux/rdfind/1.5.0-r0/recipe-sysroot-native= -fvisibility-inlines-hidden conftest.cpp >&5 | ||
10 | conftest.cpp: In function 'int f()': | ||
11 | conftest.cpp:22:20: error: no return statement in function returning non-void [-Werror=return-type] | ||
12 | 22 | int f() { auto a=1;} | ^ | ||
13 | cc1plus: some warnings being treated as errors | ||
14 | ... | ||
15 | configure:4308: error: no c++11 support, please set CXXFLAGS properly | ||
16 | |||
17 | * fix the test to pass | ||
18 | |||
19 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
20 | Upstream-Status: Submitted [https://github.com/pauldreik/rdfind/pull/132] | ||
21 | --- | ||
22 | configure.ac | 2 +- | ||
23 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
24 | |||
25 | diff --git a/configure.ac b/configure.ac | ||
26 | index be1b2fd..9c3513c 100644 | ||
27 | --- a/configure.ac | ||
28 | +++ b/configure.ac | ||
29 | @@ -64,7 +64,7 @@ AC_SYS_LARGEFILE | ||
30 | |||
31 | dnl make sure we have c++11 or better, | ||
32 | AC_MSG_CHECKING([for C++11 support or better]) | ||
33 | -AC_COMPILE_IFELSE([AC_LANG_PROGRAM([int f() { auto a=1;}])], | ||
34 | +AC_COMPILE_IFELSE([AC_LANG_PROGRAM([int f() { auto a=1;return a;}])], | ||
35 | [AC_MSG_RESULT([yes])], | ||
36 | [AC_MSG_ERROR([no c++11 support, please set CXXFLAGS properly])]) | ||
37 | |||
diff --git a/meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch b/meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch deleted file mode 100644 index bd59b74412..0000000000 --- a/meta-oe/recipes-support/rdfind/rdfind/0001-include-standard-headers-limits-and-cstdint.patch +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | From 8c317f0fd5fde95a9aae2319053a196a166aec88 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 25 Jan 2023 21:12:47 -0800 | ||
4 | Subject: [PATCH] include standard headers <limits> and <cstdint> | ||
5 | |||
6 | gcc 13 moved some includes around and as a result <cstdint> is no longer | ||
7 | transitively included [1]. Explicitly include it for uint64_t. | ||
8 | |||
9 | Fixes errors like below | ||
10 | |||
11 | ../rdfind-1.5.0/rdfind.cc:225:30: error: 'numeric_limits' is not a member of 'std' | ||
12 | 225 | o.maximumfilesize = std::numeric_limits<decltype(o.maximumfilesize)>::max(); | ||
13 | | ^~~~~~~~~~~~~~ | ||
14 | |||
15 | ... | ||
16 | |||
17 | | ../rdfind-1.5.0/Fileinfo.hh:70:20: error: 'std::int64_t' has not been declared | ||
18 | |||
19 | [1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes | ||
20 | |||
21 | Upstream-Status: Submitted [https://github.com/pauldreik/rdfind/pull/129] | ||
22 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
23 | --- | ||
24 | Fileinfo.hh | 1 + | ||
25 | rdfind.cc | 1 + | ||
26 | 2 files changed, 2 insertions(+) | ||
27 | |||
28 | diff --git a/Fileinfo.hh b/Fileinfo.hh | ||
29 | index 3ffb837..23ed54e 100644 | ||
30 | --- a/Fileinfo.hh | ||
31 | +++ b/Fileinfo.hh | ||
32 | @@ -8,6 +8,7 @@ | ||
33 | #define Fileinfo_hh | ||
34 | |||
35 | #include <array> | ||
36 | +#include <cstdint> | ||
37 | #include <string> | ||
38 | |||
39 | // os specific headers | ||
40 | diff --git a/rdfind.cc b/rdfind.cc | ||
41 | index fbd6cb8..64dd8f6 100644 | ||
42 | --- a/rdfind.cc | ||
43 | +++ b/rdfind.cc | ||
44 | @@ -9,6 +9,7 @@ | ||
45 | // std | ||
46 | #include <algorithm> | ||
47 | #include <iostream> | ||
48 | +#include <limits> | ||
49 | #include <string> | ||
50 | #include <vector> | ||
51 | |||
52 | -- | ||
53 | 2.39.1 | ||
54 | |||
diff --git a/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb b/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb deleted file mode 100644 index dab66c3827..0000000000 --- a/meta-oe/recipes-support/rdfind/rdfind_1.5.0.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Rdfind is a program that finds duplicate files" | ||
2 | HOMEPAGE = "https://rdfind.pauldreik.se/" | ||
3 | LICENSE = "GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fa22e16ebbe6638b2bd253338fbded9f" | ||
5 | |||
6 | DEPENDS = "nettle autoconf-archive" | ||
7 | |||
8 | SRC_URI = "https://rdfind.pauldreik.se/${BP}.tar.gz \ | ||
9 | file://0001-configure-Fix-check-for-AC_CHECK_LIB.patch \ | ||
10 | file://0001-include-standard-headers-limits-and-cstdint.patch \ | ||
11 | file://0001-configure.ac-fix-C-11-support-check.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[sha256sum] = "4150ed1256f7b12b928c65113c485761552b9496c433778aac3f9afc3e767080" | ||
15 | |||
16 | inherit autotools | ||
17 | |||
18 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-oe/recipes-support/rdfind/rdfind_1.6.0.bb b/meta-oe/recipes-support/rdfind/rdfind_1.6.0.bb new file mode 100644 index 0000000000..3a15fe6c9a --- /dev/null +++ b/meta-oe/recipes-support/rdfind/rdfind_1.6.0.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "Rdfind is a program that finds duplicate files" | ||
2 | HOMEPAGE = "https://rdfind.pauldreik.se/" | ||
3 | LICENSE = "GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fa22e16ebbe6638b2bd253338fbded9f" | ||
5 | |||
6 | DEPENDS = "nettle autoconf-archive" | ||
7 | |||
8 | SRC_URI = "https://rdfind.pauldreik.se/${BP}.tar.gz" | ||
9 | SRC_URI[sha256sum] = "7a406e8ef1886a5869655604618dd98f672f12c6a6be4926d053be65070f3279" | ||
10 | |||
11 | inherit autotools | ||
12 | |||
13 | BBCLASSEXTEND = "native" | ||