summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch33
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch36
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0007-Modify-gobject-intrispection-support-to-work-with-OE.patch75
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb113
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb23
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb70
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc15
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch)28
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch)0
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch)0
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0004-call-native-helpers.patch (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch)33
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/iconv-detect.h (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/iconv-detect.h)0
12 files changed, 137 insertions, 289 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch
deleted file mode 100644
index 55ab5a7fca..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 95425206e7317e59b7ca06d7f838ad357cdd200c Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net>
3Date: Wed, 14 Aug 2019 00:31:54 +0200
4Subject: [PATCH 5/7] Use LC_MESSAGES for address localization when LC_ADDRESS
5 is not available.
6
7Musl does not define LC_ADDRESS unfortunately.
8
9Upstream-Status: Inappropriate [musl specific]
10
11Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
12---
13 src/addressbook/libebook-contacts/e-phone-number-private.cpp | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/src/addressbook/libebook-contacts/e-phone-number-private.cpp b/src/addressbook/libebook-contacts/e-phone-number-private.cpp
17index 4c5aebb..9abcebd 100644
18--- a/src/addressbook/libebook-contacts/e-phone-number-private.cpp
19+++ b/src/addressbook/libebook-contacts/e-phone-number-private.cpp
20@@ -36,6 +36,10 @@
21 #include <phonenumbers/logger.h>
22 #include <phonenumbers/phonenumberutil.h>
23
24+#ifndef LC_ADDRESS
25+#define LC_ADDRESS LC_MESSAGES
26+#endif
27+
28 using i18n::phonenumbers::PhoneNumber;
29 using i18n::phonenumbers::PhoneNumberUtil;
30
31--
322.21.0
33
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch
deleted file mode 100644
index c0c1427fd2..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From fb9164bbca5b425f1cf1bb3cac51d06afe81938a Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net>
3Date: Wed, 14 Aug 2019 00:47:59 +0200
4Subject: [PATCH 6/7] Dont add /usr/lib to LDFLAGS when linking libphonenumber.
5
6This will refer to host lib dir which is not what we want.
7
8Upstream-Status: Inappropriate [configuration]
9
10Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
11---
12 cmake/modules/FindPhonenumber.cmake | 6 ++----
13 1 file changed, 2 insertions(+), 4 deletions(-)
14
15diff --git a/cmake/modules/FindPhonenumber.cmake b/cmake/modules/FindPhonenumber.cmake
16index 04d1056..70c0c41 100644
17--- a/cmake/modules/FindPhonenumber.cmake
18+++ b/cmake/modules/FindPhonenumber.cmake
19@@ -37,12 +37,10 @@ string(TOUPPER "${WITH_PHONENUMBER}" optupper)
20 if(("${optupper}" STREQUAL "ON") OR ("${substr}" STREQUAL "${CMAKE_BINARY_DIR}"))
21 set(WITH_PHONENUMBER "ON")
22 set(PHONENUMBER_INCLUDE_DIRS "${INCLUDE_INSTALL_DIR}")
23- set(PHONENUMBER_LIB_DIRS ${LIB_INSTALL_DIR})
24- set(PHONENUMBER_LDFLAGS -L${PHONENUMBER_LIB_DIRS} ${PHONENUMBER_LDFLAGS})
25+ set(PHONENUMBER_LDFLAGS ${PHONENUMBER_LDFLAGS})
26 else(("${optupper}" STREQUAL "ON") OR ("${substr}" STREQUAL "${CMAKE_BINARY_DIR}"))
27 set(PHONENUMBER_INCLUDE_DIRS "${WITH_PHONENUMBER}/include")
28- set(PHONENUMBER_LIB_DIRS ${WITH_PHONENUMBER}/lib${LIB_SUFFIX})
29- set(PHONENUMBER_LDFLAGS -L${PHONENUMBER_LIB_DIRS} ${PHONENUMBER_LDFLAGS})
30+ set(PHONENUMBER_LDFLAGS ${PHONENUMBER_LDFLAGS})
31 endif(("${optupper}" STREQUAL "ON") OR ("${substr}" STREQUAL "${CMAKE_BINARY_DIR}"))
32
33 unset(bindirlen)
34--
352.21.0
36
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0007-Modify-gobject-intrispection-support-to-work-with-OE.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0007-Modify-gobject-intrispection-support-to-work-with-OE.patch
deleted file mode 100644
index c00082a2ce..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0007-Modify-gobject-intrispection-support-to-work-with-OE.patch
+++ /dev/null
@@ -1,75 +0,0 @@
1From d84f4fd68441e934b37be2a6917abad52c5d1bda Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net>
3Date: Fri, 16 Aug 2019 21:22:16 +0200
4Subject: [PATCH 7/7] Modify gobject-intrispection support to work with OE.
5
61. Use tools provided by the recipe sysroot instread of host ones.
72. Make sure all the required dirs make it into g-ir-scanner via
8 LDFLAGS.
9
10Upstream-Status: Inappropriate [configuration]
11
12Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
13---
14 cmake/modules/GObjectIntrospection.cmake | 12 ++++++++++--
15 1 file changed, 10 insertions(+), 2 deletions(-)
16
17diff --git a/cmake/modules/GObjectIntrospection.cmake b/cmake/modules/GObjectIntrospection.cmake
18index 5be5042..67c035a 100644
19--- a/cmake/modules/GObjectIntrospection.cmake
20+++ b/cmake/modules/GObjectIntrospection.cmake
21@@ -20,6 +20,9 @@ if(ENABLE_INTROSPECTION)
22 pkg_check_variable(G_IR_SCANNER gobject-introspection-1.0 g_ir_scanner)
23 pkg_check_variable(G_IR_COMPILER gobject-introspection-1.0 g_ir_compiler)
24
25+ string(CONCAT G_IR_SCANNER $ENV{PKG_CONFIG_SYSROOT_DIR} "${G_IR_SCANNER}")
26+ string(CONCAT G_IR_COMPILER $ENV{PKG_CONFIG_SYSROOT_DIR} "${G_IR_COMPILER}")
27+
28 if(NOT G_IR_SCANNER)
29 message(FATAL_ERROR "g-ir-scanner not provided by gobject-introspection-1.0, you can disable GObject introspection by -DENABLE_INTROSPECTION=OFF")
30 endif(NOT G_IR_SCANNER)
31@@ -116,7 +119,7 @@ macro(gir_add_introspection gir)
32 file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/${_gir_name}_files "${_gir_files}")
33
34 add_custom_command(
35- COMMAND ${CMAKE_COMMAND} -E env "CC='${CMAKE_C_COMPILER}'" LDFLAGS=
36+ COMMAND ${CMAKE_COMMAND} -E env "CC='${CMAKE_C_COMPILER}'" LDFLAGS=${INTROSPECTION_SCANNER_LDFLAGS}
37 ${INTROSPECTION_SCANNER_ENV}
38 ${G_IR_SCANNER}
39 ${INTROSPECTION_SCANNER_ARGS}
40@@ -186,6 +189,7 @@ macro(gir_add_introspection_simple gir_library pkg_export_prefix gir_library_ver
41 unset(INTROSPECTION_SCANNER_ARGS)
42 unset(INTROSPECTION_SCANNER_ENV)
43 unset(INTROSPECTION_COMPILER_ARGS)
44+ unset(INTROSPECTION_SCANNER_LDFLAGS)
45
46 set(${gir_vars_prefix} ${gir_library})
47 set(${gir_vars_prefix}_SCANNERFLAGS "--warn-all")
48@@ -223,12 +227,12 @@ macro(gir_add_introspection_simple gir_library pkg_export_prefix gir_library_ver
49 --add-include-path=${CMAKE_CURRENT_SOURCE_DIR}
50 --library-path=${CMAKE_BINARY_DIR}
51 --library-path=${CMAKE_BINARY_DIR}/src
52+ --library-path=${CMAKE_BINARY_DIR}/src/private
53 --library-path=${CMAKE_CURRENT_BINARY_DIR}
54 ${_gir_extra_libdirs}
55 ${_gir_identifies_prefixes}
56 ${_gir_deps}
57 --add-include-path=${SHARE_INSTALL_PREFIX}/gir-1.0
58- --library-path=${LIB_INSTALL_DIR}
59 ${_extra_library_path}
60 --pkg-export ${pkg_export_prefix}-${gir_library_version}
61 --c-include=${c_include}
62@@ -279,6 +283,10 @@ macro(gir_add_introspection_simple gir_library pkg_export_prefix gir_library_ver
63 )
64 endif(UNIX)
65
66+ _gir_list_prefix(_gir_scanner_ldflags ${gir_extra_libdirs_var} "-Wl,-rpath-link=")
67+ string(REPLACE ";" " " _gir_scanner_ldflags "${_gir_scanner_ldflags}")
68+ set(INTROSPECTION_SCANNER_LDFLAGS "${_gir_scanner_ldflags}")
69+
70 set(INTROSPECTION_SCANNER_ENV
71 ${_loader_library_path_var}="${_extra_loader_library_path_native}"
72 )
73--
742.21.0
75
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
deleted file mode 100644
index b4174cbb03..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
+++ /dev/null
@@ -1,113 +0,0 @@
1SUMMARY = "Evolution database backend server"
2HOMEPAGE = "http://www.gnome.org/projects/evolution/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2 & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
7 file://src/camel/camel.h;endline=24;md5=342fc5e9357254bc30c24e43ae47d9a1 \
8 file://src/libedataserver/e-data-server-util.h;endline=20;md5=8f21a9c80ea82a4fb80b5f959f672543 \
9 file://src/calendar/libecal/e-cal.h;endline=24;md5=e699ec3866f73f129f7a4ffffdcfc196"
10
11DEPENDS = " \
12 intltool-native gperf-native glib-2.0-native \
13 glib-2.0 gtk+3 libgnome-keyring libgdata libcanberra icu \
14 dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \
15"
16
17inherit gnomebase cmake gtk-doc gettext gobject-introspection perlnative upstream-version-is-even vala
18
19SRC_URI += "file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \
20 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
21 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
22 file://0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch \
23 file://0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch \
24 file://0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch \
25 file://0007-Modify-gobject-intrispection-support-to-work-with-OE.patch \
26 file://iconv-detect.h \
27 "
28SRC_URI[archive.md5sum] = "57820f3f88fc554e1a58665a52e12c05"
29SRC_URI[archive.sha256sum] = "83f67cb4b680e892b22b51bcde64c788b7ac63e92a99de401fb347e3794f4c7f"
30
31LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
32LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF"
33
34EXTRA_OECMAKE = " \
35 -D${LKSTRFTIME} \
36 -DSYSCONF_INSTALL_DIR=${sysconfdir} \
37 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
38"
39
40PACKAGECONFIG ??= "${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'introspection', '', d)}"
41PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
42PACKAGECONFIG[oauth2] = "-DENABLE_OAUTH2=ON,-DENABLE_OAUTH2=OFF,json-glib webkitgtk"
43PACKAGECONFIG[mitkrb5] = "-DWITH_KRB5=ON,-DWITH_KRB5=OFF,krb5"
44PACKAGECONFIG[goa] = "-DENABLE_GOA=ON,-DENABLE_GOA=OFF,gnome-online-accounts"
45PACKAGECONFIG[weather] = "-DENABLE_WEATHER=ON,-DENABLE_WEATHER=OFF,libgweather"
46PACKAGECONFIG[phonenumber] = "-DWITH_PHONENUMBER=ON,-DWITH_PHONENUMBER=OFF,libphonenumber"
47PACKAGECONFIG[introspection] = "-DENABLE_INTROSPECTION=ON,-DENABLE_INTROSPECTION=OFF"
48PACKAGECONFIG[vala] = "-DENABLE_VALA_BINDINGS=ON -DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen,-DENABLE_VALA_BINDINGS=OFF"
49
50# -ldb needs this on some platforms
51LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
52
53do_configure_append () {
54 cp ${WORKDIR}/iconv-detect.h ${S}/src
55
56 # fix native perl shebang
57 sed -i 's:${STAGING_BINDIR_NATIVE}/perl-native:${bindir}:' ${B}/src/tools/addressbook-export/csv2vcard
58}
59
60do_compile_prepend() {
61 # CMake does not support building native binaries when cross compiling. As result
62 # it always cross compiles them for the target and then aborts when they fail to run.
63 # To work around this manually build required tools and patch cmake targets to use
64 # those native binaries we built here.
65 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -I${B} ${S}/src/camel/camel-gen-tables.c \
66 -o ${B}/src/camel/camel-gen-tables-native
67 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -I${B} $(pkg-config-native --cflags glib-2.0) \
68 ${S}/src/addressbook/libebook-contacts/gen-western-table.c \
69 -o ${B}/src/addressbook/libebook-contacts/gen-western-table-native \
70 $(pkg-config-native --libs glib-2.0)
71}
72
73
74PACKAGES =+ "libebook-contacts libebook-contacts-dev \
75 libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \
76 libedata-book libedata-book-dev libedata-cal libedata-cal-dev \
77 libedataserver libedataserver-dev \
78 libedataserverui libedataserverui-dev"
79
80FILES_${PN} =+ "${systemd_user_unitdir} \
81 ${datadir}/dbus-1 \
82 ${datadir}/evolution-data-server-*/ui/"
83RDEPENDS_${PN} += "perl"
84
85FILES_libcamel = "${libdir}/libcamel-*.so.* \
86 ${libdir}/libcamel-provider-*.so.* \
87 ${libdir}/girepository-*/Camel-*.typelib \
88 ${libdir}/evolution-data-server*/camel-providers/*.so \
89 ${libdir}/evolution-data-server*/camel-providers/*.urls"
90FILES_libebook = "${libdir}/libebook-*.so.* \
91 ${libdir}/girepository-*/EBook-*.typelib"
92RRECOMMENDS_libebook = "libedata-book"
93
94FILES_libebook-contacts = "${libdir}/libebook-contacts-*.so.* \
95 ${libdir}/girepository-*/EBookContacts-*.typelib"
96
97FILES_libecal = "${libdir}/libecal-*.so.*"
98RRECOMMENDS_libecal = "libedata-cal tzdata"
99
100FILES_libedata-book = "${libexecdir}/e-addressbook-factory \
101 ${datadir}/dbus-1/services/*.AddressBook.service \
102 ${libdir}/libedata-book-*.so.* \
103 ${libdir}/evolution-data-server-*/extensions/libebook*.so"
104
105FILES_libedata-cal = "${libexecdir}/e-calendar-factory \
106 ${datadir}/dbus-1/services/*.Calendar.service \
107 ${libdir}/libedata-cal-*.so.* \
108 ${libdir}/evolution-data-server-*/extensions/libecal*.so"
109
110FILES_libedataserver = "${libdir}/libedataserver-*.so.* \
111 ${libdir}/girepository-*/EDataServer-*.typelib"
112
113FILES_libedataserverui = "${libdir}/libedataserverui-*.so.*"
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
new file mode 100644
index 0000000000..681a61c33a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
@@ -0,0 +1,23 @@
1require ${BPN}.inc
2
3inherit native
4
5DEPENDS = "glib-2.0-native"
6
7# build native helpers
8do_compile() {
9 cd ${S}/src/camel
10 sed -i 's:#include "evolution-data-server-config.h"::g' camel-gen-tables.c
11 ${CC} -o ${B}/camel-gen-tables camel-gen-tables.c ${CFLAGS} ${LDFLAGS}
12
13 LDFLAGS_glib=`pkg-config glib-2.0 --libs`
14 CFLAGS_glib=`pkg-config glib-2.0 --cflags`
15 cd ${S}/src/addressbook/libebook-contacts
16 sed -i 's:#include "evolution-data-server-config.h"::g' gen-western-table.c
17 ${CC} -o ${B}/gen-western-table gen-western-table.c ${CFLAGS} ${CFLAGS_glib} ${LDFLAGS} ${LDFLAGS_glib}
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 755 ${B}/* ${D}${bindir}
23}
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
new file mode 100644
index 0000000000..a8bb69f00b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
@@ -0,0 +1,70 @@
1require ${BPN}.inc
2
3DEPENDS = " \
4 ${BPN}-native intltool-native gperf-native \
5 glib-2.0 gtk+3 libgdata \
6 dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \
7"
8
9inherit distro_features_check cmake gtk-doc gettext gobject-introspection perlnative pythonnative
10
11REQUIRED_DISTRO_FEATURES = "x11"
12
13SRC_URI += " \
14 file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \
15 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
16 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
17 file://0004-call-native-helpers.patch \
18 file://iconv-detect.h \
19"
20
21LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
22LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF"
23
24# For arm qemu-arm runs at 100% CPU load and never returns - so disable introspection for now
25GI_DATA_ENABLED="False"
26
27EXTRA_OECMAKE = " \
28 -DSYSCONF_INSTALL_DIR=${sysconfdir} \
29 -DWITH_KRB5=OFF \
30 -DENABLE_GOA=OFF \
31 -DENABLE_UOA=OFF \
32 -DENABLE_GOOGLE_AUTH=OFF \
33 -DENABLE_WEATHER=OFF \
34 -DENABLE_INTROSPECTION=${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'ON', 'OFF', d)} \
35 -D${LKSTRFTIME} \
36 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
37"
38
39PACKAGECONFIG[canberra] = "-DENABLE_CANBERRA=ON,-DENABLE_CANBERRA=OFF,libcanberra"
40PACKAGECONFIG[oauth] = "-DENABLE_OAUTH2=ON,-DENABLE_OAUTH2=OFF,webkitgtk json-glib"
41
42# BROKEN: due missing pkg-config in openldap eds' cmake finds host-libs when
43# searching for openldap-libs
44PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
45
46# -ldb needs this on some platforms
47LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
48
49do_configure_append () {
50 cp ${WORKDIR}/iconv-detect.h ${S}/src
51
52 # fix native perl shebang
53 sed -i 's:${STAGING_BINDIR_NATIVE}/perl-native:${bindir}:' ${B}/src/tools/addressbook-export/csv2vcard
54
55 # fix abs path for g-ir-scanner-wrapper
56 sed -i ${B}/build.ninja \
57 -e 's: ${bindir}/g-ir-scanner-wrapper: ${STAGING_BINDIR}/g-ir-scanner-wrapper:g'
58}
59
60do_compile_prepend() {
61 export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
62}
63
64FILES_${PN} =+ " \
65 ${datadir}/dbus-1 \
66 ${datadir}/evolution-data-server-*/ui/ \
67 ${systemd_user_unitdir} \
68"
69
70RDEPENDS_${PN} += "perl"
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
new file mode 100644
index 0000000000..2e5176ce72
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
@@ -0,0 +1,15 @@
1SUMMARY = "Evolution database backend server"
2HOMEPAGE = "http://www.gnome.org/projects/evolution/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2 & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
7 file://src/camel/camel.h;endline=24;md5=342fc5e9357254bc30c24e43ae47d9a1 \
8 file://src/libedataserver/e-data-server-util.h;endline=20;md5=8f21a9c80ea82a4fb80b5f959f672543"
9
10inherit gnomebase
11
12SRC_URI[archive.md5sum] = "d1701875bbac80d6d62e9acfc6c43bea"
13SRC_URI[archive.sha256sum] = "6ff56ba04cb639e627fe9d6e0ada106a10cadd68a0d53b8ec72b4e285df53abe"
14PV = "3.34.1"
15
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
index cc9dca4ea5..e8c6d6a763 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
@@ -1,7 +1,7 @@
1From e32075119803f9fffbba01a31083e416cb213011 Mon Sep 17 00:00:00 2001 1From 131b88a81aba3d72d566bc8a9d968941a98e0007 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> 2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Tue, 19 Dec 2017 16:37:20 +0100 3Date: Sun, 31 Mar 2019 18:11:55 +0200
4Subject: [PATCH 1/7] CMakeLists.txt: Remove TRY_RUN for iconv 4Subject: [PATCH] CMakeLists.txt: Remove TRY_RUN for iconv
5MIME-Version: 1.0 5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8 6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit 7Content-Transfer-Encoding: 8bit
@@ -13,22 +13,24 @@ Upstream-Status: Inappropriate [OE specific]
13 13
14Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> 14Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
15--- 15---
16 CMakeLists.txt | 6 ------ 16 CMakeLists.txt | 11 -----------
17 1 file changed, 6 deletions(-) 17 1 file changed, 11 deletions(-)
18 18
19diff --git a/CMakeLists.txt b/CMakeLists.txt 19diff --git a/CMakeLists.txt b/CMakeLists.txt
20index f9d72db..ed99904 100644 20index 1672daf..0b3e4e0 100644
21--- a/CMakeLists.txt 21--- a/CMakeLists.txt
22+++ b/CMakeLists.txt 22+++ b/CMakeLists.txt
23@@ -526,15 +526,9 @@ endif(NOT HAVE_ICONV) 23@@ -524,17 +524,6 @@ if(NOT HAVE_ICONV)
24 message(FATAL_ERROR "You need to install a working iconv implementation, such as ftp://ftp.gnu.org/pub/gnu/libiconv")
25 endif(NOT HAVE_ICONV)
24 26
25 set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBS}) 27-set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBS})
26 file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/" _binary_dir_with_separator) 28-file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/" _binary_dir_with_separator)
27-CHECK_C_SOURCE_RUNS("#define ICONV_DETECT_BUILD_DIR \"${_binary_dir_with_separator}\" 29-CHECK_C_SOURCE_RUNS("#define ICONV_DETECT_BUILD_DIR \"${_binary_dir_with_separator}\"
28- #include \"${CMAKE_SOURCE_DIR}/iconv-detect.c\"" _correct_iconv) 30- #include \"${CMAKE_SOURCE_DIR}/iconv-detect.c\"" _correct_iconv)
29 unset(_binary_dir_with_separator) 31-unset(_binary_dir_with_separator)
30 unset(CMAKE_REQUIRED_LIBRARIES) 32-unset(CMAKE_REQUIRED_LIBRARIES)
31 33-
32-if(NOT _correct_iconv) 34-if(NOT _correct_iconv)
33- message(FATAL_ERROR "You need to install a working iconv implementation, such as ftp://ftp.gnu.org/pub/gnu/libiconv") 35- message(FATAL_ERROR "You need to install a working iconv implementation, such as ftp://ftp.gnu.org/pub/gnu/libiconv")
34-endif(NOT _correct_iconv) 36-endif(NOT _correct_iconv)
@@ -37,5 +39,5 @@ index f9d72db..ed99904 100644
37 # Backtraces for debugging 39 # Backtraces for debugging
38 # ****************************** 40 # ******************************
39-- 41--
402.21.0 422.20.1
41 43
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
index 23c3a96d43..23c3a96d43 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
index c9e6f96f5c..c9e6f96f5c 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0004-call-native-helpers.patch
index 67023df2cb..e320f6342d 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/0004-call-native-helpers.patch
@@ -1,26 +1,21 @@
1From 30bd4ae3badb152c9f81c6d34014c586fa0cc825 Mon Sep 17 00:00:00 2001 1From 9c375e3fcf8ff778a5010a07a7da4b6a58adec7c Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net> 2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Mon, 12 Aug 2019 14:13:52 +0200 3Date: Sun, 31 Mar 2019 19:11:31 +0200
4Subject: [PATCH 4/7] Add native suffix to exacutables produced and run during 4Subject: [PATCH] call native helpers
5 build process. 5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
6 8
7CMake can't build tools for the host system when cross compiling. As 9Upstream-Status: Inappropriate[oe-specific]
8result eds currently fails to build in OE due to some programs being
9cross compiled for the target and run on the host. To work around this
10limitation modify existing targets using build time generated binaries
11to invoke binaries suffixed with -native. We can inject such binaries
12into expected locations prior to invoking ninja in do_compile.
13 10
14Upstream-Status: Inappropriate [OE specific] 11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
15
16Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
17--- 12---
18 src/addressbook/libebook-contacts/CMakeLists.txt | 2 +- 13 src/addressbook/libebook-contacts/CMakeLists.txt | 2 +-
19 src/camel/CMakeLists.txt | 2 +- 14 src/camel/CMakeLists.txt | 2 +-
20 2 files changed, 2 insertions(+), 2 deletions(-) 15 2 files changed, 2 insertions(+), 2 deletions(-)
21 16
22diff --git a/src/addressbook/libebook-contacts/CMakeLists.txt b/src/addressbook/libebook-contacts/CMakeLists.txt 17diff --git a/src/addressbook/libebook-contacts/CMakeLists.txt b/src/addressbook/libebook-contacts/CMakeLists.txt
23index e9e3259..2ae72a8 100644 18index e9e3259..e749d1b 100644
24--- a/src/addressbook/libebook-contacts/CMakeLists.txt 19--- a/src/addressbook/libebook-contacts/CMakeLists.txt
25+++ b/src/addressbook/libebook-contacts/CMakeLists.txt 20+++ b/src/addressbook/libebook-contacts/CMakeLists.txt
26@@ -25,7 +25,7 @@ target_link_libraries(gen-western-table 21@@ -25,7 +25,7 @@ target_link_libraries(gen-western-table
@@ -28,12 +23,12 @@ index e9e3259..2ae72a8 100644
28 add_custom_command( 23 add_custom_command(
29 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h 24 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h
30- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gen-western-table "${CMAKE_CURRENT_SOURCE_DIR}/e-name-western-tables.h.in" >${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h 25- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gen-western-table "${CMAKE_CURRENT_SOURCE_DIR}/e-name-western-tables.h.in" >${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h
31+ COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gen-western-table-native "${CMAKE_CURRENT_SOURCE_DIR}/e-name-western-tables.h.in" >${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h 26+ COMMAND gen-western-table "${CMAKE_CURRENT_SOURCE_DIR}/e-name-western-tables.h.in" >${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h
32 DEPENDS gen-western-table e-name-western-tables.h.in 27 DEPENDS gen-western-table e-name-western-tables.h.in
33 ) 28 )
34 29
35diff --git a/src/camel/CMakeLists.txt b/src/camel/CMakeLists.txt 30diff --git a/src/camel/CMakeLists.txt b/src/camel/CMakeLists.txt
36index be626a8..9226b2b 100644 31index be626a8..14ac8b8 100644
37--- a/src/camel/CMakeLists.txt 32--- a/src/camel/CMakeLists.txt
38+++ b/src/camel/CMakeLists.txt 33+++ b/src/camel/CMakeLists.txt
39@@ -10,7 +10,7 @@ target_include_directories(camel-gen-tables PUBLIC 34@@ -10,7 +10,7 @@ target_include_directories(camel-gen-tables PUBLIC
@@ -41,10 +36,10 @@ index be626a8..9226b2b 100644
41 add_custom_command( 36 add_custom_command(
42 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c 37 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c
43- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/camel-gen-tables >${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c 38- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/camel-gen-tables >${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c
44+ COMMAND ${CMAKE_CURRENT_BINARY_DIR}/camel-gen-tables-native >${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c 39+ COMMAND camel-gen-tables >${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c
45 DEPENDS camel-gen-tables 40 DEPENDS camel-gen-tables
46 ) 41 )
47 42
48-- 43--
492.21.0 442.20.1
50 45
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/iconv-detect.h b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/iconv-detect.h
index 46f476d5bc..46f476d5bc 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/iconv-detect.h
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server/iconv-detect.h