summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index cfced50a0e..9d63e5b73b 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Wireless daemon for Linux"
2LICENSE = "LGPL-2.1" 2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" 3LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
4 4
5inherit autotools pkgconfig systemd python3native 5inherit autotools manpages pkgconfig systemd python3native
6 6
7DEPENDS = "ell" 7DEPENDS = "ell"
8 8
@@ -16,12 +16,11 @@ S = "${WORKDIR}/git"
16PACKAGECONFIG ??= " \ 16PACKAGECONFIG ??= " \
17 client \ 17 client \
18 monitor \ 18 monitor \
19 manual-pages \
20 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ 19 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
21" 20"
22PACKAGECONFIG[client] = "--enable-client,--disable-client,readline" 21PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor" 22PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
24PACKAGECONFIG[manual-pages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native" 23PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
25PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" 24PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
26PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" 25PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
27PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" 26PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
@@ -33,8 +32,6 @@ do_configure_prepend () {
33} 32}
34 33
35do_install_append() { 34do_install_append() {
36 mkdir --parents ${D}${docdir}/${BPN}
37 install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN}
38 # If client and monitor are disabled, bindir is empty, causing a QA error 35 # If client and monitor are disabled, bindir is empty, causing a QA error
39 rmdir --ignore-fail-on-non-empty ${D}/${bindir} 36 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
40} 37}