summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb17
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb32
2 files changed, 32 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb
deleted file mode 100644
index 911e0ba9fb..0000000000
--- a/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "Library for interfacing with common SoC peripherals"
2DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
3 found in SoC (System on Chips) through generic Linux Kernel interfaces."
4
5HOMEPAGE = "https://github.com/jackmitch/libsoc"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e0bfebea12a718922225ba987b2126a5"
9
10inherit autotools
11
12SRCREV = "2919c35e706fe7c311f83f9343865420fa4b37fe"
13SRC_URI = "git://github.com/jackmitch/libsoc.git"
14
15S = "${WORKDIR}/git"
16
17RDEPENDS_${PN} = "libgcc"
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
new file mode 100644
index 0000000000..cf39278a60
--- /dev/null
+++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Library for interfacing with common SoC peripherals"
2DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
3 found in SoC (System on Chips) through generic Linux Kernel interfaces."
4
5HOMEPAGE = "https://github.com/jackmitch/libsoc"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e0bfebea12a718922225ba987b2126a5"
9
10inherit autotools pkgconfig python-dir
11
12SRCREV = "7fc953f980f4a51f0272ad691d3aa06b6aedbf16"
13SRC_URI = "git://github.com/jackmitch/libsoc.git"
14
15S = "${WORKDIR}/git"
16
17BOARD ??= "devboard"
18
19PACKAGECONFIG ?= ""
20
21PACKAGECONFIG[disabledebug] = "--disable-debug,,"
22PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
23PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
24PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
25
26PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
27 '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
28
29RDEPENDS_${PN} = "libgcc"
30
31FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a"
32FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}"