summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb b/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb
deleted file mode 100644
index e672701ae0..0000000000
--- a/meta-oe/recipes-support/xserver-xorg-cvt/xserver-xorg-cvt-native_1.20.10.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "X.Org X cvt"
2HOMEPAGE = "https://linux.die.net/man/1/cvt"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
5
6DEPENDS += "pixman-native xorgproto-native libxrandr-native"
7
8XORG_PN = "xorg-server"
9
10SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
11SRC_URI[sha256sum] = "977420c082450dc808de301ef56af4856d653eea71519a973c3490a780cb7c99"
12
13S = "${WORKDIR}/${XORG_PN}-${PV}"
14B = "${WORKDIR}/build"
15
16inherit pkgconfig native
17
18do_configure[noexec] = "1"
19
20do_compile() {
21 cd ${S}
22 for header in `find -name '*.h'`; do
23 path=`dirname $header`
24 if ! echo "$incpaths" | grep -q "$path" ; then
25 incpaths="$incpaths -I$path"
26 fi
27 done
28 CFLAGS="${CFLAGS} -DXORG_VERSION_CURRENT=1 $incpaths `pkg-config --cflags pixman-1`"
29 LDFLAGS="${LDFLAGS} -lm `pkg-config --libs pixman-1`"
30 ${CC} $CFLAGS -o ${B}/cvt \
31 ${S}/hw/xfree86/utils/cvt/cvt.c \
32 ${S}/hw/xfree86/modes/xf86cvt.c \
33 ${S}/os/xprintf.c \
34 $LDFLAGS
35}
36
37do_install() {
38 install -d ${D}${bindir}
39 install -m 755 ${B}/cvt ${D}${bindir}
40}