diff options
-rw-r--r-- | meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb | 1 |
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch b/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch new file mode 100644 index 0000000000..4fc7703d81 --- /dev/null +++ b/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 216e31260b618ec73862f9f5336597f391444dac Mon Sep 17 00:00:00 2001 | ||
2 | From: Chen Qi <Qi.Chen@windriver.com> | ||
3 | Date: Sun, 29 Sep 2019 17:20:42 +0800 | ||
4 | Subject: [PATCH] avoid race condition | ||
5 | |||
6 | It's possible that the cxx-generate-packed-data.cc is compiled | ||
7 | while the t/test-full.pb.h is being generated. This will result | ||
8 | the following error. | ||
9 | |||
10 | DEBUG: ./t/test-full.pb.h:4:0: error: unterminated #ifndef | ||
11 | ./t/test-full.pb.h:4:0: error: unterminated #ifndef | ||
12 | |||
13 | Add a dependency to avoid such problem. | ||
14 | |||
15 | Upstream-Status: Pending | ||
16 | |||
17 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | ||
18 | --- | ||
19 | Makefile.am | 1 + | ||
20 | 1 file changed, 1 insertion(+) | ||
21 | |||
22 | diff --git a/Makefile.am b/Makefile.am | ||
23 | index b0cb065..1608ae0 100644 | ||
24 | --- a/Makefile.am | ||
25 | +++ b/Makefile.am | ||
26 | @@ -156,6 +156,7 @@ noinst_PROGRAMS += \ | ||
27 | t_generated_code2_cxx_generate_packed_data_SOURCES = \ | ||
28 | t/generated-code2/cxx-generate-packed-data.cc \ | ||
29 | t/test-full.pb.cc | ||
30 | +t/generated-code2/cxx-generate-packed-data.cc: t/test-full.pb.h | ||
31 | $(t_generated_code2_cxx_generate_packed_data_OBJECTS): t/test-full.pb.h | ||
32 | t_generated_code2_cxx_generate_packed_data_CXXFLAGS = \ | ||
33 | $(AM_CXXFLAGS) \ | ||
34 | -- | ||
35 | 2.17.1 | ||
36 | |||
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb index 6d1ffc3f40..b92f82dec2 100644 --- a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb +++ b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb | |||
@@ -15,6 +15,7 @@ DEPENDS = "protobuf-native protobuf" | |||
15 | SRCREV = "1390409f4ee4e26d0635310995b516eb702c3f9e" | 15 | SRCREV = "1390409f4ee4e26d0635310995b516eb702c3f9e" |
16 | 16 | ||
17 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \ | 17 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \ |
18 | file://0001-avoid-race-condition.patch \ | ||
18 | " | 19 | " |
19 | 20 | ||
20 | S = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/git" |