diff options
-rw-r--r-- | meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-support/zbar/zbar_0.10.bb | 31 |
2 files changed, 0 insertions, 67 deletions
diff --git a/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch b/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch deleted file mode 100644 index c93af32966..0000000000 --- a/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From 224507bc4b6e58f7a6e445bfebfb59d6b8d78bd6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 2 Dec 2016 17:38:51 -0800 | ||
4 | Subject: [PATCH] make relies GNU extentions | ||
5 | |||
6 | We get errors like | ||
7 | `%'-style pattern rules are a GNU make extension | ||
8 | |||
9 | Disable this warning, since we use gmake with OE | ||
10 | anyway | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | configure.ac | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -3,7 +3,7 @@ AC_PREREQ([2.61]) | ||
20 | AC_INIT([zbar], [0.10], [spadix@users.sourceforge.net]) | ||
21 | AC_CONFIG_AUX_DIR(config) | ||
22 | AC_CONFIG_MACRO_DIR(config) | ||
23 | -AM_INIT_AUTOMAKE([1.10 -Wall -Werror foreign subdir-objects std-options dist-bzip2]) | ||
24 | +AM_INIT_AUTOMAKE([1.10 -Wall -Wno-error foreign subdir-objects std-options dist-bzip2]) | ||
25 | AC_CONFIG_HEADERS([include/config.h]) | ||
26 | AC_CONFIG_SRCDIR(zbar/scanner.c) | ||
27 | LT_PREREQ([2.2]) | ||
28 | @@ -47,7 +47,7 @@ AC_DEFINE_UNQUOTED([LIB_VERSION_REVISION | ||
29 | [Library revision]) | ||
30 | |||
31 | AM_CPPFLAGS="-I$srcdir/include" | ||
32 | -AM_CFLAGS="-Wall -Wno-parentheses -Werror" | ||
33 | +AM_CFLAGS="-Wall -Wno-parentheses" | ||
34 | AM_CXXFLAGS="$AM_CFLAGS" | ||
35 | AC_SUBST([AM_CPPFLAGS]) | ||
36 | AC_SUBST([AM_CFLAGS]) | ||
diff --git a/meta-oe/recipes-support/zbar/zbar_0.10.bb b/meta-oe/recipes-support/zbar/zbar_0.10.bb deleted file mode 100644 index 181d7ae43c..0000000000 --- a/meta-oe/recipes-support/zbar/zbar_0.10.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | DESCRIPTION = "2D barcode scanner toolkit." | ||
2 | SECTION = "graphics" | ||
3 | LICENSE = "LGPL-2.1" | ||
4 | |||
5 | DEPENDS = "pkgconfig intltool-native libpng jpeg" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=4015840237ca7f0175cd626f78714ca8" | ||
8 | |||
9 | PV = "0.10+git${SRCPV}" | ||
10 | |||
11 | # iPhoneSDK-1.3.1 tag | ||
12 | SRCREV = "67003d2a985b5f9627bee2d8e3e0b26d0c474b57" | ||
13 | SRC_URI = "git://github.com/ZBar/Zbar \ | ||
14 | file://0001-make-relies-GNU-extentions.patch \ | ||
15 | " | ||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
19 | |||
20 | PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | ||
21 | |||
22 | PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp" | ||
23 | |||
24 | EXTRA_OECONF = "--without-imagemagick --without-qt --without-python --disable-video --without-gtk" | ||
25 | |||
26 | CPPFLAGS += "-Wno-error" | ||
27 | |||
28 | do_install_append() { | ||
29 | #remove usr/bin if empty | ||
30 | rmdir ${D}${bindir} | ||
31 | } | ||