summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/python/python-futures_3.0.5.bb16
-rw-r--r--meta-oe/recipes-devtools/python/python-futures_3.2.0.bb13
2 files changed, 13 insertions, 16 deletions
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.0.5.bb b/meta-oe/recipes-devtools/python/python-futures_3.0.5.bb
deleted file mode 100644
index c85fc56b83..0000000000
--- a/meta-oe/recipes-devtools/python/python-futures_3.0.5.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables."
2SECTION = "devel/python"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://PKG-INFO;md5=3d78c5bb15ac641d34f2ddc3bd7f51fa"
5HOMEPAGE = "http://code.google.com/p/pythonfutures"
6DEPENDS = "python"
7
8SRC_URI = "https://pypi.python.org/packages/source/f/futures/futures-${PV}.tar.gz"
9SRC_URI[md5sum] = "ced2c365e518242512d7a398b515ff95"
10SRC_URI[sha256sum] = "0542525145d5afc984c88f914a0c85c77527f65946617edb5274f72406f981df"
11
12S = "${WORKDIR}/futures-${PV}"
13
14inherit setuptools
15
16BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-devtools/python/python-futures_3.2.0.bb b/meta-oe/recipes-devtools/python/python-futures_3.2.0.bb
new file mode 100644
index 0000000000..3ee945fc9c
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-futures_3.2.0.bb
@@ -0,0 +1,13 @@
1DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables."
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=834d982f973c48b6d662b5944c5ab567"
5HOMEPAGE = "https://github.com/agronholm/pythonfutures"
6DEPENDS = "python"
7
8SRC_URI[md5sum] = "d1b299a06b96ccb59f70324716dc0016"
9SRC_URI[sha256sum] = "9ec02aa7d674acb8618afb127e27fde7fc68994c0437ad759fa094a574adb265"
10
11inherit pypi setuptools
12
13BBCLASSEXTEND = "native nativesdk"