diff options
-rw-r--r-- | meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch | 96 | ||||
-rw-r--r-- | meta-oe/recipes-support/mcelog/mcelog/mcelog-debash.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-support/mcelog/mcelog_1.49.bb (renamed from meta-oe/recipes-support/mcelog/mcelog_1.40.bb) | 6 |
3 files changed, 2 insertions, 136 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch b/meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch deleted file mode 100644 index f9dfbcab5c..0000000000 --- a/meta-oe/recipes-support/mcelog/mcelog/0001-Add-Kabylake-client-support.patch +++ /dev/null | |||
@@ -1,96 +0,0 @@ | |||
1 | From 11bfbb446116c8313728157148a6bb15625031e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tony Luck <tony.luck@intel.com> | ||
3 | Date: Tue, 30 Aug 2016 09:37:02 -0700 | ||
4 | Subject: [PATCH] Add Kabylake client support | ||
5 | |||
6 | CPU models 0x8E and 0x9E denote kabylake client processor | ||
7 | |||
8 | Upstream-Status: Backport [A little modification on context] | ||
9 | https://github.com/andikleen/mcelog/commit/11bfbb446116c8313728157148a6bb15625031e8 | ||
10 | |||
11 | Signed-off-by: Tony Luck <tony.luck@intel.com> | ||
12 | Signed-off-by: Andi Kleen <ak@linux.intel.com> | ||
13 | Signed-off-by: Quanyang Wang <quanyang.wang@windriver.com> | ||
14 | --- | ||
15 | intel.c | 5 ++++- | ||
16 | intel.h | 3 ++- | ||
17 | mcelog.c | 4 +++- | ||
18 | mcelog.h | 1 + | ||
19 | 4 files changed, 10 insertions(+), 3 deletions(-) | ||
20 | |||
21 | diff --git a/intel.c b/intel.c | ||
22 | index f4ef9f6..33a99a8 100644 | ||
23 | --- a/intel.c | ||
24 | +++ b/intel.c | ||
25 | @@ -35,7 +35,8 @@ void intel_cpu_init(enum cputype cpu) | ||
26 | cpu == CPU_IVY_BRIDGE || cpu == CPU_IVY_BRIDGE_EPEX || | ||
27 | cpu == CPU_HASWELL || cpu == CPU_HASWELL_EPEX || cpu == CPU_BROADWELL || | ||
28 | cpu == CPU_BROADWELL_DE || cpu == CPU_BROADWELL_EPEX || | ||
29 | - cpu == CPU_KNIGHTS_LANDING || cpu == CPU_SKYLAKE || cpu == CPU_SKYLAKE_XEON) | ||
30 | + cpu == CPU_KNIGHTS_LANDING || cpu == CPU_SKYLAKE || cpu == CPU_SKYLAKE_XEON || | ||
31 | + cpu == CPU_KABYLAKE) | ||
32 | memory_error_support = 1; | ||
33 | } | ||
34 | |||
35 | @@ -90,6 +91,8 @@ enum cputype select_intel_cputype(int family, int model) | ||
36 | return CPU_SKYLAKE; | ||
37 | else if (model == 0x55) | ||
38 | return CPU_SKYLAKE_XEON; | ||
39 | + else if (model == 0x8E || model == 0x9E) | ||
40 | + return CPU_KABYLAKE; | ||
41 | if (model > 0x1a) { | ||
42 | Eprintf("Family 6 Model %u CPU: only decoding architectural errors\n", | ||
43 | model); | ||
44 | diff --git a/intel.h b/intel.h | ||
45 | index d22895b..c231925 100644 | ||
46 | --- a/intel.h | ||
47 | +++ b/intel.h | ||
48 | @@ -26,5 +26,6 @@ extern int memory_error_support; | ||
49 | case CPU_ATOM: \ | ||
50 | case CPU_KNIGHTS_LANDING: \ | ||
51 | case CPU_SKYLAKE: \ | ||
52 | - case CPU_SKYLAKE_XEON | ||
53 | + case CPU_SKYLAKE_XEON: \ | ||
54 | + case CPU_KABYLAKE | ||
55 | |||
56 | diff --git a/mcelog.c b/mcelog.c | ||
57 | index 1d79fa1..7214a0d 100644 | ||
58 | --- a/mcelog.c | ||
59 | +++ b/mcelog.c | ||
60 | @@ -238,6 +238,7 @@ static char *cputype_name[] = { | ||
61 | [CPU_ATOM] = "ATOM", | ||
62 | [CPU_SKYLAKE] = "Skylake", | ||
63 | [CPU_SKYLAKE_XEON] = "Skylake server", | ||
64 | + [CPU_KABYLAKE] = "Kabylake", | ||
65 | }; | ||
66 | |||
67 | static struct config_choice cpu_choices[] = { | ||
68 | @@ -287,6 +288,7 @@ static struct config_choice cpu_choices[] = { | ||
69 | { "atom", CPU_ATOM }, | ||
70 | { "skylake", CPU_SKYLAKE }, | ||
71 | { "skylake_server", CPU_SKYLAKE_XEON }, | ||
72 | + { "kabylake", CPU_KABYLAKE }, | ||
73 | { NULL } | ||
74 | }; | ||
75 | |||
76 | @@ -451,7 +453,7 @@ static void dump_mce(struct mce *m, unsigned recordlen) | ||
77 | cputype != CPU_HASWELL_EPEX && cputype != CPU_BROADWELL && | ||
78 | cputype != CPU_BROADWELL_DE && cputype != CPU_BROADWELL_EPEX && | ||
79 | cputype != CPU_KNIGHTS_LANDING && cputype != CPU_SKYLAKE && | ||
80 | - cputype != CPU_SKYLAKE_XEON) | ||
81 | + cputype != CPU_SKYLAKE_XEON && cputype != CPU_KABYLAKE) | ||
82 | resolveaddr(m->addr); | ||
83 | if (!ascii_mode && ismemerr && (m->status & MCI_STATUS_ADDRV)) { | ||
84 | diskdb_resolve_addr(m->addr); | ||
85 | diff --git a/mcelog.h b/mcelog.h | ||
86 | index abc8bc9..254b3a0 100644 | ||
87 | --- a/mcelog.h | ||
88 | +++ b/mcelog.h | ||
89 | @@ -130,6 +130,7 @@ enum cputype { | ||
90 | CPU_ATOM, | ||
91 | CPU_SKYLAKE, | ||
92 | CPU_SKYLAKE_XEON, | ||
93 | + CPU_KABYLAKE, | ||
94 | }; | ||
95 | |||
96 | enum option_ranges { | ||
diff --git a/meta-oe/recipes-support/mcelog/mcelog/mcelog-debash.patch b/meta-oe/recipes-support/mcelog/mcelog/mcelog-debash.patch deleted file mode 100644 index bea2f6293c..0000000000 --- a/meta-oe/recipes-support/mcelog/mcelog/mcelog-debash.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From 8f57d35747a3b3fabc33466563077373090f869c Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Tue, 2 Sep 2014 07:05:15 -0700 | ||
4 | Subject: [PATCH] cache-error-trigger: remove bashism | ||
5 | |||
6 | Use "$(cat $F)" to instead of "$(< $F)" to debash. | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
11 | --- | ||
12 | triggers/cache-error-trigger | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/triggers/cache-error-trigger b/triggers/cache-error-trigger | ||
16 | index e32bfd6..785526f 100755 | ||
17 | --- a/triggers/cache-error-trigger | ||
18 | +++ b/triggers/cache-error-trigger | ||
19 | @@ -1,4 +1,4 @@ | ||
20 | -#!/bin/bash | ||
21 | +#!/bin/sh | ||
22 | # cache error trigger. This shell script is executed by mcelog in daemon mode | ||
23 | # when a CPU reports excessive corrected cache errors. This could be a indication | ||
24 | # for future uncorrected errors. | ||
25 | @@ -28,7 +28,7 @@ for i in $AFFECTED_CPUS ; do | ||
26 | logger -s -p daemon.crit -t mcelog "Offlining CPU $i due to cache error threshold" | ||
27 | F=$(printf "/sys/devices/system/cpu/cpu%d/online" $i) | ||
28 | echo 0 > $F | ||
29 | - if [ "$(< $F)" != "0" ] ; then | ||
30 | + if [ "$(cat $F)" != "0" ] ; then | ||
31 | logger -s -p daemon.warn -t mcelog "Offlining CPU $i failed" | ||
32 | EXIT=1 | ||
33 | fi | ||
34 | -- | ||
35 | 1.7.9.5 | ||
36 | |||
diff --git a/meta-oe/recipes-support/mcelog/mcelog_1.40.bb b/meta-oe/recipes-support/mcelog/mcelog_1.49.bb index 0d359fc4b8..84633a76c9 100644 --- a/meta-oe/recipes-support/mcelog/mcelog_1.40.bb +++ b/meta-oe/recipes-support/mcelog/mcelog_1.49.bb | |||
@@ -6,15 +6,13 @@ HOMEPAGE = "http://mcelog.org/" | |||
6 | SECTION = "System Environment/Base" | 6 | SECTION = "System Environment/Base" |
7 | 7 | ||
8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \ | 8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \ |
9 | file://mcelog-debash.patch \ | ||
10 | file://0001-Add-Kabylake-client-support.patch \ | ||
11 | file://run-ptest \ | 9 | file://run-ptest \ |
12 | " | 10 | " |
13 | 11 | ||
14 | SRCREV = "008c73e6de3a4bf969d1627e695d4efc807aed92" | 12 | SRCREV = "2cfdf29b2ef98ccd5ed42cdde8bbe437e0d6412f" |
15 | 13 | ||
16 | LICENSE = "GPLv2" | 14 | LICENSE = "GPLv2" |
17 | LIC_FILES_CHKSUM = "file://README;md5=3d12dd2a10bdd22379cc4c0fc6949a88" | 15 | LIC_FILES_CHKSUM = "file://README.md;md5=279840fabb191e6cd9150492d31b0e20" |
18 | 16 | ||
19 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
20 | 18 | ||