summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch54
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.12.0.bb (renamed from meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb)3
2 files changed, 1 insertions, 56 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch b/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch
deleted file mode 100644
index 91575d2712..0000000000
--- a/meta-python/recipes-devtools/python/python3-pybind11/0001-Do-not-strip-binaries.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From debd676cd94f92a30b3be45f1245aa13d8c398c0 Mon Sep 17 00:00:00 2001
2From: Philip Balister <philip@balister.org>
3Date: Wed, 8 Jul 2020 09:41:43 -0400
4Subject: [PATCH] Do not strip binaries.
5
6 * OpenEmbedded strips them after creating debug packages.
7
8Signed-off-by: Philip Balister <philip@balister.org>
9Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
10
11Upstream-Status: Pending
12---
13 tools/pybind11NewTools.cmake | 7 -------
14 tools/pybind11Tools.cmake | 6 ------
15 2 files changed, 13 deletions(-)
16
17diff --git a/tools/pybind11NewTools.cmake b/tools/pybind11NewTools.cmake
18index 7d7424a7..accd90c4 100644
19--- a/tools/pybind11NewTools.cmake
20+++ b/tools/pybind11NewTools.cmake
21@@ -233,13 +233,6 @@ function(pybind11_add_module target_name)
22 endif()
23 endif()
24
25- # Use case-insensitive comparison to match the result of $<CONFIG:cfgs>
26- string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
27- if(NOT MSVC AND NOT "${uppercase_CMAKE_BUILD_TYPE}" MATCHES DEBUG|RELWITHDEBINFO)
28- # Strip unnecessary sections of the binary on Linux/macOS
29- pybind11_strip(${target_name})
30- endif()
31-
32 if(MSVC)
33 target_link_libraries(${target_name} PRIVATE pybind11::windows_extras)
34 endif()
35diff --git a/tools/pybind11Tools.cmake b/tools/pybind11Tools.cmake
36index 66ad00a4..855ede41 100644
37--- a/tools/pybind11Tools.cmake
38+++ b/tools/pybind11Tools.cmake
39@@ -212,12 +212,6 @@ function(pybind11_add_module target_name)
40 endif()
41 endif()
42
43- # Use case-insensitive comparison to match the result of $<CONFIG:cfgs>
44- string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
45- if(NOT MSVC AND NOT "${uppercase_CMAKE_BUILD_TYPE}" MATCHES DEBUG|RELWITHDEBINFO)
46- pybind11_strip(${target_name})
47- endif()
48-
49 if(MSVC)
50 target_link_libraries(${target_name} PRIVATE pybind11::windows_extras)
51 endif()
52--
532.39.2
54
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.12.0.bb
index 78662fe3cd..0403e406a4 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.12.0.bb
@@ -7,10 +7,9 @@ DEPENDS = "\
7 python3-ninja-native \ 7 python3-ninja-native \
8" 8"
9 9
10SRCREV = "8a099e44b3d5f85b20f05828d919d2332a8de841" 10SRCREV = "3e9dfa2866941655c56877882565e7577de6fc7b"
11SRC_URI = "\ 11SRC_URI = "\
12 git://github.com/pybind/pybind11.git;branch=stable;protocol=https \ 12 git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
13 file://0001-Do-not-strip-binaries.patch \
14" 13"
15 14
16S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"