diff options
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/PTHREAD_STACK_MIN.patch | 19 | ||||
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | 7 |
2 files changed, 23 insertions, 3 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/PTHREAD_STACK_MIN.patch b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/PTHREAD_STACK_MIN.patch new file mode 100644 index 0000000000..f08177d7b4 --- /dev/null +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/PTHREAD_STACK_MIN.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | PTHREAD_STACK_MIN is no longer a compile time define in glibc 2.34+ and since | ||
2 | we only care for glibc and musl where PTHREAD_STACK_MIN is always defined there | ||
3 | is no need to check for constant called PTHREAD_STACK_MIN since its already defined | ||
4 | this fix may not work for wider audience but for OE needs its sufficient | ||
5 | |||
6 | Upstream-Status: Inappropriate [OE-only fix] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- a/src/third_party/boost-1.70.0/boost/thread/pthread/thread_data.hpp | ||
9 | +++ b/src/third_party/boost-1.70.0/boost/thread/pthread/thread_data.hpp | ||
10 | @@ -57,9 +57,7 @@ namespace boost | ||
11 | #else | ||
12 | std::size_t page_size = ::sysconf( _SC_PAGESIZE); | ||
13 | #endif | ||
14 | -#if PTHREAD_STACK_MIN > 0 | ||
15 | if (size<PTHREAD_STACK_MIN) size=PTHREAD_STACK_MIN; | ||
16 | -#endif | ||
17 | size = ((size+page_size-1)/page_size)*page_size; | ||
18 | int res = pthread_attr_setstacksize(&val_, size); | ||
19 | BOOST_VERIFY(!res && "pthread_attr_setstacksize failed"); | ||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb index 9c1e485b31..9d461078ae 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -11,9 +11,9 @@ DEPENDS = "openssl libpcap zlib boost curl python3 \ | |||
11 | 11 | ||
12 | inherit scons dos2unix siteinfo python3native systemd useradd | 12 | inherit scons dos2unix siteinfo python3native systemd useradd |
13 | 13 | ||
14 | PV = "4.4.6" | 14 | PV = "4.4.7" |
15 | #v4.4.6 | 15 | #v4.4.7 |
16 | SRCREV = "72e66213c2c3eab37d9358d5e78ad7f5c1d0d0d7" | 16 | SRCREV = "abb6b9c2bf675e9e2aeaecba05f0f8359d99e203" |
17 | SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4 \ | 17 | SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4 \ |
18 | file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \ | 18 | file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \ |
19 | file://0001-Use-long-long-instead-of-int64_t.patch \ | 19 | file://0001-Use-long-long-instead-of-int64_t.patch \ |
@@ -31,6 +31,7 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4 \ | |||
31 | file://ppc64_ARCH_BITS.patch \ | 31 | file://ppc64_ARCH_BITS.patch \ |
32 | file://0001-Do-not-use-MINSIGSTKSZ.patch \ | 32 | file://0001-Do-not-use-MINSIGSTKSZ.patch \ |
33 | file://0001-Use-explicit-typecast-to-size_t.patch \ | 33 | file://0001-Use-explicit-typecast-to-size_t.patch \ |
34 | file://PTHREAD_STACK_MIN.patch \ | ||
34 | " | 35 | " |
35 | SRC_URI_append_libc-musl ="\ | 36 | SRC_URI_append_libc-musl ="\ |
36 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ | 37 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ |