diff options
-rw-r--r-- | meta-python/recipes-extended/python-pyparted/python-pyparted.inc | 22 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb | 23 |
2 files changed, 21 insertions, 24 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc deleted file mode 100644 index 97054487f9..0000000000 --- a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \ | ||
2 | an interface to libparted, the GNU parted library for disk partitioning and \ | ||
3 | filesystem manipulation." | ||
4 | SUMMARY = "Python bindings for libparted" | ||
5 | HOMEPAGE = "https://github.com/rhinstaller/pyparted" | ||
6 | LICENSE = "GPL-2.0+" | ||
7 | LIC_FILES_CHKSUM = "\ | ||
8 | file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \ | ||
9 | file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \ | ||
10 | " | ||
11 | DEPENDS += "parted" | ||
12 | |||
13 | # upstream only publishes releases in github archives which are discouraged | ||
14 | SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8" | ||
15 | SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | RDEPENDS_${PN}_class-target += " \ | ||
20 | parted (>= 2.3) \ | ||
21 | " | ||
22 | RDEPENDS_${PN}_class-native = "" | ||
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb index d83901ff3a..a801920c09 100644 --- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb +++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb | |||
@@ -1,8 +1,27 @@ | |||
1 | require python-pyparted.inc | 1 | DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \ |
2 | an interface to libparted, the GNU parted library for disk partitioning and \ | ||
3 | filesystem manipulation." | ||
4 | SUMMARY = "Python bindings for libparted" | ||
5 | HOMEPAGE = "https://github.com/rhinstaller/pyparted" | ||
6 | LICENSE = "GPL-2.0+" | ||
7 | LIC_FILES_CHKSUM = "\ | ||
8 | file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \ | ||
9 | file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \ | ||
10 | " | ||
11 | DEPENDS += "parted" | ||
12 | |||
13 | # upstream only publishes releases in github archives which are discouraged | ||
14 | SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8" | ||
15 | SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https" | ||
2 | 16 | ||
3 | inherit distutils3 | 17 | inherit distutils3 |
4 | 18 | ||
5 | RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math" | 19 | S = "${WORKDIR}/git" |
20 | |||
21 | RDEPENDS_${PN}_class-target += " \ | ||
22 | parted (>= 2.3) \ | ||
23 | python3-stringold python3-codecs python3-math \ | ||
24 | " | ||
6 | RDEPENDS_${PN}_class-native = "" | 25 | RDEPENDS_${PN}_class-native = "" |
7 | 26 | ||
8 | BBCLASSEXTEND = "native" | 27 | BBCLASSEXTEND = "native" |