summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted.inc22
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb23
2 files changed, 21 insertions, 24 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
deleted file mode 100644
index 97054487f9..0000000000
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://github.com/rhinstaller/pyparted"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "\
8 file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9 file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
10"
11DEPENDS += "parted"
12
13# upstream only publishes releases in github archives which are discouraged
14SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
15SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
16
17S = "${WORKDIR}/git"
18
19RDEPENDS_${PN}_class-target += " \
20 parted (>= 2.3) \
21"
22RDEPENDS_${PN}_class-native = ""
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
index d83901ff3a..a801920c09 100644
--- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
+++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
@@ -1,8 +1,27 @@
1require python-pyparted.inc 1DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://github.com/rhinstaller/pyparted"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "\
8 file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9 file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
10"
11DEPENDS += "parted"
12
13# upstream only publishes releases in github archives which are discouraged
14SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
15SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
2 16
3inherit distutils3 17inherit distutils3
4 18
5RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math" 19S = "${WORKDIR}/git"
20
21RDEPENDS_${PN}_class-target += " \
22 parted (>= 2.3) \
23 python3-stringold python3-codecs python3-math \
24"
6RDEPENDS_${PN}_class-native = "" 25RDEPENDS_${PN}_class-native = ""
7 26
8BBCLASSEXTEND = "native" 27BBCLASSEXTEND = "native"