summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-prettytable.inc43
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb38
2 files changed, 36 insertions, 45 deletions
diff --git a/meta-python/recipes-devtools/python/python-prettytable.inc b/meta-python/recipes-devtools/python/python-prettytable.inc
deleted file mode 100644
index c77a49191e..0000000000
--- a/meta-python/recipes-devtools/python/python-prettytable.inc
+++ /dev/null
@@ -1,43 +0,0 @@
1SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
5
6SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
7SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
8
9SRCNAME = "prettytable"
10
11SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
12
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15do_install_append() {
16 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
17 for f in $perm_files; do
18 chmod 644 "${f}"
19 done
20}
21
22UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
23UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
24
25BBCLASSEXTEND = "native nativesdk"
26inherit ptest
27
28SRC_URI += " \
29 file://run-ptest \
30"
31
32RDEPENDS_${PN} += " \
33 ${PYTHON_PN}-math \
34 ${PYTHON_PN}-html \
35"
36
37RDEPENDS_${PN}-ptest += " \
38 ${PYTHON_PN}-pytest \
39"
40
41do_install_ptest() {
42 cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
43}
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
index 5445f10192..18f3390619 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
@@ -1,3 +1,37 @@
1inherit setuptools3 1SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2require python-prettytable.inc 2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
3 5
6SRC_URI[md5sum] = "a6b80afeef286ce66733d54a0296b13b"
7SRC_URI[sha256sum] = "2d5460dc9db74a32bcc8f9f67de68b2c4f4d2f01fa3bd518764c69156d9cacd9"
8
9do_install_append() {
10 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
11 for f in $perm_files; do
12 chmod 644 "${f}"
13 done
14}
15
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
17UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
18
19BBCLASSEXTEND = "native nativesdk"
20inherit pypi ptest setuptools3
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
26RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-math \
28 ${PYTHON_PN}-html \
29"
30
31RDEPENDS_${PN}-ptest += " \
32 ${PYTHON_PN}-pytest \
33"
34
35do_install_ptest() {
36 cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
37}