diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-prettytable.inc | 43 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb | 38 |
2 files changed, 36 insertions, 45 deletions
diff --git a/meta-python/recipes-devtools/python/python-prettytable.inc b/meta-python/recipes-devtools/python/python-prettytable.inc deleted file mode 100644 index c77a49191e..0000000000 --- a/meta-python/recipes-devtools/python/python-prettytable.inc +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | SUMMARY = "Python library for displaying tabular data in a ASCII table format" | ||
2 | HOMEPAGE = "http://code.google.com/p/prettytable" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282" | ||
5 | |||
6 | SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899" | ||
7 | SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f" | ||
8 | |||
9 | SRCNAME = "prettytable" | ||
10 | |||
11 | SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip" | ||
12 | |||
13 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
14 | |||
15 | do_install_append() { | ||
16 | perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"` | ||
17 | for f in $perm_files; do | ||
18 | chmod 644 "${f}" | ||
19 | done | ||
20 | } | ||
21 | |||
22 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/" | ||
23 | UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)" | ||
24 | |||
25 | BBCLASSEXTEND = "native nativesdk" | ||
26 | inherit ptest | ||
27 | |||
28 | SRC_URI += " \ | ||
29 | file://run-ptest \ | ||
30 | " | ||
31 | |||
32 | RDEPENDS_${PN} += " \ | ||
33 | ${PYTHON_PN}-math \ | ||
34 | ${PYTHON_PN}-html \ | ||
35 | " | ||
36 | |||
37 | RDEPENDS_${PN}-ptest += " \ | ||
38 | ${PYTHON_PN}-pytest \ | ||
39 | " | ||
40 | |||
41 | do_install_ptest() { | ||
42 | cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/ | ||
43 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb index 5445f10192..18f3390619 100644 --- a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb +++ b/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb | |||
@@ -1,3 +1,37 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Python library for displaying tabular data in a ASCII table format" |
2 | require python-prettytable.inc | 2 | HOMEPAGE = "http://code.google.com/p/prettytable" |
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282" | ||
3 | 5 | ||
6 | SRC_URI[md5sum] = "a6b80afeef286ce66733d54a0296b13b" | ||
7 | SRC_URI[sha256sum] = "2d5460dc9db74a32bcc8f9f67de68b2c4f4d2f01fa3bd518764c69156d9cacd9" | ||
8 | |||
9 | do_install_append() { | ||
10 | perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"` | ||
11 | for f in $perm_files; do | ||
12 | chmod 644 "${f}" | ||
13 | done | ||
14 | } | ||
15 | |||
16 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/" | ||
17 | UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)" | ||
18 | |||
19 | BBCLASSEXTEND = "native nativesdk" | ||
20 | inherit pypi ptest setuptools3 | ||
21 | |||
22 | SRC_URI += " \ | ||
23 | file://run-ptest \ | ||
24 | " | ||
25 | |||
26 | RDEPENDS_${PN} += " \ | ||
27 | ${PYTHON_PN}-math \ | ||
28 | ${PYTHON_PN}-html \ | ||
29 | " | ||
30 | |||
31 | RDEPENDS_${PN}-ptest += " \ | ||
32 | ${PYTHON_PN}-pytest \ | ||
33 | " | ||
34 | |||
35 | do_install_ptest() { | ||
36 | cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/ | ||
37 | } | ||