summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch39
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb3
2 files changed, 1 insertions, 41 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch b/meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch
deleted file mode 100644
index c5b9083dca..0000000000
--- a/meta-oe/recipes-devtools/openocd/openocd/0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From b95a996bfb281104b68ec66f32ebb79db519a4a8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 31 May 2018 21:06:46 -0700
4Subject: [PATCH] Fix libusb-1.0.22 deprecated libusb_set_debug with
5 libusb_set_option
6
7libusb_set_debug is deprecated in libusb >= 1.0.22 therefore replace
8with equivalent libusb_set_option() API
9
10see libusb commit for more details
11
12https://github.com/libusb/libusb/commit/539f22e2fd916558d11ab9a66f10f461c5593168
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16Upstream-Status: Submitted [http://openocd.zylin.com/#/c/4540/]
17 src/jtag/drivers/xds110.c | 5 ++++-
18 1 file changed, 4 insertions(+), 1 deletion(-)
19
20diff --git a/src/jtag/drivers/xds110.c b/src/jtag/drivers/xds110.c
21index 90b699027..9bfe02ea8 100644
22--- a/src/jtag/drivers/xds110.c
23+++ b/src/jtag/drivers/xds110.c
24@@ -367,8 +367,11 @@ static bool usb_connect(void)
25
26 /* Set libusb to auto detach kernel and disable debug messages */
27 (void)libusb_set_auto_detach_kernel_driver(dev, 1);
28+#if LIBUSB_API_VERSION >= 0x01000106
29+ libusb_set_option(ctx, LIBUSB_OPTION_LOG_LEVEL, LIBUSB_LOG_LEVEL_NONE);
30+#else
31 libusb_set_debug(ctx, LIBUSB_LOG_LEVEL_NONE);
32-
33+#endif
34 /* Claim the debug interface on the XDS110 */
35 result = libusb_claim_interface(dev, INTERFACE_DEBUG);
36 } else {
37--
382.17.1
39
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 4377e88e47..9a8a09a913 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -9,11 +9,10 @@ SRC_URI = " \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ 9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ 10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ 11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
12 file://0001-Fix-libusb-1.0.22-deprecated-libusb_set_debug-with-l.patch \
13" 12"
14 13
15SRCREV_FORMAT = "openocd" 14SRCREV_FORMAT = "openocd"
16SRCREV_openocd = "cdf1e826eb23c29de1019ce64125f644f01b0afe" 15SRCREV_openocd = "7ee618692f56b0efea864890da45d73d28e393d9"
17SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" 16SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
18SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787" 17SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
19SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b" 18SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b"