summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch43
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_6.10.bb (renamed from meta-networking/recipes-support/cifs/cifs-utils_6.9.bb)8
2 files changed, 49 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch b/meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch
new file mode 100644
index 0000000000..233ae40ce0
--- /dev/null
+++ b/meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch
@@ -0,0 +1,43 @@
1From f61f5f8a328207867b5c523b1c6bef6aaecaab88 Mon Sep 17 00:00:00 2001
2From: Wang Mingyu <wangmy@cn.fujitsu.com>
3Date: Sat, 15 Feb 2020 16:05:58 +0800
4Subject: [PATCH] Bugfix: Modify the dir of install-exec-hook and
5 install-data-hook
6
7Error message:
8(cd /sbin && ln -sf mount.cifs mount.smb3)
9 /yocto/work001/fnst/wangmy/build/tmp/hosttools/install -c mount.cifs
10'/yocto/work001/fnst/wangmy/build/tmp/work/core2-64-poky-linux/cifs-utils/6.10-r0/image/sbin'
11make install-data-hook
12ln: failed to create symbolic link 'mount.smb3': Permission denied
13
14Upstream-Status: Pending
15
16Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
17---
18 Makefile.am | 8 ++++----
19 1 file changed, 4 insertions(+), 4 deletions(-)
20
21diff --git a/Makefile.am b/Makefile.am
22index fe9cd34..e9be6b3 100644
23--- a/Makefile.am
24+++ b/Makefile.am
25@@ -119,11 +119,11 @@ endif
26 SUBDIRS = contrib
27
28 install-exec-hook:
29- (cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
30+ (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
31
32 install-data-hook:
33- (cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
34+ (test -n "$(man_MANS)" || exit 0; cd $(DESTDIR)$(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
35
36 uninstall-hook:
37- (cd $(ROOTSBINDIR) && rm -f $(ROOTSBINDIR)/mount.smb3)
38- (cd $(man8dir) && rm -f $(man8dir)/mount.smb3.8)
39+ (cd $(DESTDIR)$(ROOTSBINDIR) && rm -f $(DESTDIR)$(ROOTSBINDIR)/mount.smb3)
40+ (test -n "$(man_MANS)" || exit 0; cd $(DESTDIR)$(man8dir) && rm -f $(DESTDIR)$(man8dir)/mount.smb3.8)
41--
422.17.1
43
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_6.9.bb b/meta-networking/recipes-support/cifs/cifs-utils_6.10.bb
index 51dcb23d11..8d82ee4546 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_6.9.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_6.10.bb
@@ -4,9 +4,9 @@ SECTION = "otherosfs"
4LICENSE = "GPLv3 & LGPLv3" 4LICENSE = "GPLv3 & LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6 6
7PV = "6.9" 7PV = "6.10"
8 8
9SRCREV = "9a8c21ad9e4510a83a3a41f7a04f763a4fe9ec09" 9SRCREV = "5ff5fc2ecc10353fd39ad508db5c2828fd2d8d9a"
10SRC_URI = "git://git.samba.org/cifs-utils.git" 10SRC_URI = "git://git.samba.org/cifs-utils.git"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
@@ -22,6 +22,10 @@ PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samb
22PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba" 22PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
23PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils" 23PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
24 24
25SRC_URI += " \
26 file://0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch \
27 "
28
25inherit autotools pkgconfig 29inherit autotools pkgconfig
26 30
27do_install_append() { 31do_install_append() {