diff options
-rw-r--r-- | meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb new file mode 100644 index 0000000000..a7478d4d5b --- /dev/null +++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | # SPDX-FileCopyrightText: Huawei Inc. | ||
2 | # SPDX-License-Identifier: MIT | ||
3 | |||
4 | # TODO: Pin upstream release (current v7.11.0-80-g419a757) | ||
5 | src_org = "lvgl" | ||
6 | SRC_URI = "gitsm://github.com/${src_org}/lv_drivers;destsuffix=${S};protocol=https;nobranch=1" | ||
7 | SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254" | ||
8 | |||
9 | LICENSE = "MIT" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2" | ||
11 | |||
12 | HOMEPAGE = "https://docs.lvgl.io/latest/en/html/porting/index.html" | ||
13 | SUMMARY = "LVGL's Display and Touch pad drivers" | ||
14 | DESCRIPTION = "Collection of drivers: SDL, framebuffer, wayland and more..." | ||
15 | |||
16 | DEPENDS += "libxkbcommon" | ||
17 | DEPENDS += "lvgl" | ||
18 | DEPENDS += "wayland" | ||
19 | |||
20 | REQUIRED_DISTRO_FEATURES = "wayland" | ||
21 | |||
22 | inherit cmake | ||
23 | inherit features_check | ||
24 | |||
25 | S = "${WORKDIR}/${PN}-${PV}" | ||
26 | |||
27 | EXTRA_OECMAKE += "-Dinstall:BOOL=ON" | ||
28 | |||
29 | TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1" | ||
30 | TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl" | ||
31 | |||
32 | |||
33 | do_configure:append() { | ||
34 | [ -r "${S}/lv_drv_conf.h" ] \ | ||
35 | || sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \ | ||
36 | -e "s|# define USE_WAYLAND 0|# define USE_WAYLAND 1|g" \ | ||
37 | < "${S}/lv_drv_conf_template.h" > "${S}/lv_drv_conf.h" | ||
38 | } | ||
39 | |||
40 | |||
41 | FILES:${PN}-dev = "\ | ||
42 | ${includedir}/lvgl/lv_drivers/ \ | ||
43 | " | ||
44 | |||
45 | FILES:${PN}-staticdev = "${libdir}/" | ||