diff options
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch | 23 | ||||
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_2.6.2.bb | 1 |
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch b/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch new file mode 100644 index 0000000000..80119e3fde --- /dev/null +++ b/meta-networking/recipes-support/wireshark/wireshark/fix-fatal-no-names-found-git-error.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | fixes | ||
2 | |||
3 | | fatal: No names found, cannot describe anything. | ||
4 | | CMake Error at CMakeLists.txt:3086 (string): | ||
5 | | string begin index: 1 is out of range 0 - 0 | ||
6 | |||
7 | Use always to circumvent the issue if git tag is not present | ||
8 | |||
9 | Upstream-status: Pending | ||
10 | |||
11 | Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> | ||
12 | --- | ||
13 | --- wireshark-2.6.1/CMakeLists.txt 2018-08-08 18:18:05.388318652 -0700 | ||
14 | +++ wireshark-2.6.1/CMakeLists-fix.txt 2018-08-08 18:22:27.829670496 -0700 | ||
15 | @@ -3078,7 +3078,7 @@ | ||
16 | endif() | ||
17 | |||
18 | execute_process( | ||
19 | - COMMAND git describe --abbrev=8 --match v[1-9]* | ||
20 | + COMMAND git describe --always --abbrev=8 --match v[1-9]* | ||
21 | OUTPUT_VARIABLE _git_description | ||
22 | OUTPUT_STRIP_TRAILING_WHITESPACE | ||
23 | WORKING_DIRECTORY ${CMAKE_SOURCE_DIR} | ||
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.6.2.bb b/meta-networking/recipes-support/wireshark/wireshark_2.6.2.bb index 1735ae7fe0..e949080e1b 100644 --- a/meta-networking/recipes-support/wireshark/wireshark_2.6.2.bb +++ b/meta-networking/recipes-support/wireshark/wireshark_2.6.2.bb | |||
@@ -10,6 +10,7 @@ DEPENDS_append_class-target = " wireshark-native chrpath-replacement-native " | |||
10 | 10 | ||
11 | SRC_URI = "https://1.as.dl.wireshark.org/src/${BP}.tar.xz \ | 11 | SRC_URI = "https://1.as.dl.wireshark.org/src/${BP}.tar.xz \ |
12 | file://0001-Add-libm-to-link-for-fmod-API.patch \ | 12 | file://0001-Add-libm-to-link-for-fmod-API.patch \ |
13 | file://fix-fatal-no-names-found-git-error.patch \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src" | 16 | UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src" |