diff options
-rw-r--r-- | meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch | 42 | ||||
-rw-r--r-- | meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb | 1 |
2 files changed, 0 insertions, 43 deletions
diff --git a/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch b/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch deleted file mode 100644 index 1ba6847d2f..0000000000 --- a/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | From 42976ed0a0160864b41680604ea9cdb3c175cb94 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 15 Jan 2020 17:48:28 -0800 | ||
4 | Subject: [PATCH] Use overloadable attribute with clang | ||
5 | |||
6 | This is overriding the libc implementation | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | librdmacm/preload.c | 8 +++++++- | ||
12 | 1 file changed, 7 insertions(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/librdmacm/preload.c b/librdmacm/preload.c | ||
15 | index d46beb1b..b451de50 100644 | ||
16 | --- a/librdmacm/preload.c | ||
17 | +++ b/librdmacm/preload.c | ||
18 | @@ -59,6 +59,12 @@ | ||
19 | #include "cma.h" | ||
20 | #include "indexer.h" | ||
21 | |||
22 | +#ifdef __clang__ | ||
23 | +#define OVERLOAD __attribute__((overloadable)) | ||
24 | +#else | ||
25 | +#define OVERLOAD | ||
26 | +#endif | ||
27 | + | ||
28 | struct socket_calls { | ||
29 | int (*socket)(int domain, int type, int protocol); | ||
30 | int (*bind)(int socket, const struct sockaddr *addr, socklen_t addrlen); | ||
31 | @@ -793,7 +799,7 @@ ssize_t recv(int socket, void *buf, size_t len, int flags) | ||
32 | rrecv(fd, buf, len, flags) : real.recv(fd, buf, len, flags); | ||
33 | } | ||
34 | |||
35 | -ssize_t recvfrom(int socket, void *buf, size_t len, int flags, | ||
36 | +ssize_t OVERLOAD recvfrom(int socket, void *buf, size_t len, int flags, | ||
37 | struct sockaddr *src_addr, socklen_t *addrlen) | ||
38 | { | ||
39 | int fd; | ||
40 | -- | ||
41 | 2.25.0 | ||
42 | |||
diff --git a/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb b/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb index 417979dc33..361d69b337 100644 --- a/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb +++ b/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb | |||
@@ -9,7 +9,6 @@ BRANCH = "stable-v${@d.getVar('PV').split('.')[0]}" | |||
9 | SRC_URI = "git://github.com/linux-rdma/rdma-core.git;branch=${BRANCH} \ | 9 | SRC_URI = "git://github.com/linux-rdma/rdma-core.git;branch=${BRANCH} \ |
10 | file://0001-Remove-man-files-which-cant-be-built.patch \ | 10 | file://0001-Remove-man-files-which-cant-be-built.patch \ |
11 | file://0001-librdmacm-Use-sched_yield-instead-of-pthread_yield.patch \ | 11 | file://0001-librdmacm-Use-sched_yield-instead-of-pthread_yield.patch \ |
12 | file://0001-Use-overloadable-attribute-with-clang.patch \ | ||
13 | " | 12 | " |
14 | SRCREV = "84caf035ae6123e2296b72006cd2cf698c65eb46" | 13 | SRCREV = "84caf035ae6123e2296b72006cd2cf698c65eb46" |
15 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |