summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb35
1 files changed, 22 insertions, 13 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index 9d63e5b73b..f758781e38 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -1,18 +1,20 @@
1DESCRIPTION = "Wireless daemon for Linux" 1SUMMARY = "Wireless daemon for Linux"
2HOMEPAGE = "https://iwd.wiki.kernel.org/"
2LICENSE = "LGPL-2.1" 3LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" 4LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
4 5
5inherit autotools manpages pkgconfig systemd python3native
6
7DEPENDS = "ell" 6DEPENDS = "ell"
8 7
9SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \ 8SRC_URI = " \
10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \ 9 git://git.kernel.org/pub/scm/network/wireless/iwd.git \
11 file://0001-build-Support-missing-rawmemchr.patch \ 10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
12 " 11 file://0001-build-Support-missing-rawmemchr.patch \
12"
13SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261" 13SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16inherit autotools manpages pkgconfig python3native systemd
17
16PACKAGECONFIG ??= " \ 18PACKAGECONFIG ??= " \
17 client \ 19 client \
18 monitor \ 20 monitor \
@@ -25,10 +27,15 @@ PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
25PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" 27PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
26PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" 28PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
27 29
28EXTRA_OECONF += "--enable-external-ell" 30EXTRA_OECONF = "--enable-external-ell"
29 31
30do_configure_prepend () { 32SYSTEMD_SERVICE_${PN} = " \
31 mkdir -p ${S}/build-aux 33 iwd.service \
34 ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
35"
36
37do_configure_prepend() {
38 install -d ${S}/build-aux
32} 39}
33 40
34do_install_append() { 41do_install_append() {
@@ -36,9 +43,11 @@ do_install_append() {
36 rmdir --ignore-fail-on-non-empty ${D}/${bindir} 43 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
37} 44}
38 45
39FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_unitdir}/network/" 46FILES_${PN} += " \
40 47 ${datadir}/dbus-1 \
41SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}" 48 ${nonarch_libdir}/modules-load.d \
49 ${systemd_unitdir}/network \
50"
42 51
43RDEPENDS_${PN} = "dbus" 52RDEPENDS_${PN} = "dbus"
44 53