diff options
3 files changed, 15 insertions, 30 deletions
diff --git a/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb b/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb deleted file mode 100644 index bb0aad3413..0000000000 --- a/meta-oe/recipes-benchmark/analyze-suspend/analyze-suspend_5.5.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "Analyze Suspend" | ||
2 | DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \ | ||
3 | the activity between suspend and resume, allowing them to identify \ | ||
4 | inefficiencies and bottlenecks." | ||
5 | HOMEPAGE = "https://01.org/suspendresume" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" | ||
8 | |||
9 | # Apart from the listed RDEPENDS, analyze-suspend depends on some features | ||
10 | # provided by the kernel. These options are: | ||
11 | # - CONFIG_PM_DEBUG=y | ||
12 | # - CONFIG_PM_SLEEP_DEBUG=y | ||
13 | # - CONFIG_FTRACE=y | ||
14 | # - CONFIG_FUNCTION_TRACER=y | ||
15 | # - CONFIG_FUNCTION_GRAPH_TRACER=y | ||
16 | |||
17 | RDEPENDS_${PN} += "python-core python-datetime python-stringold" | ||
18 | |||
19 | SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https" | ||
20 | SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | do_install() { | ||
25 | install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py | ||
26 | install -Dm 0644 README ${D}${docdir}/analyze-suspend/README | ||
27 | } | ||
28 | |||
29 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb index bad4aa769e..d2e8ea4af8 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb | |||
@@ -46,7 +46,7 @@ RDEPENDS_packagegroup-meta-oe = "\ | |||
46 | " | 46 | " |
47 | 47 | ||
48 | RDEPENDS_packagegroup-meta-oe-benchmarks = "\ | 48 | RDEPENDS_packagegroup-meta-oe-benchmarks = "\ |
49 | analyze-suspend dhrystone iperf2 linpack phoronix-test-suite \ | 49 | dhrystone iperf2 linpack phoronix-test-suite \ |
50 | tiobench bonnie++ fio iperf2 iperf3 lmbench s-suite whetstone \ | 50 | tiobench bonnie++ fio iperf2 iperf3 lmbench s-suite whetstone \ |
51 | libc-bench memtester sysbench dbench iozone3 libhugetlbfs \ | 51 | libc-bench memtester sysbench dbench iozone3 libhugetlbfs \ |
52 | nbench-byte tinymembench \ | 52 | nbench-byte tinymembench \ |
@@ -196,6 +196,9 @@ RDEPENDS_packagegroup-meta-oe-kernel ="\ | |||
196 | agent-proxy broadcom-bt-firmware cpupower \ | 196 | agent-proxy broadcom-bt-firmware cpupower \ |
197 | crash ipmitool minicoredumper oprofile \ | 197 | crash ipmitool minicoredumper oprofile \ |
198 | " | 198 | " |
199 | RDEPENDS_packagegroup-meta-oe-kernel_append_x86 = " pm-graph " | ||
200 | RDEPENDS_packagegroup-meta-oe-kernel_append_x86-64 = " pm-graph " | ||
201 | |||
199 | RDEPENDS_packagegroup-meta-oe-kernel_remove_libc-musl = "crash minicoredumper" | 202 | RDEPENDS_packagegroup-meta-oe-kernel_remove_libc-musl = "crash minicoredumper" |
200 | 203 | ||
201 | RDEPENDS_packagegroup-meta-oe-kernel_remove_mips64 = "crash" | 204 | RDEPENDS_packagegroup-meta-oe-kernel_remove_mips64 = "crash" |
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb index 63a9fa88e9..a1378866ad 100644 --- a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb +++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb | |||
@@ -12,11 +12,22 @@ SRC_URI = "git://github.com/intel/pm-graph.git \ | |||
12 | " | 12 | " |
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | # Apart from the listed RDEPENDS, analyze-suspend depends on some features | ||
16 | # provided by the kernel. These options are: | ||
17 | # - CONFIG_PM_DEBUG=y | ||
18 | # - CONFIG_PM_SLEEP_DEBUG=y | ||
19 | # - CONFIG_FTRACE=y | ||
20 | # - CONFIG_FUNCTION_TRACER=y | ||
21 | # - CONFIG_FUNCTION_GRAPH_TRACER=y | ||
22 | |||
15 | COMPATIBLE_HOST='(i.86|x86_64).*' | 23 | COMPATIBLE_HOST='(i.86|x86_64).*' |
16 | EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}" | 24 | EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}" |
17 | 25 | ||
18 | do_install() { | 26 | do_install() { |
19 | oe_runmake install | 27 | oe_runmake install |
28 | install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py | ||
20 | } | 29 | } |
21 | 30 | ||
22 | RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression" | 31 | RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression" |
32 | RPROVIDES_${PN} = "analyze-suspend" | ||
33 | BBCLASSEXTEND = "native nativesdk" | ||