diff options
-rw-r--r-- | meta-networking/recipes-connectivity/libiec61850/files/0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch (renamed from meta-networking/recipes-connectivity/libiec61850/files/0003-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch) | 4 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/libiec61850/files/0001-use-poll.h-instead-of-sys-poll.h.patch | 33 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/libiec61850/files/0002-serial_port_linux-Add-missing-include-sys-time.h.patch | 32 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.0.bb (renamed from meta-networking/recipes-connectivity/libiec61850/libiec61850_1.4.2.1.bb) | 8 |
4 files changed, 5 insertions, 72 deletions
diff --git a/meta-networking/recipes-connectivity/libiec61850/files/0003-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch b/meta-networking/recipes-connectivity/libiec61850/files/0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch index 65567610b9..2168a0713c 100644 --- a/meta-networking/recipes-connectivity/libiec61850/files/0003-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch +++ b/meta-networking/recipes-connectivity/libiec61850/files/0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 89f326a427c7ad13c115e2d3f2ac27807aa5a795 Mon Sep 17 00:00:00 2001 | 1 | From d4ddfc7a350011b7944ed8d6bca80f164dfd1387 Mon Sep 17 00:00:00 2001 |
2 | From: Romain Naour <romain.naour@smile.fr> | 2 | From: Romain Naour <romain.naour@smile.fr> |
3 | Date: Fri, 10 Jul 2020 17:08:34 +0200 | 3 | Date: Fri, 10 Jul 2020 17:08:34 +0200 |
4 | Subject: [PATCH] pyiec61850: don't break CMAKE_INSTALL_PATH by trying to find | 4 | Subject: [PATCH] pyiec61850: don't break CMAKE_INSTALL_PATH by trying to find |
@@ -33,5 +33,5 @@ index 159ef4b..d1732a1 100644 | |||
33 | 33 | ||
34 | add_test(test_pyiec61850 ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_LIST_DIR}/test_pyiec61850.py) | 34 | add_test(test_pyiec61850 ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_LIST_DIR}/test_pyiec61850.py) |
35 | -- | 35 | -- |
36 | 2.21.3 | 36 | 2.31.1 |
37 | 37 | ||
diff --git a/meta-networking/recipes-connectivity/libiec61850/files/0001-use-poll.h-instead-of-sys-poll.h.patch b/meta-networking/recipes-connectivity/libiec61850/files/0001-use-poll.h-instead-of-sys-poll.h.patch deleted file mode 100644 index a04473d218..0000000000 --- a/meta-networking/recipes-connectivity/libiec61850/files/0001-use-poll.h-instead-of-sys-poll.h.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 4cad505fc98240eb66eaabfae61a9694f8158dda Mon Sep 17 00:00:00 2001 | ||
2 | From: Romain Naour <romain.naour@smile.fr> | ||
3 | Date: Tue, 7 Apr 2020 20:58:37 +0200 | ||
4 | Subject: [PATCH] use <poll.h> instead of <sys/poll.h> | ||
5 | |||
6 | The manpage of poll(2) states that the prototype of poll is defined | ||
7 | in <poll.h>. Use that header file instead of <sys/poll.h> to allow | ||
8 | compilation against musl-libc. | ||
9 | |||
10 | Upstream status: Pending | ||
11 | https://github.com/mz-automation/libiec61850/pull/228 | ||
12 | |||
13 | Signed-off-by: Romain Naour <romain.naour@smile.fr> | ||
14 | --- | ||
15 | hal/ethernet/linux/ethernet_linux.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/hal/ethernet/linux/ethernet_linux.c b/hal/ethernet/linux/ethernet_linux.c | ||
19 | index c3ab2e2..9aa5c28 100644 | ||
20 | --- a/hal/ethernet/linux/ethernet_linux.c | ||
21 | +++ b/hal/ethernet/linux/ethernet_linux.c | ||
22 | @@ -23,7 +23,7 @@ | ||
23 | |||
24 | #include <sys/socket.h> | ||
25 | #include <sys/ioctl.h> | ||
26 | -#include <sys/poll.h> | ||
27 | +#include <poll.h> | ||
28 | #include <linux/if_packet.h> | ||
29 | #include <linux/if_ether.h> | ||
30 | #include <linux/if_arp.h> | ||
31 | -- | ||
32 | 2.21.1 | ||
33 | |||
diff --git a/meta-networking/recipes-connectivity/libiec61850/files/0002-serial_port_linux-Add-missing-include-sys-time.h.patch b/meta-networking/recipes-connectivity/libiec61850/files/0002-serial_port_linux-Add-missing-include-sys-time.h.patch deleted file mode 100644 index e1b8ca15b3..0000000000 --- a/meta-networking/recipes-connectivity/libiec61850/files/0002-serial_port_linux-Add-missing-include-sys-time.h.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 661405eb6066b67dfe51d5ff9635e29f86bdd238 Mon Sep 17 00:00:00 2001 | ||
2 | From: Romain Naour <romain.naour@smile.fr> | ||
3 | Date: Tue, 7 Apr 2020 21:02:54 +0200 | ||
4 | Subject: [PATCH] serial_port_linux: Add missing include sys/time.h | ||
5 | |||
6 | POSIX says `struct timeval` is defined if <sys/time.h> is included. | ||
7 | |||
8 | Adding this header allow to build against musl-libc. | ||
9 | |||
10 | Upstream status: Pending | ||
11 | https://github.com/mz-automation/libiec61850/pull/228 | ||
12 | |||
13 | Signed-off-by: Romain Naour <romain.naour@smile.fr> | ||
14 | --- | ||
15 | hal/serial/linux/serial_port_linux.c | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/hal/serial/linux/serial_port_linux.c b/hal/serial/linux/serial_port_linux.c | ||
19 | index e6308c0..15e5794 100644 | ||
20 | --- a/hal/serial/linux/serial_port_linux.c | ||
21 | +++ b/hal/serial/linux/serial_port_linux.c | ||
22 | @@ -29,6 +29,7 @@ | ||
23 | #include <termios.h> | ||
24 | #include <fcntl.h> | ||
25 | #include <unistd.h> | ||
26 | +#include <sys/time.h> | ||
27 | |||
28 | #include "hal_serial.h" | ||
29 | #include "hal_time.h" | ||
30 | -- | ||
31 | 2.21.1 | ||
32 | |||
diff --git a/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.4.2.1.bb b/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.0.bb index 18cb0cd8ef..18e2992833 100644 --- a/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.4.2.1.bb +++ b/meta-networking/recipes-connectivity/libiec61850/libiec61850_1.5.0.bb | |||
@@ -13,12 +13,10 @@ SECTION = "console/network" | |||
13 | LICENSE = "GPLv3" | 13 | LICENSE = "GPLv3" |
14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
15 | DEPENDS = "swig-native python3" | 15 | DEPENDS = "swig-native python3" |
16 | SRCREV = "d798814fb463115a835da597535a625b68a39cff" | 16 | SRCREV = "fcefc746fea286aeaa40d2f62240216da81c85e5" |
17 | 17 | ||
18 | SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.4 \ | 18 | SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.5 \ |
19 | file://0001-use-poll.h-instead-of-sys-poll.h.patch \ | 19 | file://0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \ |
20 | file://0002-serial_port_linux-Add-missing-include-sys-time.h.patch \ | ||
21 | file://0003-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \ | ||
22 | " | 20 | " |
23 | 21 | ||
24 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |