diff options
-rw-r--r-- | meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb b/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb new file mode 100644 index 0000000000..00e5d497b3 --- /dev/null +++ b/meta-oe/recipes-support/logwarn/logwarn_1.0.14.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SUMMARY = "A utility for finding interesting messages in log files" | ||
2 | DESCRIPTION = "Logwarn searches for interesting messages in log files, \ | ||
3 | where 'interesting' is defined by a user-supplied list of positive and \ | ||
4 | negative extended regular expressions. \ | ||
5 | " | ||
6 | HOMEPAGE = "https://github.com/archiecobbs/logwarn/wiki" | ||
7 | SECTION = "console/utils" | ||
8 | |||
9 | LICENSE = "Apache-2.0" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
11 | |||
12 | SRC_URI = "https://s3.amazonaws.com/archie-public/${BPN}/${BP}.tar.gz" | ||
13 | |||
14 | SRC_URI[md5sum] = "e544a6230673ea54f7430bf817bb39d8" | ||
15 | SRC_URI[sha256sum] = "8dbfcf9b28c782ab3bddd6a620d4fb95d1b0ffcbe93276996cdc4800aa9aebd1" | ||
16 | |||
17 | inherit autotools-brokensep | ||
18 | |||
19 | # This directory is NOT volatile. | ||
20 | # | ||
21 | lcl_default_state_dir = "${localstatedir}/lib/logwarn" | ||
22 | |||
23 | CFLAGS += '-DDEFAULT_STATE_DIR=\""${lcl_default_state_dir}\""' | ||
24 | |||
25 | |||
26 | # Make sure some files exist for autoreconf. | ||
27 | # | ||
28 | do_configure_prepend () { | ||
29 | touch ${S}/NEWS | ||
30 | touch ${S}/ChangeLog | ||
31 | touch ${S}/README | ||
32 | } | ||
33 | |||
34 | # Create a directory for logfile state info, usually under /var/lib. | ||
35 | # | ||
36 | do_install_append () { | ||
37 | install -d ${D}${lcl_default_state_dir} | ||
38 | } | ||
39 | |||
40 | # Make a package for the nagios plug-in (script). | ||
41 | # | ||
42 | PACKAGES += "${PN}-nagios" | ||
43 | |||
44 | FILES_${PN}-nagios = "${nonarch_libdir}/nagios" | ||
45 | |||
46 | RDEPENDS_${PN}-nagios += "bash" | ||