summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs-128_128.5.2.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs-128_128.5.2.bb b/meta-oe/recipes-extended/mozjs/mozjs-128_128.5.2.bb
index 6bcbb13501..c3804ec64d 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs-128_128.5.2.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs-128_128.5.2.bb
@@ -24,7 +24,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
24 24
25S = "${WORKDIR}/firefox-${PV}" 25S = "${WORKDIR}/firefox-${PV}"
26 26
27inherit pkgconfig perlnative python3native rust 27inherit pkgconfig perlnative python3native rust cargo
28 28
29DEPENDS += "zlib cbindgen-native python3 icu" 29DEPENDS += "zlib cbindgen-native python3 icu"
30DEPENDS:remove:mipsarch = "icu" 30DEPENDS:remove:mipsarch = "icu"
@@ -83,6 +83,13 @@ do_configure() {
83} 83}
84do_configure[cleandirs] += "${B}" 84do_configure[cleandirs] += "${B}"
85 85
86# The main build system is a Makefile that call cargo downstream.
87# We inherit cargo to get the environnement but need to switch back to
88# base_do_compile to do the Makefile base compilation.
89do_compile() {
90 base_do_compile
91}
92
86do_install() { 93do_install() {
87 oe_runmake 'DESTDIR=${D}' install 94 oe_runmake 'DESTDIR=${D}' install
88} 95}