diff options
-rw-r--r-- | meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch | 24 | ||||
-rw-r--r-- | meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch | 37 | ||||
-rw-r--r-- | meta-oe/recipes-test/evtest/evtest_1.35.bb (renamed from meta-oe/recipes-test/evtest/evtest_1.34.bb) | 3 |
3 files changed, 9 insertions, 55 deletions
diff --git a/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch b/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch index aa49a06296..595b0296ea 100644 --- a/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch +++ b/meta-oe/recipes-test/evtest/evtest/0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From fa57c78c33d26084f85f1a6b4c29378631dc9395 Mon Sep 17 00:00:00 2001 | 1 | From 490f5b6cd788692d989f07180a5714c76872911e Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 30 Nov 2019 11:58:58 -0800 | 3 | Date: Sat, 30 Nov 2019 11:58:58 -0800 |
4 | Subject: [PATCH] Fix build on 32bit arches with 64bit time_t | 4 | Subject: [PATCH] Fix build on 32bit arches with 64bit time_t |
@@ -10,17 +10,18 @@ input.h [1] | |||
10 | 10 | ||
11 | Upstream-Status: Submitted [https://gitlab.freedesktop.org/libevdev/evtest/merge_requests/6] | 11 | Upstream-Status: Submitted [https://gitlab.freedesktop.org/libevdev/evtest/merge_requests/6] |
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
13 | |||
13 | --- | 14 | --- |
14 | evtest.c | 7 ++++++- | 15 | evtest.c | 5 +++++ |
15 | 1 file changed, 6 insertions(+), 1 deletion(-) | 16 | 1 file changed, 5 insertions(+) |
16 | 17 | ||
17 | diff --git a/evtest.c b/evtest.c | 18 | diff --git a/evtest.c b/evtest.c |
18 | index 548c203..93063cd 100644 | 19 | index ba7a161..8fc2e5a 100644 |
19 | --- a/evtest.c | 20 | --- a/evtest.c |
20 | +++ b/evtest.c | 21 | +++ b/evtest.c |
21 | @@ -61,6 +61,11 @@ | 22 | @@ -63,6 +63,11 @@ |
22 | #include <sys/types.h> | 23 | #define input_event_usec time.tv_usec |
23 | #include <unistd.h> | 24 | #endif |
24 | 25 | ||
25 | +#ifndef input_event_sec | 26 | +#ifndef input_event_sec |
26 | +#define input_event_sec time.tv_sec | 27 | +#define input_event_sec time.tv_sec |
@@ -30,12 +31,3 @@ index 548c203..93063cd 100644 | |||
30 | #define BITS_PER_LONG (sizeof(long) * 8) | 31 | #define BITS_PER_LONG (sizeof(long) * 8) |
31 | #define NBITS(x) ((((x)-1)/BITS_PER_LONG)+1) | 32 | #define NBITS(x) ((((x)-1)/BITS_PER_LONG)+1) |
32 | #define OFF(x) ((x)%BITS_PER_LONG) | 33 | #define OFF(x) ((x)%BITS_PER_LONG) |
33 | @@ -1140,7 +1145,7 @@ static int print_events(int fd) | ||
34 | type = ev[i].type; | ||
35 | code = ev[i].code; | ||
36 | |||
37 | - printf("Event: time %ld.%06ld, ", ev[i].time.tv_sec, ev[i].time.tv_usec); | ||
38 | + printf("Event: time %ld.%06ld, ", ev[i].input_event_sec, ev[i].input_event_usec); | ||
39 | |||
40 | if (type == EV_SYN) { | ||
41 | if (code == SYN_MT_REPORT) | ||
diff --git a/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch b/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch deleted file mode 100644 index b2bf94fd56..0000000000 --- a/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 5eb4ab1c139ea38ebe6bb4acba08b09ee7d77d3c Mon Sep 17 00:00:00 2001 | ||
2 | From: Baruch Siach <baruch@tkos.co.il> | ||
3 | Date: Sun, 18 Aug 2019 10:01:06 +0300 | ||
4 | Subject: Add missing limits.h include | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Fixes build with musl libc that does not include limits.h indirectly via | ||
10 | other headers. | ||
11 | |||
12 | evtest.c: In function ‘scan_devices’: | ||
13 | evtest.c:886:14: error: ‘PATH_MAX’ undeclared (first use in this function); did you mean INT8_MAX’? | ||
14 | char fname[PATH_MAX]; | ||
15 | ^~~~~~~~ | ||
16 | |||
17 | Signed-off-by: Baruch Siach <baruch@tkos.co.il> | ||
18 | Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> | ||
19 | --- | ||
20 | evtest.c | 1 + | ||
21 | 1 file changed, 1 insertion(+) | ||
22 | |||
23 | diff --git a/evtest.c b/evtest.c | ||
24 | index 37d4f85..548c203 100644 | ||
25 | --- a/evtest.c | ||
26 | +++ b/evtest.c | ||
27 | @@ -56,6 +56,7 @@ | ||
28 | #include <getopt.h> | ||
29 | #include <ctype.h> | ||
30 | #include <signal.h> | ||
31 | +#include <limits.h> | ||
32 | #include <sys/time.h> | ||
33 | #include <sys/types.h> | ||
34 | #include <unistd.h> | ||
35 | -- | ||
36 | cgit v1.1 | ||
37 | |||
diff --git a/meta-oe/recipes-test/evtest/evtest_1.34.bb b/meta-oe/recipes-test/evtest/evtest_1.35.bb index daf9dc3836..51af9997f9 100644 --- a/meta-oe/recipes-test/evtest/evtest_1.34.bb +++ b/meta-oe/recipes-test/evtest/evtest_1.35.bb | |||
@@ -7,9 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | |||
7 | 7 | ||
8 | DEPENDS = "libxml2" | 8 | DEPENDS = "libxml2" |
9 | 9 | ||
10 | SRCREV = "16e5104127a620686bdddc4a9ad62881134d6c69" | 10 | SRCREV = "da347a8f88d2e5729dd12d61ee9743f902065b55" |
11 | SRC_URI = "git://gitlab.freedesktop.org/libevdev/evtest.git;protocol=https;branch=master \ | 11 | SRC_URI = "git://gitlab.freedesktop.org/libevdev/evtest.git;protocol=https;branch=master \ |
12 | file://add_missing_limits_h_include.patch \ | ||
13 | file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \ | 12 | file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \ |
14 | " | 13 | " |
15 | 14 | ||