diff options
-rw-r--r-- | meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb | 18 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb | 24 |
2 files changed, 24 insertions, 18 deletions
diff --git a/meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb b/meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb deleted file mode 100644 index d2c7ffdab2..0000000000 --- a/meta-oe/recipes-graphics/jasper/jasper_1.900.1.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Jpeg 2000 implementation" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=baa697d7510288a9cdcce9bd7edaf9bc" | ||
4 | |||
5 | PR = "r1" | ||
6 | |||
7 | SRC_URI = "git://github.com/mdadams/jasper.git;protocol=https" | ||
8 | SRCREV = "b13b8c86be870107f83b0a9a4b77557cb2b65d69" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | inherit autotools lib_package | ||
13 | |||
14 | PACKAGECONFIG ??= "" | ||
15 | PACKAGECONFIG[jpeg] = "--enable-libjpeg,--disable-libjpeg,jpeg" | ||
16 | PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,freeglut" | ||
17 | |||
18 | EXTRA_OECONF = "--enable-shared" | ||
diff --git a/meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb b/meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb new file mode 100644 index 0000000000..1d5a29438a --- /dev/null +++ b/meta-oe/recipes-graphics/jasper/jasper_2.0.16.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Jpeg 2000 implementation" | ||
2 | HOMEPAGE = "https://github.com/mdadams/jasper" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb" | ||
5 | |||
6 | SRC_URI = "git://github.com/mdadams/jasper.git;protocol=https" | ||
7 | SRCREV = "9aef6d91a82a8a6aecb575cbee57f74470603cc2" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | inherit cmake | ||
12 | |||
13 | PACKAGECONFIG ??= "" | ||
14 | PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg" | ||
15 | PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut" | ||
16 | |||
17 | EXTRA_OECMAKE_append = " -DJAS_ENABLE_SHARED=true" | ||
18 | |||
19 | do_install_append() { | ||
20 | chrpath -d ${D}${bindir}/jasper | ||
21 | chrpath -d ${D}${bindir}/imginfo | ||
22 | chrpath -d ${D}${bindir}/imgcmp | ||
23 | chrpath -d ${D}${libdir}/libjasper.so.* | ||
24 | } | ||