summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch11
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch11
2 files changed, 2 insertions, 20 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch
index 91b3046484..23e4368d27 100644
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch
+++ b/meta-networking/recipes-connectivity/openthread/ot-br-posix/mbedtls.patch
@@ -17,19 +17,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
17 void mpi_mul_hlp( size_t i, mbedtls_mpi_uint *s, mbedtls_mpi_uint *d, mbedtls_mpi_uint b ) 17 void mpi_mul_hlp( size_t i, mbedtls_mpi_uint *s, mbedtls_mpi_uint *d, mbedtls_mpi_uint b )
18 { 18 {
19- mbedtls_mpi_uint c = 0, t = 0; 19- mbedtls_mpi_uint c = 0, t = 0;
20+ mbedtls_mpi_uint c = 0; 20+ mbedtls_mpi_uint c = 0, t __attribute__ ((unused)) = 0;
21 21
22 #if defined(MULADDC_HUIT) 22 #if defined(MULADDC_HUIT)
23 for( ; i >= 8; i -= 8 ) 23 for( ; i >= 8; i -= 8 )
24@@ -1595,8 +1595,6 @@ void mpi_mul_hlp( size_t i, mbedtls_mpi_
25 }
26 #endif /* MULADDC_HUIT */
27
28- t++;
29-
30 do {
31 *d += c; c = ( *d < c ); d++;
32 }
33--- a/third_party/openthread/repo/third_party/mbedtls/repo/CMakeLists.txt 24--- a/third_party/openthread/repo/third_party/mbedtls/repo/CMakeLists.txt
34+++ b/third_party/openthread/repo/third_party/mbedtls/repo/CMakeLists.txt 25+++ b/third_party/openthread/repo/third_party/mbedtls/repo/CMakeLists.txt
35@@ -192,7 +192,7 @@ if(CMAKE_COMPILER_IS_GNU) 26@@ -192,7 +192,7 @@ if(CMAKE_COMPILER_IS_GNU)
diff --git a/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch b/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch
index be26a20dad..ffaff48dd4 100644
--- a/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch
+++ b/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch
@@ -17,19 +17,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
17 void mpi_mul_hlp( size_t i, mbedtls_mpi_uint *s, mbedtls_mpi_uint *d, mbedtls_mpi_uint b ) 17 void mpi_mul_hlp( size_t i, mbedtls_mpi_uint *s, mbedtls_mpi_uint *d, mbedtls_mpi_uint b )
18 { 18 {
19- mbedtls_mpi_uint c = 0, t = 0; 19- mbedtls_mpi_uint c = 0, t = 0;
20+ mbedtls_mpi_uint c = 0; 20+ mbedtls_mpi_uint c = 0, t __attribute__ ((unused)) = 0;
21 21
22 #if defined(MULADDC_HUIT) 22 #if defined(MULADDC_HUIT)
23 for( ; i >= 8; i -= 8 ) 23 for( ; i >= 8; i -= 8 )
24@@ -1595,8 +1595,6 @@ void mpi_mul_hlp( size_t i, mbedtls_mpi_
25 }
26 #endif /* MULADDC_HUIT */
27
28- t++;
29-
30 do {
31 *d += c; c = ( *d < c ); d++;
32 }
33--- a/third_party/mbedtls/repo/CMakeLists.txt 24--- a/third_party/mbedtls/repo/CMakeLists.txt
34+++ b/third_party/mbedtls/repo/CMakeLists.txt 25+++ b/third_party/mbedtls/repo/CMakeLists.txt
35@@ -192,7 +192,7 @@ if(CMAKE_COMPILER_IS_GNU) 26@@ -192,7 +192,7 @@ if(CMAKE_COMPILER_IS_GNU)