diff options
-rw-r--r-- | meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch | 33 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch | 31 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb (renamed from meta-multimedia/recipes-multimedia/openal/openal-soft_1.15.1.bb) | 15 |
3 files changed, 74 insertions, 5 deletions
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch b/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch new file mode 100644 index 0000000000..16f123fad8 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/openal/openal-soft/0001-Use-BUILD_CC-to-compile-native-tools.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 29217932c34d7e3368764ab64879dc6f1edab1a6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 14 Jan 2019 11:19:44 -0800 | ||
4 | Subject: [PATCH] Use host compiler to compile native tools | ||
5 | |||
6 | Helps in cross compiling | ||
7 | |||
8 | Upstream-Status: Inappropriate [OE-Specific] | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | |||
12 | --- | ||
13 | CMakeLists.txt | 5 ++--- | ||
14 | 1 file changed, 2 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
17 | index 39b80250..d6bdf8ed 100644 | ||
18 | --- a/CMakeLists.txt | ||
19 | +++ b/CMakeLists.txt | ||
20 | @@ -1288,11 +1288,10 @@ FILE(MAKE_DIRECTORY "${NATIVE_BIN_DIR}") | ||
21 | SET(BIN2H_COMMAND "${NATIVE_BIN_DIR}bin2h") | ||
22 | SET(BSINCGEN_COMMAND "${NATIVE_BIN_DIR}bsincgen") | ||
23 | ADD_CUSTOM_COMMAND(OUTPUT "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}" | ||
24 | - COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" "${NATIVE_SRC_DIR}" | ||
25 | COMMAND ${CMAKE_COMMAND} -E remove "${BIN2H_COMMAND}" "${BSINCGEN_COMMAND}" | ||
26 | - COMMAND ${CMAKE_COMMAND} --build . --config "Release" | ||
27 | + COMMAND gcc "${NATIVE_SRC_DIR}bin2h.c" -o "${BIN2H_COMMAND}" -lm | ||
28 | + COMMAND gcc "${NATIVE_SRC_DIR}bsincgen.c" -o "${BSINCGEN_COMMAND}" -lm | ||
29 | WORKING_DIRECTORY "${NATIVE_BIN_DIR}" | ||
30 | - DEPENDS "${NATIVE_SRC_DIR}CMakeLists.txt" | ||
31 | IMPLICIT_DEPENDS C "${NATIVE_SRC_DIR}bin2h.c" | ||
32 | C "${NATIVE_SRC_DIR}bsincgen.c" | ||
33 | VERBATIM | ||
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch b/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch new file mode 100644 index 0000000000..8420386e36 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/openal/openal-soft/0002-makehrtf-Disable-Wstringop-truncation.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 07ef86e33ed6f7585f0dfaa1732ea17c816655a4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 14 Jan 2019 11:45:42 -0800 | ||
4 | Subject: [PATCH] makehrtf: Disable Wstringop-truncation | ||
5 | |||
6 | Upstream-Status: Inappropriate [Should be fixed in code] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | utils/makehrtf.c | 2 ++ | ||
10 | 1 file changed, 2 insertions(+) | ||
11 | |||
12 | diff --git a/utils/makehrtf.c b/utils/makehrtf.c | ||
13 | index 0bd36849..0abe4252 100644 | ||
14 | --- a/utils/makehrtf.c | ||
15 | +++ b/utils/makehrtf.c | ||
16 | @@ -862,6 +862,7 @@ static int TrReadOperator(TokenReaderT *tr, const char *op) | ||
17 | * pattern string are replaced with the replacement string. The result is | ||
18 | * truncated if necessary. | ||
19 | */ | ||
20 | +#pragma GCC diagnostic ignored "-Wstringop-truncation" | ||
21 | static int StrSubst(const char *in, const char *pat, const char *rep, const size_t maxLen, char *out) | ||
22 | { | ||
23 | size_t inLen, patLen, repLen; | ||
24 | @@ -900,6 +901,7 @@ static int StrSubst(const char *in, const char *pat, const char *rep, const size | ||
25 | return !truncated; | ||
26 | } | ||
27 | |||
28 | +#pragma GCC diagnostic pop | ||
29 | |||
30 | /********************* | ||
31 | *** Math routines *** | ||
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft_1.15.1.bb b/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb index e0f1a26de4..a9cdfac8a9 100644 --- a/meta-multimedia/recipes-multimedia/openal/openal-soft_1.15.1.bb +++ b/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb | |||
@@ -1,13 +1,18 @@ | |||
1 | SUMMARY = "OpenAL is a cross-platform 3D audio API" | 1 | SUMMARY = "OpenAL is a cross-platform 3D audio API" |
2 | HOMEPAGE = "http://kcat.strangesoft.net/openal.html" | 2 | HOMEPAGE = "http://kcat.strangesoft.net/openal.html" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=facc3a8f452930083bbb95d82b989c35" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0f159f19f9377e1895fbb477d5a7953e" |
5 | 5 | ||
6 | inherit cmake | 6 | inherit cmake pkgconfig |
7 | 7 | ||
8 | SRC_URI = "http://kcat.strangesoft.net/openal-releases/${BP}.tar.bz2" | 8 | # openal-soft-1.19.1 |
9 | SRC_URI[md5sum] = "ea83dec3b9655a27d28e7bc7cae9cd71" | 9 | SRCREV = "6761218e51699f46bf25c377e65b3e9ea5e434b9" |
10 | SRC_URI[sha256sum] = "0e29a162f0841ccb4135ce76e92e8a704589b680a85eddf76f898de5236eb056" | 10 | SRC_URI = "git://github.com/kcat/openal-soft \ |
11 | file://0001-Use-BUILD_CC-to-compile-native-tools.patch \ | ||
12 | file://0002-makehrtf-Disable-Wstringop-truncation.patch \ | ||
13 | " | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
11 | 16 | ||
12 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)}" | 17 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)}" |
13 | PACKAGECONFIG[alsa] = "-DALSA=TRUE, -DALSA=FALSE, alsa-lib" | 18 | PACKAGECONFIG[alsa] = "-DALSA=TRUE, -DALSA=FALSE, alsa-lib" |