diff options
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch | 25 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto.inc | 4 |
2 files changed, 12 insertions, 17 deletions
diff --git a/meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch b/meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch index 70de44173d..21033eaaa8 100644 --- a/meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch +++ b/meta-oe/recipes-devtools/perfetto/files/0001-meson-add-pc-file-for-lib_perfetto.patch | |||
@@ -7,17 +7,15 @@ Subject: [PATCH] meson: add PC file for lib_perfetto | |||
7 | meson.build | 12 ++++++++++-- | 7 | meson.build | 12 ++++++++++-- |
8 | 1 file changed, 10 insertions(+), 2 deletions(-) | 8 | 1 file changed, 10 insertions(+), 2 deletions(-) |
9 | 9 | ||
10 | diff --git a/meson.build b/meson.build | ||
11 | index 06015141c..752b4d928 100644 | ||
12 | --- a/meson.build | 10 | --- a/meson.build |
13 | +++ b/meson.build | 11 | +++ b/meson.build |
14 | @@ -19,9 +19,12 @@ | 12 | @@ -19,9 +19,12 @@ |
15 | project( | 13 | project( |
16 | 'perfetto', | 14 | 'perfetto', |
17 | ['c','cpp'], | 15 | ['cpp'], |
18 | - default_options: ['c_std=c99', 'cpp_std=c++11'] | 16 | - default_options: ['cpp_std=c++17'] |
19 | + default_options: ['c_std=c99', 'cpp_std=c++11'], | 17 | + default_options: ['cpp_std=c++17'], |
20 | + version: '27.1' | 18 | + version: '31.0' |
21 | ) | 19 | ) |
22 | 20 | ||
23 | +soversion = meson.project_version() | 21 | +soversion = meson.project_version() |
@@ -25,20 +23,20 @@ index 06015141c..752b4d928 100644 | |||
25 | fs = import('fs') | 23 | fs = import('fs') |
26 | 24 | ||
27 | if not fs.is_dir('sdk') | 25 | if not fs.is_dir('sdk') |
28 | @@ -30,8 +33,9 @@ endif | 26 | @@ -36,8 +39,9 @@ if host_machine.system() == 'android' |
29 | 27 | deps_perfetto += cpp.find_library('log') | |
30 | dep_threads = dependency('threads') | 28 | endif |
31 | 29 | ||
32 | -lib_perfetto = static_library( | 30 | -lib_perfetto = static_library( |
33 | +lib_perfetto = shared_library( | 31 | +lib_perfetto = shared_library( |
34 | 'perfetto', | 32 | 'perfetto', |
35 | + version: soversion, | 33 | + version: soversion, |
36 | sources: 'sdk/perfetto.cc', | 34 | sources: 'sdk/perfetto.cc', |
37 | dependencies: dep_threads, | 35 | dependencies: deps_perfetto, |
38 | install: true, | 36 | install: true, |
39 | @@ -39,6 +43,10 @@ lib_perfetto = static_library( | 37 | @@ -50,6 +54,10 @@ dir_perfetto_trace = join_paths(meson.cu |
40 | 38 | ||
41 | inc_perfetto = include_directories('sdk') | 39 | install_data(dir_perfetto_trace / 'perfetto_trace.proto') |
42 | 40 | ||
43 | +install_headers('sdk/perfetto.h') | 41 | +install_headers('sdk/perfetto.h') |
44 | +pkg = import('pkgconfig') | 42 | +pkg = import('pkgconfig') |
@@ -47,6 +45,3 @@ index 06015141c..752b4d928 100644 | |||
47 | dep_perfetto = declare_dependency( | 45 | dep_perfetto = declare_dependency( |
48 | link_with: lib_perfetto, | 46 | link_with: lib_perfetto, |
49 | include_directories: inc_perfetto, | 47 | include_directories: inc_perfetto, |
50 | -- | ||
51 | 2.34.1 | ||
52 | |||
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto.inc b/meta-oe/recipes-devtools/perfetto/perfetto.inc index 5cb6f8bb34..de871d4f3d 100644 --- a/meta-oe/recipes-devtools/perfetto/perfetto.inc +++ b/meta-oe/recipes-devtools/perfetto/perfetto.inc | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/google/perfetto" | |||
3 | 3 | ||
4 | SRC_URI = "git://github.com/google/perfetto.git;protocol=https;name=perfetto;nobranch=1" | 4 | SRC_URI = "git://github.com/google/perfetto.git;protocol=https;name=perfetto;nobranch=1" |
5 | 5 | ||
6 | SRCREV_perfetto = "1c52b5e132312aeb007ed180d4ba1d8d66227923" | 6 | SRCREV_perfetto = "b8da07095979310818f0efde2ef3c69ea70d62c5" |
7 | PV = "27.1" | 7 | PV = "31.0" |
8 | 8 | ||
9 | S = "${WORKDIR}/git" | 9 | S = "${WORKDIR}/git" |