summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb b/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
new file mode 100644
index 0000000000..953c249664
--- /dev/null
+++ b/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
@@ -0,0 +1,39 @@
1SUMMARY = "A high-performance REST toolkit written in C++"
2HOMEPAGE = "https://pistacheio.github.io/pistache"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
5
6SRC_URI = "git://github.com/pistacheio/pistache.git;branch=master;protocol=https"
7# SRCREV tagged 0.4.26
8SRCREV = "ddffda861aa49012dcda28f1362d0339e718cd52"
9
10S = "${WORKDIR}/git"
11
12DEPENDS = "openssl brotli zlib zstd rapidjson"
13
14inherit pkgconfig meson
15
16PACKAGECONFIG ?= "openssl brotli deflate zstd examples"
17PACKAGECONFIG[openssl] = "-DPISTACHE_USE_SSL=true, -DPISTACHE_USE_SSL=false"
18PACKAGECONFIG[brotli] = "-DPISTACHE_USE_CONTENT_ENCODING_BROTLI=true, -DPISTACHE_USE_CONTENT_ENCODING_BROTLI=false"
19PACKAGECONFIG[deflate] = "-DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=true, -DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=false"
20PACKAGECONFIG[zstd] = "-DPISTACHE_USE_CONTENT_ENCODING_ZSTD=true, -DPISTACHE_USE_CONTENT_ENCODING_ZSTD=false"
21PACKAGECONFIG[examples] = "-DPISTACHE_BUILD_EXAMPLES=true, -DPISTACHE_BUILD_EXAMPLES=false"
22PACKAGECONFIG[test] = "-DPISTACHE_BUILD_TESTS=true, -DPISTACHE_BUILD_TESTS=false"
23
24do_install:append () {
25 install -d ${D}${bindir}
26 rm -rf ${B}/examples/*.p/
27 install -m 0755 ${B}/examples/run* ${D}${bindir}/
28}
29
30PACKAGES += "${PN}-examples"
31FILES:${PN}:remove = " ${bindir}/*"
32RDEPENDS:${PN}-examples += "${PN}"
33FILES:${PN}-examples = "${bindir}"
34
35RDEPENDS:${PN} += "rapidjson"
36
37COMPATIBLE_HOST:libc-musl = "null"
38
39BBCLASSEXTEND = "native nativesdk"