diff options
8 files changed, 136 insertions, 79 deletions
diff --git a/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch b/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch new file mode 100644 index 0000000000..6c7f3bd30d --- /dev/null +++ b/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From a860fe0796c43e35eac9783140fcb563cab9f55a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 8 Jun 2017 23:09:51 -0700 | ||
4 | Subject: [PATCH 1/3] audio_alsa09.c: alsa drain fix | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | audio_alsa09.c | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/audio_alsa09.c b/audio_alsa09.c | ||
12 | index 534e3db..d9450e6 100644 | ||
13 | --- a/audio_alsa09.c | ||
14 | +++ b/audio_alsa09.c | ||
15 | @@ -506,7 +506,7 @@ void esd_audio_flush(void) | ||
16 | } | ||
17 | |||
18 | if (alsa_playback_handle != NULL) | ||
19 | - snd_pcm_drain( alsa_playback_handle ); | ||
20 | + snd_pcm_drop( alsa_playback_handle ); | ||
21 | |||
22 | if (alsadbg) | ||
23 | print_state(); | ||
24 | -- | ||
25 | 2.13.1 | ||
26 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/0001-replace-missing-AM_PATH_AUDIOFILE-by-PKG_CHECK_MODUL.patch b/meta-oe/recipes-multimedia/esound/esound/0001-replace-missing-AM_PATH_AUDIOFILE-by-PKG_CHECK_MODUL.patch deleted file mode 100644 index 89c97a4fc4..0000000000 --- a/meta-oe/recipes-multimedia/esound/esound/0001-replace-missing-AM_PATH_AUDIOFILE-by-PKG_CHECK_MODUL.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 218e0702d6ce4d2cb20d5d108daa16afca2b7c41 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Fri, 16 Dec 2016 13:22:51 +0100 | ||
4 | Subject: [PATCH] replace missing AM_PATH_AUDIOFILE by PKG_CHECK_MODULES( | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstrem-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
12 | --- | ||
13 | configure.ac | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 486c492..dccfd1b 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -353,7 +353,7 @@ echo "---------------------------------------------------------------------" | ||
21 | echo "--- Checking for the audiofile library. NOTE: This library is now" | ||
22 | echo "--- REQUIRED from proper compilation of the esound package." | ||
23 | |||
24 | -AM_PATH_AUDIOFILE(0.1.5, [ | ||
25 | +PKG_CHECK_MODULES(AUDIOFILE, audiofile, [ | ||
26 | |||
27 | build_esdplay=true | ||
28 | echo "--- libaudiofile found. Building esound with audiofile support" | ||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch b/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch new file mode 100644 index 0000000000..337546abe9 --- /dev/null +++ b/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 1fbee6e96384f340b816e221fe1c2f3ff0b487bf Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 8 Jun 2017 23:11:31 -0700 | ||
4 | Subject: [PATCH 2/3] Undefine open64 and fopen64 | ||
5 | |||
6 | Since the signatures do not match with libc | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | esddsp.c | 2 ++ | ||
11 | 1 file changed, 2 insertions(+) | ||
12 | |||
13 | diff --git a/esddsp.c b/esddsp.c | ||
14 | index d3c6ea9..17b5949 100644 | ||
15 | --- a/esddsp.c | ||
16 | +++ b/esddsp.c | ||
17 | @@ -290,6 +290,7 @@ open (const char *pathname, int flags, ...) | ||
18 | return open_wrapper(func, pathname, flags, mode); | ||
19 | } | ||
20 | |||
21 | +#undef open64 | ||
22 | int | ||
23 | open64 (const char *pathname, int flags, ...) | ||
24 | { | ||
25 | @@ -374,6 +375,7 @@ fopen (const char *path, const char *mode) | ||
26 | return fopen_wrapper(func, path, mode); | ||
27 | } | ||
28 | |||
29 | +#undef fopen64 | ||
30 | FILE * | ||
31 | fopen64 (const char *path, const char *mode) | ||
32 | { | ||
33 | -- | ||
34 | 2.13.1 | ||
35 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch b/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch new file mode 100644 index 0000000000..62c880d9d0 --- /dev/null +++ b/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 979a02d9ec9c28686021cd2b49ca55d2195c9dce Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 8 Jun 2017 23:12:36 -0700 | ||
4 | Subject: [PATCH 3/3] Use -I=<path> in configure | ||
5 | |||
6 | This helps to use proper sysroot in | ||
7 | cross build environment | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | configure.ac | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/configure.ac b/configure.ac | ||
15 | index 5645dce..d374cda 100644 | ||
16 | --- a/configure.ac | ||
17 | +++ b/configure.ac | ||
18 | @@ -208,7 +208,7 @@ if test "x$enable_local_sound" = "xyes"; then | ||
19 | AC_CHECK_HEADERS(CoreAudio/CoreAudio.h) | ||
20 | # mme_api.h directly includes other files from the mme subdir | ||
21 | xCPPFLAGS="$CPPFLAGS" | ||
22 | - CPPFLAGS="$CPPFLAGS -I/usr/include/mme" | ||
23 | + CPPFLAGS="$CPPFLAGS -I=/usr/include/mme" | ||
24 | AC_CHECK_HEADERS(mme/mme_api.h) | ||
25 | CPPFLAGS="$xCPPFLAGS" | ||
26 | AM_PATH_ARTS(, HAVE_ARTS=yes, HAVE_ARTS=no) | ||
27 | @@ -269,7 +269,7 @@ if test "x$enable_local_sound" = "xyes"; then | ||
28 | osf*) | ||
29 | found_sound=yes | ||
30 | AC_DEFINE(DRIVER_OSF, 1, [Defined if OSF backend is enabled]) | ||
31 | - CPPFLAGS="$CPPFLAGS -I/usr/include/mme" | ||
32 | + CPPFLAGS="$CPPFLAGS -I=/usr/include/mme" | ||
33 | SOUND_LIBS=-lmme | ||
34 | esac | ||
35 | fi | ||
36 | -- | ||
37 | 2.13.1 | ||
38 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/configure-fix.patch b/meta-oe/recipes-multimedia/esound/esound/configure-fix.patch deleted file mode 100644 index 8fdc35ad5e..0000000000 --- a/meta-oe/recipes-multimedia/esound/esound/configure-fix.patch +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | --- /tmp/configure.ac 2008-06-02 16:46:55.640793306 +0200 | ||
2 | +++ esound-0.2.36/configure.ac 2008-06-02 16:47:26.030793494 +0200 | ||
3 | @@ -29,6 +29,7 @@ | ||
4 | AC_SUBST(pkgdocdir) | ||
5 | |||
6 | AC_PROG_CC | ||
7 | +AC_PROG_CXX | ||
8 | AC_PROG_CPP | ||
9 | AC_LIBTOOL_WIN32_DLL | ||
10 | AM_PROG_LIBTOOL | ||
diff --git a/meta-oe/recipes-multimedia/esound/esound/esound_0.2.36-1ubuntu5.diff.gz b/meta-oe/recipes-multimedia/esound/esound/esound_0.2.36-1ubuntu5.diff.gz deleted file mode 100644 index 719f5d09de..0000000000 --- a/meta-oe/recipes-multimedia/esound/esound/esound_0.2.36-1ubuntu5.diff.gz +++ /dev/null | |||
Binary files differ | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound_0.2.36.bb b/meta-oe/recipes-multimedia/esound/esound_0.2.36.bb deleted file mode 100644 index d19ba8223c..0000000000 --- a/meta-oe/recipes-multimedia/esound/esound_0.2.36.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | SUMMARY = "Enlightened Sound Daemon" | ||
2 | SECTION = "gpe/base" | ||
3 | LICENSE = "LGPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605" | ||
5 | DEPENDS = "audiofile" | ||
6 | |||
7 | inherit gnome binconfig | ||
8 | |||
9 | PR = "r1" | ||
10 | |||
11 | SRC_URI = " \ | ||
12 | ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-0.2.36.tar.bz2;name=archive \ | ||
13 | file://esound_0.2.36-1ubuntu5.diff.gz \ | ||
14 | file://no-docs.patch \ | ||
15 | file://configure-fix.patch \ | ||
16 | file://0001-replace-missing-AM_PATH_AUDIOFILE-by-PKG_CHECK_MODUL.patch \ | ||
17 | " | ||
18 | |||
19 | SRC_URI[archive.md5sum] = "3facb5aa0115cc1c31771b9ad454ae76" | ||
20 | SRC_URI[archive.sha256sum] = "68bf399fcbd45c5e9ba99cd13a3a479e4ef2bc5dc52e540ffa00aef1e1b19a76" | ||
21 | |||
22 | EXTRA_OECONF = " \ | ||
23 | --disable-alsa \ | ||
24 | --disable-arts \ | ||
25 | --disable-artstest \ | ||
26 | " | ||
27 | |||
28 | CFLAGS += "-lm" | ||
29 | |||
30 | do_configure_prepend() { | ||
31 | sed -i -e 's:/usr/include/mme:${STAGING_INCDIR}/mme:g' ${S}/configure.ac | ||
32 | } | ||
33 | |||
34 | PACKAGES =+ "esddsp esd esd-utils" | ||
35 | |||
36 | FILES_esddsp = "${bindir}/esddsp ${libdir}/libesddsp.so.*" | ||
37 | FILES_esd = "${bindir}/esd" | ||
38 | FILES_esd-utils = "${bindir}/*" | ||
diff --git a/meta-oe/recipes-multimedia/esound/esound_0.2.41.bb b/meta-oe/recipes-multimedia/esound/esound_0.2.41.bb new file mode 100644 index 0000000000..0ddf94f2da --- /dev/null +++ b/meta-oe/recipes-multimedia/esound/esound_0.2.41.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "Enlightened Sound Daemon" | ||
2 | SECTION = "gpe/base" | ||
3 | LICENSE = "LGPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605" | ||
5 | DEPENDS = "audiofile" | ||
6 | |||
7 | inherit gnome | ||
8 | |||
9 | SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/${P}.tar.bz2;name=archive \ | ||
10 | file://no-docs.patch \ | ||
11 | file://0001-audio_alsa09.c-alsa-drain-fix.patch \ | ||
12 | file://0002-Undefine-open64-and-fopen64.patch \ | ||
13 | file://0003-Use-I-path-in-configure.patch \ | ||
14 | " | ||
15 | SRC_URI[archive.md5sum] = "8d9aad3d94d15e0d59ba9dc0ea990c6c" | ||
16 | SRC_URI[archive.sha256sum] = "5eb5dd29a64b3462a29a5b20652aba7aa926742cef43577bf0796b787ca34911" | ||
17 | |||
18 | EXTRA_OECONF += " \ | ||
19 | --disable-arts \ | ||
20 | --disable-artstest \ | ||
21 | " | ||
22 | EXTRA_OECONF_remove = "--disable-schemas-install" | ||
23 | |||
24 | CFLAGS += "-lm" | ||
25 | |||
26 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||
27 | PACKAGECONFIG[libwrap] = "--with-libwrap,--without-libwrap,tcp-wrappers," | ||
28 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-oss,--disable-alsa,alsa-lib," | ||
29 | |||
30 | PACKAGECONFIG ??= "libwrap alsa \ | ||
31 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ | ||
32 | " | ||
33 | PACKAGES =+ "esddsp esd esd-utils" | ||
34 | |||
35 | FILES_esddsp = "${bindir}/esddsp ${libdir}/libesddsp.so.*" | ||
36 | FILES_esd = "${bindir}/esd" | ||
37 | FILES_esd-utils = "${bindir}/*" | ||