diff options
-rw-r--r-- | meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch | 19 | ||||
-rw-r--r-- | meta-oe/recipes-support/htop/htop_3.0.4.bb (renamed from meta-oe/recipes-support/htop/htop_3.0.1.bb) | 20 |
2 files changed, 25 insertions, 14 deletions
diff --git a/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch b/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch index fc0d86e335..93d6d58573 100644 --- a/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch +++ b/meta-oe/recipes-support/htop/files/0001-Use-pkg-config.patch | |||
@@ -1,3 +1,8 @@ | |||
1 | From 14100c6fc2cce7260ca5ace81094aee0ae40dd07 Mon Sep 17 00:00:00 2001 | ||
2 | From: Paul Barker <pbarker@toganlabs.com> | ||
3 | Date: Sun, 5 Nov 2017 22:07:30 +0000 | ||
4 | Subject: [PATCH] htop: Update to v2.0.2 | ||
5 | |||
1 | We need to use pkg-config to find the ncurses library instead of the | 6 | We need to use pkg-config to find the ncurses library instead of the |
2 | ncurses*-config applications. | 7 | ncurses*-config applications. |
3 | 8 | ||
@@ -7,11 +12,15 @@ Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> | |||
7 | Upstream-status: Inappropriate | 12 | Upstream-status: Inappropriate |
8 | (`ncurses*-config` can be used outside of OpenEmbedded) | 13 | (`ncurses*-config` can be used outside of OpenEmbedded) |
9 | 14 | ||
15 | --- | ||
16 | configure.ac | 12 ++++++------ | ||
17 | 1 file changed, 6 insertions(+), 6 deletions(-) | ||
18 | |||
10 | diff --git a/configure.ac b/configure.ac | 19 | diff --git a/configure.ac b/configure.ac |
11 | index 559dc4d..77aea22 100644 | 20 | index 115d894..0e0a1eb 100644 |
12 | --- a/configure.ac | 21 | --- a/configure.ac |
13 | +++ b/configure.ac | 22 | +++ b/configure.ac |
14 | @@ -185,10 +185,10 @@ m4_define([HTOP_CHECK_LIB], | 23 | @@ -205,10 +205,10 @@ AS_VAR_POPDEF([CACHEVAR])dnl |
15 | 24 | ||
16 | AC_ARG_ENABLE(unicode, [AS_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes") | 25 | AC_ARG_ENABLE(unicode, [AS_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes") |
17 | if test "x$enable_unicode" = xyes; then | 26 | if test "x$enable_unicode" = xyes; then |
@@ -26,9 +35,9 @@ index 559dc4d..77aea22 100644 | |||
26 | HTOP_CHECK_LIB([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], | 35 | HTOP_CHECK_LIB([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], |
27 | HTOP_CHECK_LIB([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], | 36 | HTOP_CHECK_LIB([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], |
28 | HTOP_CHECK_LIB([ncurses], [addnwstr], [HAVE_LIBNCURSESW], | 37 | HTOP_CHECK_LIB([ncurses], [addnwstr], [HAVE_LIBNCURSESW], |
29 | @@ -201,8 +201,8 @@ if test "x$enable_unicode" = xyes; then | 38 | @@ -225,8 +225,8 @@ if test "x$enable_unicode" = xyes; then |
30 | [AC_CHECK_HEADERS([ncurses/curses.h],[:], | 39 | # (at this point we already link against a working ncurses library with wide character support) |
31 | [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])]) | 40 | AC_SEARCH_LIBS([keypad], [tinfow tinfo]) |
32 | else | 41 | else |
33 | - HTOP_CHECK_SCRIPT([ncurses6], [refresh], [HAVE_LIBNCURSES], "ncurses6-config", | 42 | - HTOP_CHECK_SCRIPT([ncurses6], [refresh], [HAVE_LIBNCURSES], "ncurses6-config", |
34 | - HTOP_CHECK_SCRIPT([ncurses], [refresh], [HAVE_LIBNCURSES], "ncurses5-config", | 43 | - HTOP_CHECK_SCRIPT([ncurses], [refresh], [HAVE_LIBNCURSES], "ncurses5-config", |
diff --git a/meta-oe/recipes-support/htop/htop_3.0.1.bb b/meta-oe/recipes-support/htop/htop_3.0.4.bb index d677e36c01..49d53ec98f 100644 --- a/meta-oe/recipes-support/htop/htop_3.0.1.bb +++ b/meta-oe/recipes-support/htop/htop_3.0.4.bb | |||
@@ -9,23 +9,25 @@ DEPENDS = "ncurses" | |||
9 | SRC_URI = "git://github.com/htop-dev/htop.git \ | 9 | SRC_URI = "git://github.com/htop-dev/htop.git \ |
10 | file://0001-Use-pkg-config.patch \ | 10 | file://0001-Use-pkg-config.patch \ |
11 | " | 11 | " |
12 | SRCREV = "dace850fa6e27b5626115b366059258cfe4d60c9" | 12 | SRCREV = "0b989ee38ce37eb4a50265faa11df2bd7ed8e5c3" |
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | inherit autotools pkgconfig | 16 | inherit autotools pkgconfig |
17 | 17 | ||
18 | PACKAGECONFIG ??= "cgroup \ | 18 | PACKAGECONFIG ??= " \ |
19 | taskstats \ | 19 | unicode \ |
20 | unicode \ | 20 | linux-affinity \ |
21 | linux-affinity \ | 21 | delayacct \ |
22 | delayacct" | 22 | " |
23 | PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz" | 23 | PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz" |
24 | PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup" | ||
25 | PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver" | 24 | PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver" |
26 | PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats" | 25 | PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver" |
27 | PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode" | 26 | PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode" |
28 | PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity" | ||
29 | PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc" | 27 | PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc" |
28 | PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity" | ||
30 | PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid" | 29 | PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid" |
31 | PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl" | 30 | PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl" |
31 | PACKAGECONFIG[sensors] = "--with-sensors,--without-sensors,lmsensors,lmsensors-libsensors" | ||
32 | |||
33 | FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg" | ||