summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.8.8.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.9.7.bb24
2 files changed, 24 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-django_1.8.8.bb b/meta-python/recipes-devtools/python/python-django_1.8.8.bb
deleted file mode 100644
index e56c55558d..0000000000
--- a/meta-python/recipes-devtools/python/python-django_1.8.8.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "A high-level Python Web framework"
2HOMEPAGE = "http://www.djangoproject.com/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
5
6SRC_URI[md5sum] = "08ecf83b7e9d064ed7e3981ddc3a8a15"
7SRC_URI[sha256sum] = "8255242fa0d9e0bf331259a6bdb81364933acbe8863291661558ffdb2fc9ed70"
8
9PYPI_PACKAGE = "Django"
10inherit pypi setuptools
11
12FILES_${PN} += "${datadir}/django"
13
14BBCLASSEXTEND = "nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-django_1.9.7.bb b/meta-python/recipes-devtools/python/python-django_1.9.7.bb
new file mode 100644
index 0000000000..8693da8b15
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-django_1.9.7.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A high-level Python Web framework"
2HOMEPAGE = "http://www.djangoproject.com/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
5
6SRC_URI[md5sum] = "7de9ba83bfe01f4b7d45645c1b259c83"
7SRC_URI[sha256sum] = "2b29e81c8c32b3c0d9a0119217416887c480d927ae2630bada2da83078c93bf6"
8
9PYPI_PACKAGE = "Django"
10inherit pypi setuptools
11
12FILES_${PN} += "${datadir}/django"
13
14BBCLASSEXTEND = "nativesdk"
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-datetime \
18 ${PYTHON_PN}-importlib \
19 ${PYTHON_PN}-numbers \
20 ${PYTHON_PN}-pip \
21 ${PYTHON_PN}-pkgutil \
22 ${PYTHON_PN}-subprocess \
23 ${PYTHON_PN}-threading \
24 "