summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch56
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm_48.0.bb1
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch b/meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch
new file mode 100644
index 0000000000..8363a7f41d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gdm/gdm/a3e0aca75e16aeafc171751028406b54f5ed8397.patch
@@ -0,0 +1,56 @@
1From 2fbc2ac50b9f143eb594e5f77a8051222ffbd2c9 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
3Date: Mon, 27 Jan 2025 14:01:23 +0100
4Subject: [PATCH] gdm-settings-utils: rename variable to fix build with gcc 15
5
6In GNU23 C, bool is a keyword. Rename the variable to avoid syntax error.
7---
8 common/gdm-settings-utils.c | 8 ++++----
9 common/gdm-settings-utils.h | 2 +-
10 2 files changed, 5 insertions(+), 5 deletions(-)
11
12 Signed-off-by: Markus Volk <f_l_k@t-online.de>
13
14Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gdm/-/commit/a3e0aca75e16aeafc171751028406b54f5ed8397.patch]
15
16diff --git a/common/gdm-settings-utils.c b/common/gdm-settings-utils.c
17index 636be3a9e..da4c7aefb 100644
18--- a/common/gdm-settings-utils.c
19+++ b/common/gdm-settings-utils.c
20@@ -287,16 +287,16 @@ gdm_settings_parse_boolean_as_value (gboolean boolval)
21 /* adapted from GKeyFile */
22 gboolean
23 gdm_settings_parse_value_as_boolean (const char *value,
24- gboolean *bool)
25+ gboolean *boolval)
26 {
27 g_return_val_if_fail (value != NULL, FALSE);
28- g_return_val_if_fail (bool != NULL, FALSE);
29+ g_return_val_if_fail (boolval != NULL, FALSE);
30
31 if (g_ascii_strcasecmp (value, "true") == 0 || strcmp (value, "1") == 0) {
32- *bool = TRUE;
33+ *boolval = TRUE;
34 return TRUE;
35 } else if (g_ascii_strcasecmp (value, "false") == 0 || strcmp (value, "0") == 0) {
36- *bool = FALSE;
37+ *boolval = FALSE;
38 return TRUE;
39 } else {
40 return FALSE;
41diff --git a/common/gdm-settings-utils.h b/common/gdm-settings-utils.h
42index 4f2362ce7..734d625c7 100644
43--- a/common/gdm-settings-utils.h
44+++ b/common/gdm-settings-utils.h
45@@ -44,7 +44,7 @@ gboolean gdm_settings_parse_schemas (const char *fil
46 GSList **list);
47
48 gboolean gdm_settings_parse_value_as_boolean (const char *value,
49- gboolean *bool);
50+ gboolean *boolval);
51 gboolean gdm_settings_parse_value_as_integer (const char *value,
52 int *intval);
53 gboolean gdm_settings_parse_value_as_double (const char *value,
54--
55GitLab
56
diff --git a/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb b/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb
index 1c8076e6c7..92ddc143f6 100644
--- a/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb
+++ b/meta-gnome/recipes-gnome/gdm/gdm_48.0.bb
@@ -21,6 +21,7 @@ GIR_MESON_OPTION = ""
21 21
22inherit gnomebase gsettings pkgconfig gobject-introspection gettext systemd useradd itstool gnome-help features_check 22inherit gnomebase gsettings pkgconfig gobject-introspection gettext systemd useradd itstool gnome-help features_check
23 23
24SRC_URI += "file://a3e0aca75e16aeafc171751028406b54f5ed8397.patch"
24SRC_URI[archive.sha256sum] = "1bc06daff093ec7b5e37ecb4f92e5da3474a1b1ba076edb9151ee967d1c30adf" 25SRC_URI[archive.sha256sum] = "1bc06daff093ec7b5e37ecb4f92e5da3474a1b1ba076edb9151ee967d1c30adf"
25 26
26PACKAGECONFIG ??= "" 27PACKAGECONFIG ??= ""