summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.5.1.bb2
2 files changed, 13 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymongo.inc b/meta-python/recipes-devtools/python/python-pymongo.inc
index 29c2a3f89b..7f199b46b0 100644
--- a/meta-python/recipes-devtools/python/python-pymongo.inc
+++ b/meta-python/recipes-devtools/python/python-pymongo.inc
@@ -11,9 +11,17 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2a944942e1496af1886903d274dedb13"
11SRC_URI[md5sum] = "35ae53073a25603591e085b18bc5a0ec" 11SRC_URI[md5sum] = "35ae53073a25603591e085b18bc5a0ec"
12SRC_URI[sha256sum] = "e820d93414f3bec1fa456c84afbd4af1b43ff41366321619db74e6bc065d6924" 12SRC_URI[sha256sum] = "e820d93414f3bec1fa456c84afbd4af1b43ff41366321619db74e6bc065d6924"
13 13
14PACKAGES =+ "${PYTHON_PN}-bson"
15
16FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
17
18RDEPENDS_${PYTHON_PN}-bson += " \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-netclient \
21 ${PYTHON_PN}-numbers \
22 ${PYTHON_PN}-threading \
23"
24
14RDEPENDS_${PN} += " \ 25RDEPENDS_${PN} += " \
15 ${PYTHON_PN}-datetime \ 26 ${PYTHON_PN}-bson \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-numbers \
18 ${PYTHON_PN}-threading \
19" 27"
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.5.1.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.5.1.bb
index 3b250a16bf..9f02cab137 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.5.1.bb
@@ -2,7 +2,7 @@ inherit pypi setuptools3
2require python-pymongo.inc 2require python-pymongo.inc
3 3
4# Requires _pydecimal which is in misc 4# Requires _pydecimal which is in misc
5RDEPENDS_${PN} += " \ 5RDEPENDS_${PYTHON_PN}-bson += " \
6 ${PYTHON_PN}-enum \ 6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \ 7 ${PYTHON_PN}-misc \
8 ${PYTHON_PN}-selectors \ 8 ${PYTHON_PN}-selectors \