diff options
3 files changed, 68 insertions, 1 deletions
diff --git a/meta-python/recipes-core/images/meta-python-ptest-all-image.bb b/meta-python/recipes-core/images/meta-python-ptest-all-image.bb new file mode 100644 index 0000000000..fd4dc42487 --- /dev/null +++ b/meta-python/recipes-core/images/meta-python-ptest-all-image.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "Recipe to trigger execution of all meta-python ptest images." | ||
2 | HOMEPAGE = "https://www.openembedded.org/" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | |||
6 | inherit features_check nopackages | ||
7 | REQUIRED_DISTRO_FEATURES = "ptest" | ||
8 | |||
9 | require conf/include/ptest-packagelists-meta-python.inc | ||
10 | |||
11 | # Include the full set of ptests | ||
12 | PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON} ${PTESTS_SLOW_META_PYTHON}" | ||
13 | |||
14 | do_testimage[noexec] = "1" | ||
15 | do_testimage[depends] = "${@' '.join(['meta-python-ptest-image-'+x+':do_testimage' for x in d.getVar('PTESTS_META_PYTHON').split()])}" | ||
16 | |||
17 | do_build[depends] = "${@' '.join(['meta-python-ptest-image-'+x+':do_build' for x in d.getVar('PTESTS_META_PYTHON').split()])}" | ||
18 | |||
19 | # normally image.bbclass would do this | ||
20 | EXCLUDE_FROM_WORLD = "1" | ||
21 | |||
22 | python () { | ||
23 | if bb.utils.contains('IMAGE_CLASSES', 'testimage', True, False, d): | ||
24 | bb.build.addtask("do_testimage", "", "", d) | ||
25 | } | ||
diff --git a/meta-python/recipes-core/images/meta-python-ptest-fast-image.bb b/meta-python/recipes-core/images/meta-python-ptest-fast-image.bb new file mode 100644 index 0000000000..4f93a15959 --- /dev/null +++ b/meta-python/recipes-core/images/meta-python-ptest-fast-image.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require meta-python-ptest-all-image.bb | ||
2 | |||
3 | DESCRIPTION = "Recipe to trigger execution of all fast meta-python ptest images." | ||
4 | |||
5 | PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON}" | ||
6 | |||
diff --git a/meta-python/recipes-core/images/meta-python-ptest-image.bb b/meta-python/recipes-core/images/meta-python-ptest-image.bb index d497016d41..a649cbb94c 100644 --- a/meta-python/recipes-core/images/meta-python-ptest-image.bb +++ b/meta-python/recipes-core/images/meta-python-ptest-image.bb | |||
@@ -1,5 +1,41 @@ | |||
1 | inherit features_check | ||
2 | REQUIRED_DISTRO_FEATURES = "ptest" | ||
3 | |||
4 | require conf/include/ptest-packagelists-meta-python.inc | ||
5 | |||
1 | require meta-python-image-base.bb | 6 | require meta-python-image-base.bb |
2 | 7 | ||
3 | SUMMARY = "meta-python ptest test image" | 8 | SUMMARY = "meta-python ptest test image" |
4 | 9 | ||
5 | IMAGE_INSTALL += "packagegroup-meta-python3-ptest" | 10 | DESCRIPTION += "Also including the ${MCNAME} ptest package." |
11 | HOMEPAGE = "https://www.openembedded.org/" | ||
12 | |||
13 | PTESTS_META_PYTHON = "${PTESTS_SLOW_META_PYTHON} ${PTESTS_FAST_META_PYTHON}" | ||
14 | |||
15 | IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh" | ||
16 | |||
17 | BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS_META_PYTHON').split()])}" | ||
18 | |||
19 | # The image can be sufficiently large (~1.8GB) that we need to be careful that it fits in a live | ||
20 | # image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the | ||
21 | # box) and explicitly add up to 1500MB. | ||
22 | IMAGE_OVERHEAD_FACTOR = "1.0" | ||
23 | IMAGE_ROOTFS_EXTRA_SPACE = "324288" | ||
24 | # If a particular ptest needs more space, it can be customized: | ||
25 | #IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-<pn> = "1024288" | ||
26 | |||
27 | # ptests need more memory than standard to avoid the OOM killer | ||
28 | QB_MEM = "-m 1024" | ||
29 | # If a particular ptest needs more memory, it can be customized: | ||
30 | #QB_MEM:virtclass-mcextend-<pn> = "-m 4096" | ||
31 | |||
32 | TEST_SUITES = "ping ssh parselogs ptest" | ||
33 | |||
34 | # Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places | ||
35 | PTEST_EXPECT_FAILURE = "1" | ||
36 | |||
37 | python () { | ||
38 | if not d.getVar("MCNAME"): | ||
39 | raise bb.parse.SkipRecipe("No class extension set") | ||
40 | } | ||
41 | |||