summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-core/images/meta-python-ptest-all-image.bb25
-rw-r--r--meta-python/recipes-core/images/meta-python-ptest-fast-image.bb6
-rw-r--r--meta-python/recipes-core/images/meta-python-ptest-image.bb38
3 files changed, 68 insertions, 1 deletions
diff --git a/meta-python/recipes-core/images/meta-python-ptest-all-image.bb b/meta-python/recipes-core/images/meta-python-ptest-all-image.bb
new file mode 100644
index 0000000000..fd4dc42487
--- /dev/null
+++ b/meta-python/recipes-core/images/meta-python-ptest-all-image.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Recipe to trigger execution of all meta-python ptest images."
2HOMEPAGE = "https://www.openembedded.org/"
3
4LICENSE = "MIT"
5
6inherit features_check nopackages
7REQUIRED_DISTRO_FEATURES = "ptest"
8
9require conf/include/ptest-packagelists-meta-python.inc
10
11# Include the full set of ptests
12PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON} ${PTESTS_SLOW_META_PYTHON}"
13
14do_testimage[noexec] = "1"
15do_testimage[depends] = "${@' '.join(['meta-python-ptest-image-'+x+':do_testimage' for x in d.getVar('PTESTS_META_PYTHON').split()])}"
16
17do_build[depends] = "${@' '.join(['meta-python-ptest-image-'+x+':do_build' for x in d.getVar('PTESTS_META_PYTHON').split()])}"
18
19# normally image.bbclass would do this
20EXCLUDE_FROM_WORLD = "1"
21
22python () {
23 if bb.utils.contains('IMAGE_CLASSES', 'testimage', True, False, d):
24 bb.build.addtask("do_testimage", "", "", d)
25}
diff --git a/meta-python/recipes-core/images/meta-python-ptest-fast-image.bb b/meta-python/recipes-core/images/meta-python-ptest-fast-image.bb
new file mode 100644
index 0000000000..4f93a15959
--- /dev/null
+++ b/meta-python/recipes-core/images/meta-python-ptest-fast-image.bb
@@ -0,0 +1,6 @@
1require meta-python-ptest-all-image.bb
2
3DESCRIPTION = "Recipe to trigger execution of all fast meta-python ptest images."
4
5PTESTS_META_PYTHON = "${PTESTS_FAST_META_PYTHON}"
6
diff --git a/meta-python/recipes-core/images/meta-python-ptest-image.bb b/meta-python/recipes-core/images/meta-python-ptest-image.bb
index d497016d41..a649cbb94c 100644
--- a/meta-python/recipes-core/images/meta-python-ptest-image.bb
+++ b/meta-python/recipes-core/images/meta-python-ptest-image.bb
@@ -1,5 +1,41 @@
1inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require conf/include/ptest-packagelists-meta-python.inc
5
1require meta-python-image-base.bb 6require meta-python-image-base.bb
2 7
3SUMMARY = "meta-python ptest test image" 8SUMMARY = "meta-python ptest test image"
4 9
5IMAGE_INSTALL += "packagegroup-meta-python3-ptest" 10DESCRIPTION += "Also including the ${MCNAME} ptest package."
11HOMEPAGE = "https://www.openembedded.org/"
12
13PTESTS_META_PYTHON = "${PTESTS_SLOW_META_PYTHON} ${PTESTS_FAST_META_PYTHON}"
14
15IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"
16
17BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS_META_PYTHON').split()])}"
18
19# The image can be sufficiently large (~1.8GB) that we need to be careful that it fits in a live
20# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
21# box) and explicitly add up to 1500MB.
22IMAGE_OVERHEAD_FACTOR = "1.0"
23IMAGE_ROOTFS_EXTRA_SPACE = "324288"
24# If a particular ptest needs more space, it can be customized:
25#IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-<pn> = "1024288"
26
27# ptests need more memory than standard to avoid the OOM killer
28QB_MEM = "-m 1024"
29# If a particular ptest needs more memory, it can be customized:
30#QB_MEM:virtclass-mcextend-<pn> = "-m 4096"
31
32TEST_SUITES = "ping ssh parselogs ptest"
33
34# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places
35PTEST_EXPECT_FAILURE = "1"
36
37python () {
38 if not d.getVar("MCNAME"):
39 raise bb.parse.SkipRecipe("No class extension set")
40}
41