summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch10
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch15
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools_1.67.1.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb)2
3 files changed, 13 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch
index 67505d0ce1..bf13c71cdd 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch
@@ -1,4 +1,4 @@
1From 64d737318656286f69ddc5ad654072785ddcbbed Mon Sep 17 00:00:00 2001 1From 028a02fa7f03a3bcd590624d32b09100129e096a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 16 Sep 2022 19:09:15 -0700 3Date: Fri, 16 Sep 2022 19:09:15 -0700
4Subject: [PATCH] protobuf: Disable musttail attribute on mips 4Subject: [PATCH] protobuf: Disable musttail attribute on mips
@@ -9,12 +9,14 @@ Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> 10Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
11--- 11---
12 third_party/protobuf/src/google/protobuf/port_def.inc | 3 ++- 12 third_party/protobuf/src/google/protobuf/port_def.inc | 1 +
13 1 file changed, 2 insertions(+), 1 deletion(-) 13 1 file changed, 1 insertion(+)
14 14
15diff --git a/third_party/protobuf/src/google/protobuf/port_def.inc b/third_party/protobuf/src/google/protobuf/port_def.inc
16index 2b13718..8875e3e 100644
15--- a/third_party/protobuf/src/google/protobuf/port_def.inc 17--- a/third_party/protobuf/src/google/protobuf/port_def.inc
16+++ b/third_party/protobuf/src/google/protobuf/port_def.inc 18+++ b/third_party/protobuf/src/google/protobuf/port_def.inc
17@@ -298,6 +298,7 @@ 19@@ -242,6 +242,7 @@ static_assert(PROTOBUF_ABSL_MIN(20230125, 3),
18 #error PROTOBUF_TAILCALL was previously defined 20 #error PROTOBUF_TAILCALL was previously defined
19 #endif 21 #endif
20 #if ABSL_HAVE_CPP_ATTRIBUTE(clang::musttail) && !defined(__arm__) && \ 22 #if ABSL_HAVE_CPP_ATTRIBUTE(clang::musttail) && !defined(__arm__) && \
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 07276c17f6..5366a1e1cf 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -1,4 +1,4 @@
1From 9b2f1d400db8b8d0045f5a58a748a2dc52b5c9ef Mon Sep 17 00:00:00 2001 1From f1bf68aaa5417bcb7ad4996f1be8d2c0f53c521c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 17 Feb 2021 13:38:55 -0800 3Date: Wed, 17 Feb 2021 13:38:55 -0800
4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options 4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options
@@ -23,14 +23,14 @@ Upstream-Status: Inappropriate [oe specific]
23 23
24Signed-off-by: Khem Raj <raj.khem@gmail.com> 24Signed-off-by: Khem Raj <raj.khem@gmail.com>
25--- 25---
26 setup.py | 9 ++++++--- 26 setup.py | 10 ++++++----
27 1 file changed, 6 insertions(+), 3 deletions(-) 27 1 file changed, 6 insertions(+), 4 deletions(-)
28 28
29diff --git a/setup.py b/setup.py 29diff --git a/setup.py b/setup.py
30index cc53e79..be3bc78 100644 30index 5e19b63..61b30d8 100644
31--- a/setup.py 31--- a/setup.py
32+++ b/setup.py 32+++ b/setup.py
33@@ -88,9 +88,11 @@ 33@@ -90,9 +90,11 @@ def check_linker_need_libatomic():
34 b"#include <atomic>\n" 34 b"#include <atomic>\n"
35 + b"int main() { return std::atomic<int64_t>{}; }" 35 + b"int main() { return std::atomic<int64_t>{}; }"
36 ) 36 )
@@ -45,7 +45,7 @@ index cc53e79..be3bc78 100644
45 stdin=PIPE, 45 stdin=PIPE,
46 stdout=PIPE, 46 stdout=PIPE,
47 stderr=PIPE, 47 stderr=PIPE,
48@@ -101,7 +103,7 @@ 48@@ -103,7 +105,7 @@ def check_linker_need_libatomic():
49 # Double-check to see if -latomic actually can solve the problem. 49 # Double-check to see if -latomic actually can solve the problem.
50 # https://github.com/grpc/grpc/issues/22491 50 # https://github.com/grpc/grpc/issues/22491
51 cpp_test = subprocess.Popen( 51 cpp_test = subprocess.Popen(
@@ -54,6 +54,3 @@ index cc53e79..be3bc78 100644
54 stdin=PIPE, 54 stdin=PIPE,
55 stdout=PIPE, 55 stdout=PIPE,
56 stderr=PIPE, 56 stderr=PIPE,
57--
582.25.1
59
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.67.1.bb
index 6765bed04b..6ac826c5cf 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.67.1.bb
@@ -14,7 +14,7 @@ DEPENDS += "python3-grpcio"
14SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \ 14SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
15 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \ 15 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
16 " 16 "
17SRC_URI[sha256sum] = "4a36e07913d26ba5ccfd2685ba63ca97f26b08c249d2cc9e74dda37efa49d7e4" 17SRC_URI[sha256sum] = "d9657f5ddc62b52f58904e6054b7d8a8909ed08a1e28b734be3a707087bcf004"
18 18
19RDEPENDS:${PN} = "python3-grpcio" 19RDEPENDS:${PN} = "python3-grpcio"
20 20