summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/pidgin/gmime/iconv-detect.h5
-rw-r--r--meta-oe/recipes-support/pidgin/gmime/nodolt.patch10
-rw-r--r--meta-oe/recipes-support/pidgin/gmime_3.2.3.bb23
3 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h b/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h
new file mode 100644
index 0000000000..714cb5aa9d
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h
@@ -0,0 +1,5 @@
1/* This is an auto-generated header, DO NOT EDIT! */
2
3#define ICONV_ISO_INT_FORMAT "iso-%u-%u"
4#define ICONV_ISO_STR_FORMAT "iso-%u-%s"
5#define ICONV_10646 "iso-10646"
diff --git a/meta-oe/recipes-support/pidgin/gmime/nodolt.patch b/meta-oe/recipes-support/pidgin/gmime/nodolt.patch
new file mode 100644
index 0000000000..1f9bdd3041
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/gmime/nodolt.patch
@@ -0,0 +1,10 @@
1--- a/configure.ac
2+++ b/configure.ac
3@@ -150,7 +150,6 @@ AC_EXEEXT
4 AC_PROG_LIBTOOL
5 dnl when using libtool 2.x create libtool early, because it's used in configure
6 m4_ifdef([LT_OUTPUT], [LT_OUTPUT])
7-DOLT
8
9 dnl Checks for header files.
10 AC_CHECK_HEADERS(sys/mman.h)
diff --git a/meta-oe/recipes-support/pidgin/gmime_3.2.3.bb b/meta-oe/recipes-support/pidgin/gmime_3.2.3.bb
new file mode 100644
index 0000000000..8c6f0b010a
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/gmime_3.2.3.bb
@@ -0,0 +1,23 @@
1LICENSE = "LGPL-2.1"
2LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
3DESCRIPTION = "Runtime libraries for parsing and creating MIME mail"
4SECTION = "libs"
5DEPENDS = "glib-2.0 zlib"
6
7inherit gnome autotools gobject-introspection
8
9SRC_URI += "file://iconv-detect.h \
10 file://nodolt.patch"
11
12SRC_URI[archive.md5sum] = "69ae21a0b1df966a7d39a9431856ac81"
13SRC_URI[archive.sha256sum] = "6a0875eeb552ab447dd54853a68ced62217d863631048737dd97eaa2713e7311"
14
15EXTRA_OECONF_remove = "--disable-schemas-install"
16
17export ac_cv_have_iconv_detect_h="yes"
18do_configure_append = "cp ${WORKDIR}/iconv-detect.h ${S}"
19
20# we do not need GNOME 1 gnome-config support
21do_install_append () {
22 rm -f ${D}${libdir}/gmimeConf.sh
23}