diff options
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto.bb | 1 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/perfetto/perfetto/0001-add-missing-includes-for-the-build-with-use_libcxx_m.patch | 105 |
2 files changed, 106 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto.bb b/meta-oe/recipes-devtools/perfetto/perfetto.bb index 5a5d4de899..6b4e6372d3 100644 --- a/meta-oe/recipes-devtools/perfetto/perfetto.bb +++ b/meta-oe/recipes-devtools/perfetto/perfetto.bb | |||
@@ -28,6 +28,7 @@ SRC_URI:append = " \ | |||
28 | \ | 28 | \ |
29 | file://0001-Remove-check_build_deps-build-steps.patch \ | 29 | file://0001-Remove-check_build_deps-build-steps.patch \ |
30 | file://0002-traced-fix-missing-include.patch \ | 30 | file://0002-traced-fix-missing-include.patch \ |
31 | file://0001-add-missing-includes-for-the-build-with-use_libcxx_m.patch \ | ||
31 | " | 32 | " |
32 | 33 | ||
33 | SRCREV_bionic = "a0d0355105cb9d4a4b5384897448676133d7b8e2" | 34 | SRCREV_bionic = "a0d0355105cb9d4a4b5384897448676133d7b8e2" |
diff --git a/meta-oe/recipes-devtools/perfetto/perfetto/0001-add-missing-includes-for-the-build-with-use_libcxx_m.patch b/meta-oe/recipes-devtools/perfetto/perfetto/0001-add-missing-includes-for-the-build-with-use_libcxx_m.patch new file mode 100644 index 0000000000..225810e511 --- /dev/null +++ b/meta-oe/recipes-devtools/perfetto/perfetto/0001-add-missing-includes-for-the-build-with-use_libcxx_m.patch | |||
@@ -0,0 +1,105 @@ | |||
1 | From 3953f56f98420e2ecb0e1c4542e20bfbb81da965 Mon Sep 17 00:00:00 2001 | ||
2 | From: Takuto Ikuta <tikuta@google.com> | ||
3 | Date: Mon, 9 Dec 2024 18:45:36 +0900 | ||
4 | Subject: [PATCH] add missing includes for the build with use_libcxx_modules | ||
5 | |||
6 | This is to fix build error when we set use_libcxx_modules=true in | ||
7 | chromium build. | ||
8 | |||
9 | Bug: 40440396 | ||
10 | Change-Id: I0cca5190c2c3551cc62bafafd12da9283e4afdd4 | ||
11 | |||
12 | Upstream-Status: Backport [3953f56 add missing includes for the build with use_libcxx_modules] | ||
13 | - Removed some patches for files that do not exist in the current version v47.0 | ||
14 | |||
15 | Signed-off-by: mark.yang <mark.yang@lge.com> | ||
16 | --- | ||
17 | |||
18 | diff --git a/include/perfetto/base/flat_set.h b/include/perfetto/base/flat_set.h | ||
19 | index 9390537b39..5be590ea6b 100644 | ||
20 | --- a/include/perfetto/base/flat_set.h | ||
21 | +++ b/include/perfetto/base/flat_set.h | ||
22 | @@ -17,7 +17,10 @@ | ||
23 | #ifndef INCLUDE_PERFETTO_BASE_FLAT_SET_H_ | ||
24 | #define INCLUDE_PERFETTO_BASE_FLAT_SET_H_ | ||
25 | |||
26 | +#include <stddef.h> | ||
27 | + | ||
28 | #include <algorithm> | ||
29 | +#include <utility> | ||
30 | #include <vector> | ||
31 | |||
32 | // A vector-based set::set-like container. | ||
33 | diff --git a/include/perfetto/base/time.h b/include/perfetto/base/time.h | ||
34 | index 6436503d20..8de7648267 100644 | ||
35 | --- a/include/perfetto/base/time.h | ||
36 | +++ b/include/perfetto/base/time.h | ||
37 | @@ -17,6 +17,7 @@ | ||
38 | #ifndef INCLUDE_PERFETTO_BASE_TIME_H_ | ||
39 | #define INCLUDE_PERFETTO_BASE_TIME_H_ | ||
40 | |||
41 | +#include <stdint.h> | ||
42 | #include <time.h> | ||
43 | |||
44 | #include <chrono> | ||
45 | diff --git a/include/perfetto/ext/base/string_utils.h b/include/perfetto/ext/base/string_utils.h | ||
46 | index c8264a2fb7..3b15e55771 100644 | ||
47 | --- a/include/perfetto/ext/base/string_utils.h | ||
48 | +++ b/include/perfetto/ext/base/string_utils.h | ||
49 | @@ -24,6 +24,7 @@ | ||
50 | #include <cinttypes> | ||
51 | #include <optional> | ||
52 | #include <string> | ||
53 | +#include <system_error> | ||
54 | #include <vector> | ||
55 | |||
56 | #include "perfetto/ext/base/string_view.h" | ||
57 | diff --git a/include/perfetto/ext/base/subprocess.h b/include/perfetto/ext/base/subprocess.h | ||
58 | index 12121e0284..4075169df1 100644 | ||
59 | --- a/include/perfetto/ext/base/subprocess.h | ||
60 | +++ b/include/perfetto/ext/base/subprocess.h | ||
61 | @@ -20,6 +20,7 @@ | ||
62 | #include <condition_variable> | ||
63 | #include <functional> | ||
64 | #include <initializer_list> | ||
65 | +#include <memory> | ||
66 | #include <mutex> | ||
67 | #include <optional> | ||
68 | #include <string> | ||
69 | diff --git a/include/perfetto/ext/base/waitable_event.h b/include/perfetto/ext/base/waitable_event.h | ||
70 | index 0e786196f8..a4b268a2f3 100644 | ||
71 | --- a/include/perfetto/ext/base/waitable_event.h | ||
72 | +++ b/include/perfetto/ext/base/waitable_event.h | ||
73 | @@ -17,6 +17,8 @@ | ||
74 | #ifndef INCLUDE_PERFETTO_EXT_BASE_WAITABLE_EVENT_H_ | ||
75 | #define INCLUDE_PERFETTO_EXT_BASE_WAITABLE_EVENT_H_ | ||
76 | |||
77 | +#include <stdint.h> | ||
78 | + | ||
79 | #include <condition_variable> | ||
80 | #include <mutex> | ||
81 | |||
82 | diff --git a/include/perfetto/ext/tracing/core/slice.h b/include/perfetto/ext/tracing/core/slice.h | ||
83 | index 063043bdc6..cdabc39465 100644 | ||
84 | --- a/include/perfetto/ext/tracing/core/slice.h | ||
85 | +++ b/include/perfetto/ext/tracing/core/slice.h | ||
86 | @@ -18,6 +18,7 @@ | ||
87 | #define INCLUDE_PERFETTO_EXT_TRACING_CORE_SLICE_H_ | ||
88 | |||
89 | #include <stddef.h> | ||
90 | +#include <stdint.h> | ||
91 | #include <string.h> | ||
92 | |||
93 | #include <memory> | ||
94 | diff --git a/src/trace_processor/util/trace_blob_view_reader.h b/src/trace_processor/util/trace_blob_view_reader.h | ||
95 | index c39ffaba7c..6ffa7ff050 100644 | ||
96 | --- a/src/trace_processor/util/trace_blob_view_reader.h | ||
97 | +++ b/src/trace_processor/util/trace_blob_view_reader.h | ||
98 | @@ -19,6 +19,7 @@ | ||
99 | |||
100 | #include <cstddef> | ||
101 | #include <optional> | ||
102 | +#include <vector> | ||
103 | |||
104 | #include "perfetto/ext/base/circular_queue.h" | ||
105 | #include "perfetto/trace_processor/trace_blob_view.h" | ||