diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch | 41 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb (renamed from meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb) | 12 |
2 files changed, 6 insertions, 47 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch b/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch deleted file mode 100644 index 0c9f29a6b8..0000000000 --- a/meta-python/recipes-devtools/python/python3-sqlparse/0001-sqlparse-change-shebang-to-python3.patch +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | From f236a30dc8528b6f114201580f1efdcc1c447d43 Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Mon, 9 Mar 2020 13:10:37 +0800 | ||
4 | Subject: [PATCH] sqlparse: change shebang to python3 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Don't send upstream since upstream still support python2, | ||
9 | we can only make this change after python2 is offcially | ||
10 | dropped. | ||
11 | |||
12 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
13 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
14 | --- | ||
15 | sqlparse/__main__.py | 2 +- | ||
16 | sqlparse/cli.py | 2 +- | ||
17 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/sqlparse/__main__.py b/sqlparse/__main__.py | ||
20 | index 2bf2513..6a3a115 100644 | ||
21 | --- a/sqlparse/__main__.py | ||
22 | +++ b/sqlparse/__main__.py | ||
23 | @@ -1,4 +1,4 @@ | ||
24 | -#!/usr/bin/env python | ||
25 | +#!/usr/bin/env python3 | ||
26 | # | ||
27 | # Copyright (C) 2009-2020 the sqlparse authors and contributors | ||
28 | # <see AUTHORS file> | ||
29 | diff --git a/sqlparse/cli.py b/sqlparse/cli.py | ||
30 | index 7a8aacb..9c727e8 100755 | ||
31 | --- a/sqlparse/cli.py | ||
32 | +++ b/sqlparse/cli.py | ||
33 | @@ -1,4 +1,4 @@ | ||
34 | -#!/usr/bin/env python | ||
35 | +#!/usr/bin/env python3 | ||
36 | # | ||
37 | # Copyright (C) 2009-2020 the sqlparse authors and contributors | ||
38 | # <see AUTHORS file> | ||
39 | -- | ||
40 | 2.41.0 | ||
41 | |||
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb index c04971ee8f..e10c97d772 100644 --- a/meta-python/recipes-devtools/python/python3-sqlparse_0.4.4.bb +++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.5.0.bb | |||
@@ -4,18 +4,18 @@ SECTION = "devel/python" | |||
4 | LICENSE = "BSD-3-Clause" | 4 | LICENSE = "BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc" |
6 | 6 | ||
7 | SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \ | 7 | SRC_URI:append = " \ |
8 | file://run-ptest \ | 8 | file://run-ptest \ |
9 | " | 9 | " |
10 | 10 | ||
11 | SRC_URI[sha256sum] = "d446183e84b8349fa3061f0fe7f06ca94ba65b426946ffebe6e3e8295332420c" | 11 | SRC_URI[sha256sum] = "714d0a4932c059d16189f58ef5411ec2287a4360f17cdd0edd2d09d4c5087c93" |
12 | 12 | ||
13 | export BUILD_SYS | 13 | export BUILD_SYS |
14 | export HOST_SYS | 14 | export HOST_SYS |
15 | 15 | ||
16 | inherit pypi ptest python_flit_core | 16 | inherit pypi ptest python_hatchling |
17 | 17 | ||
18 | RDEPENDS:${PN}-ptest += " \ | 18 | RDEPENDS:${PN}-ptest += "\ |
19 | python3-pytest \ | 19 | python3-pytest \ |
20 | python3-unittest-automake-output \ | 20 | python3-unittest-automake-output \ |
21 | python3-unixadmin \ | 21 | python3-unixadmin \ |