diff options
-rw-r--r-- | meta-oe/recipes-devtools/ltrace/ltrace/0001-Fix-tautological-compare-warning.patch | 261 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/ltrace/ltrace_git.bb | 1 |
2 files changed, 262 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/0001-Fix-tautological-compare-warning.patch b/meta-oe/recipes-devtools/ltrace/ltrace/0001-Fix-tautological-compare-warning.patch new file mode 100644 index 0000000000..a599d0e191 --- /dev/null +++ b/meta-oe/recipes-devtools/ltrace/ltrace/0001-Fix-tautological-compare-warning.patch | |||
@@ -0,0 +1,261 @@ | |||
1 | From 0af8ced6376f2256b9daac301c851e1c99c3b035 Mon Sep 17 00:00:00 2001 | ||
2 | From: Adam Trhon <adam.trhon@tbs-biometrics.com> | ||
3 | Date: Fri, 12 May 2017 13:39:11 +0200 | ||
4 | Subject: [PATCH] Fix tautological compare warning | ||
5 | |||
6 | By default, gcc ignores warning from code generated by macros | ||
7 | (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80369). When | ||
8 | ltrace is compiled under icecream the warning *is generated* | ||
9 | (https://github.com/icecc/icecream/issues/202) | ||
10 | and the compilation fails (because of -Werror). | ||
11 | |||
12 | Upstream-Status: Submitted [ltrace-devel@lists.alioth.debian.org] | ||
13 | |||
14 | Signed-off-by: Adam Trhon <adam.trhon@tbs-biometrics.com> | ||
15 | --- | ||
16 | filter.c | 4 ++-- | ||
17 | sysdeps/linux-gnu/arm/fetch.c | 2 +- | ||
18 | sysdeps/linux-gnu/arm/trace.c | 2 +- | ||
19 | sysdeps/linux-gnu/ia64/fetch.c | 2 +- | ||
20 | sysdeps/linux-gnu/metag/trace.c | 2 +- | ||
21 | sysdeps/linux-gnu/mips/plt.c | 2 +- | ||
22 | sysdeps/linux-gnu/ppc/fetch.c | 2 +- | ||
23 | sysdeps/linux-gnu/ppc/plt.c | 2 +- | ||
24 | sysdeps/linux-gnu/ppc/trace.c | 4 ++-- | ||
25 | sysdeps/linux-gnu/s390/fetch.c | 2 +- | ||
26 | sysdeps/linux-gnu/s390/trace.c | 4 ++-- | ||
27 | sysdeps/linux-gnu/x86/fetch.c | 2 +- | ||
28 | sysdeps/linux-gnu/x86/trace.c | 4 ++-- | ||
29 | value.c | 4 ++-- | ||
30 | 14 files changed, 19 insertions(+), 19 deletions(-) | ||
31 | |||
32 | diff --git a/filter.c b/filter.c | ||
33 | index ba50c40..a65856d 100644 | ||
34 | --- a/filter.c | ||
35 | +++ b/filter.c | ||
36 | @@ -79,7 +79,7 @@ filter_lib_matcher_name_init(struct filter_lib_matcher *matcher, | ||
37 | { | ||
38 | switch (type) { | ||
39 | case FLM_MAIN: | ||
40 | - assert(type != type); | ||
41 | + assert(!"Unexpected value of type"); | ||
42 | abort(); | ||
43 | |||
44 | case FLM_SONAME: | ||
45 | @@ -137,7 +137,7 @@ matcher_matches_library(struct filter_lib_matcher *matcher, struct library *lib) | ||
46 | case FLM_MAIN: | ||
47 | return lib->type == LT_LIBTYPE_MAIN; | ||
48 | } | ||
49 | - assert(matcher->type != matcher->type); | ||
50 | + assert(!"Unexpected value of matcher->type"); | ||
51 | abort(); | ||
52 | } | ||
53 | |||
54 | diff --git a/sysdeps/linux-gnu/arm/fetch.c b/sysdeps/linux-gnu/arm/fetch.c | ||
55 | index b500448..8f75fcf 100644 | ||
56 | --- a/sysdeps/linux-gnu/arm/fetch.c | ||
57 | +++ b/sysdeps/linux-gnu/arm/fetch.c | ||
58 | @@ -317,7 +317,7 @@ arch_fetch_retval(struct fetch_context *ctx, enum tof type, | ||
59 | memmove(data, ctx->regs.uregs, sz); | ||
60 | return 0; | ||
61 | } | ||
62 | - assert(info->type != info->type); | ||
63 | + assert(!"Unexpected value of info->type"); | ||
64 | abort(); | ||
65 | } | ||
66 | |||
67 | diff --git a/sysdeps/linux-gnu/arm/trace.c b/sysdeps/linux-gnu/arm/trace.c | ||
68 | index 5e51e91..e76bf63 100644 | ||
69 | --- a/sysdeps/linux-gnu/arm/trace.c | ||
70 | +++ b/sysdeps/linux-gnu/arm/trace.c | ||
71 | @@ -701,7 +701,7 @@ arch_type_sizeof(struct process *proc, struct arg_type_info *info) | ||
72 | return (size_t)-2; | ||
73 | |||
74 | default: | ||
75 | - assert(info->type != info->type); | ||
76 | + assert(!"Unexpected value of info->type"); | ||
77 | abort(); | ||
78 | } | ||
79 | } | ||
80 | diff --git a/sysdeps/linux-gnu/ia64/fetch.c b/sysdeps/linux-gnu/ia64/fetch.c | ||
81 | index 171c7a2..ee2fbc7 100644 | ||
82 | --- a/sysdeps/linux-gnu/ia64/fetch.c | ||
83 | +++ b/sysdeps/linux-gnu/ia64/fetch.c | ||
84 | @@ -409,7 +409,7 @@ arch_fetch_arg_next(struct fetch_context *ctx, enum tof type, | ||
85 | case ARGTYPE_ARRAY: | ||
86 | /* Arrays decay into pointers. XXX Fortran? */ | ||
87 | default: | ||
88 | - assert(info->type != info->type); | ||
89 | + assert(!"Unexpected value of info->type"); | ||
90 | abort(); | ||
91 | } | ||
92 | } | ||
93 | diff --git a/sysdeps/linux-gnu/metag/trace.c b/sysdeps/linux-gnu/metag/trace.c | ||
94 | index ad5fffe..7a843d6 100644 | ||
95 | --- a/sysdeps/linux-gnu/metag/trace.c | ||
96 | +++ b/sysdeps/linux-gnu/metag/trace.c | ||
97 | @@ -142,7 +142,7 @@ get_regval_from_unit(enum metag_unitnum unit, unsigned int reg, | ||
98 | return regs->ax[reg][0]; | ||
99 | /* We really shouldn't be here. */ | ||
100 | default: | ||
101 | - assert(unit != unit); | ||
102 | + assert(!"Unexpected value of unit"); | ||
103 | abort(); | ||
104 | } | ||
105 | return 0; | ||
106 | diff --git a/sysdeps/linux-gnu/mips/plt.c b/sysdeps/linux-gnu/mips/plt.c | ||
107 | index c7c10ac..ca2307d 100644 | ||
108 | --- a/sysdeps/linux-gnu/mips/plt.c | ||
109 | +++ b/sysdeps/linux-gnu/mips/plt.c | ||
110 | @@ -651,7 +651,7 @@ mips_stub_bp_continue(struct breakpoint *bp, struct process *proc) | ||
111 | break; | ||
112 | } | ||
113 | |||
114 | - assert(bp->libsym->arch.type != bp->libsym->arch.type); | ||
115 | + assert(!"Unexpected value of bp->libsym->arch.type"); | ||
116 | abort(); | ||
117 | } | ||
118 | |||
119 | diff --git a/sysdeps/linux-gnu/ppc/fetch.c b/sysdeps/linux-gnu/ppc/fetch.c | ||
120 | index c6cbd71..5db5675 100644 | ||
121 | --- a/sysdeps/linux-gnu/ppc/fetch.c | ||
122 | +++ b/sysdeps/linux-gnu/ppc/fetch.c | ||
123 | @@ -502,7 +502,7 @@ allocate_argument(struct fetch_context *ctx, struct process *proc, | ||
124 | case ARGTYPE_ARRAY: | ||
125 | /* Arrays decay into pointers. XXX Fortran? */ | ||
126 | default: | ||
127 | - assert(info->type != info->type); | ||
128 | + assert(!"Unexpected value of info->type"); | ||
129 | abort(); | ||
130 | } | ||
131 | |||
132 | diff --git a/sysdeps/linux-gnu/ppc/plt.c b/sysdeps/linux-gnu/ppc/plt.c | ||
133 | index 5f81889..781da03 100644 | ||
134 | --- a/sysdeps/linux-gnu/ppc/plt.c | ||
135 | +++ b/sysdeps/linux-gnu/ppc/plt.c | ||
136 | @@ -1085,7 +1085,7 @@ ppc_plt_bp_continue(struct breakpoint *bp, struct process *proc) | ||
137 | break; | ||
138 | } | ||
139 | |||
140 | - assert(bp->libsym->arch.type != bp->libsym->arch.type); | ||
141 | + assert(!"Unexpected value of bp->libsym->arch.type"); | ||
142 | abort(); | ||
143 | } | ||
144 | |||
145 | diff --git a/sysdeps/linux-gnu/ppc/trace.c b/sysdeps/linux-gnu/ppc/trace.c | ||
146 | index 5aab538..caa6035 100644 | ||
147 | --- a/sysdeps/linux-gnu/ppc/trace.c | ||
148 | +++ b/sysdeps/linux-gnu/ppc/trace.c | ||
149 | @@ -217,7 +217,7 @@ arch_type_sizeof(struct process *proc, struct arg_type_info *info) | ||
150 | return (size_t)-2; | ||
151 | |||
152 | default: | ||
153 | - assert(info->type != info->type); | ||
154 | + assert(!"Unexpected value of info->type"); | ||
155 | abort(); | ||
156 | break; | ||
157 | } | ||
158 | @@ -231,7 +231,7 @@ arch_type_alignof(struct process *proc, struct arg_type_info *info) | ||
159 | |||
160 | switch (info->type) { | ||
161 | default: | ||
162 | - assert(info->type != info->type); | ||
163 | + assert(!"Unexpected value of info->type"); | ||
164 | abort(); | ||
165 | break; | ||
166 | |||
167 | diff --git a/sysdeps/linux-gnu/s390/fetch.c b/sysdeps/linux-gnu/s390/fetch.c | ||
168 | index 4ad5951..4721c30 100644 | ||
169 | --- a/sysdeps/linux-gnu/s390/fetch.c | ||
170 | +++ b/sysdeps/linux-gnu/s390/fetch.c | ||
171 | @@ -266,7 +266,7 @@ arch_fetch_arg_next(struct fetch_context *ctx, enum tof type, | ||
172 | return allocate_gpr(ctx, proc, info, valuep, sz); | ||
173 | |||
174 | default: | ||
175 | - assert(info->type != info->type); | ||
176 | + assert(!"Unexpected value of info->type"); | ||
177 | abort(); | ||
178 | } | ||
179 | return -1; | ||
180 | diff --git a/sysdeps/linux-gnu/s390/trace.c b/sysdeps/linux-gnu/s390/trace.c | ||
181 | index 78b04c3..24f7801 100644 | ||
182 | --- a/sysdeps/linux-gnu/s390/trace.c | ||
183 | +++ b/sysdeps/linux-gnu/s390/trace.c | ||
184 | @@ -213,7 +213,7 @@ arch_type_sizeof(struct process *proc, struct arg_type_info *info) | ||
185 | return (size_t)-2; | ||
186 | |||
187 | default: | ||
188 | - assert(info->type != info->type); | ||
189 | + assert(!"Unexpected value of info->type"); | ||
190 | abort(); | ||
191 | } | ||
192 | } | ||
193 | @@ -226,7 +226,7 @@ arch_type_alignof(struct process *proc, struct arg_type_info *info) | ||
194 | |||
195 | switch (info->type) { | ||
196 | default: | ||
197 | - assert(info->type != info->type); | ||
198 | + assert(!"Unexpected value of info->type"); | ||
199 | break; | ||
200 | |||
201 | case ARGTYPE_CHAR: | ||
202 | diff --git a/sysdeps/linux-gnu/x86/fetch.c b/sysdeps/linux-gnu/x86/fetch.c | ||
203 | index 6868101..ae2ed79 100644 | ||
204 | --- a/sysdeps/linux-gnu/x86/fetch.c | ||
205 | +++ b/sysdeps/linux-gnu/x86/fetch.c | ||
206 | @@ -523,7 +523,7 @@ classify(struct process *proc, struct fetch_context *context, | ||
207 | |||
208 | default: | ||
209 | /* Unsupported type. */ | ||
210 | - assert(info->type != info->type); | ||
211 | + assert(!"Unexpected value of info->type"); | ||
212 | abort(); | ||
213 | } | ||
214 | abort(); | ||
215 | diff --git a/sysdeps/linux-gnu/x86/trace.c b/sysdeps/linux-gnu/x86/trace.c | ||
216 | index 6a1a6a5..d8d2115 100644 | ||
217 | --- a/sysdeps/linux-gnu/x86/trace.c | ||
218 | +++ b/sysdeps/linux-gnu/x86/trace.c | ||
219 | @@ -145,7 +145,7 @@ arch_type_sizeof(struct process *proc, struct arg_type_info *info) | ||
220 | return (size_t)-2; | ||
221 | |||
222 | default: | ||
223 | - assert(info->type != info->type); | ||
224 | + assert(!"Unexpected value of info->type"); | ||
225 | abort(); | ||
226 | } | ||
227 | } | ||
228 | @@ -158,7 +158,7 @@ arch_type_alignof(struct process *proc, struct arg_type_info *info) | ||
229 | |||
230 | switch (info->type) { | ||
231 | default: | ||
232 | - assert(info->type != info->type); | ||
233 | + assert(!"Unexpected value of info->type"); | ||
234 | abort(); | ||
235 | break; | ||
236 | |||
237 | diff --git a/value.c b/value.c | ||
238 | index 2125ba9..30edb4e 100644 | ||
239 | --- a/value.c | ||
240 | +++ b/value.c | ||
241 | @@ -363,7 +363,7 @@ value_set_word(struct value *value, long word) | ||
242 | u.u64 = word; | ||
243 | break; | ||
244 | default: | ||
245 | - assert(sz != sz); | ||
246 | + assert(!"Unexpected value of sz"); | ||
247 | abort(); | ||
248 | } | ||
249 | |||
250 | @@ -414,7 +414,7 @@ value_extract_word(struct value *value, long *retp, | ||
251 | *retp = (long)u.u64; | ||
252 | return 0; | ||
253 | default: | ||
254 | - assert(sz != sz); | ||
255 | + assert(!"Unexpected value of sz"); | ||
256 | abort(); | ||
257 | } | ||
258 | } | ||
259 | -- | ||
260 | 2.12.0 | ||
261 | |||
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb index 60af5425ea..213436c769 100644 --- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb +++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb | |||
@@ -21,6 +21,7 @@ SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \ | |||
21 | file://0001-Use-correct-enum-type.patch \ | 21 | file://0001-Use-correct-enum-type.patch \ |
22 | file://0002-Fix-const-qualifier-error.patch \ | 22 | file://0002-Fix-const-qualifier-error.patch \ |
23 | file://0001-ARM-code-has-unreachable-code-after-switch-statement.patch \ | 23 | file://0001-ARM-code-has-unreachable-code-after-switch-statement.patch \ |
24 | file://0001-Fix-tautological-compare-warning.patch \ | ||
24 | " | 25 | " |
25 | S = "${WORKDIR}/git" | 26 | S = "${WORKDIR}/git" |
26 | 27 | ||